WordPress.org

Ready to get started?Download WordPress

Forums

Looking for an image plugin where i can pull images directly off my deskop (12 posts)

  1. spark12
    Member
    Posted 9 years ago #

    I am trying to find an image plugin where i can just pull images off my desktop and into the blog, without it having to be ftp'd to a root folder first. Are there any plugin's that do that?

  2. Cypher
    Member
    Posted 9 years ago #

    To make images available on your blog, you're going to have to FTP it to the site. You can use an offline blogging tool like Ecto, w.bloggar and so on to upload your images as well as publish your posts.

    If a plugin was to be made, it would only allow you to FTP images to your host.

    Regards

  3. Spark12, go to Options/Miscellaneous and select "Allow File Uploads". Now, just go to the new Upload tab and enjoy.

  4. spark12
    Member
    Posted 9 years ago #

    I set it to "Allow File Uploads" and went to the upload tab and it said "It doesn't look like you can use the file upload feature at this time because the directory you have specified (....) doesn't appear to be writable by wordpress." I double checked to make sure my path was correct in the Options/Miscellaneous tab and it was. I also checked the info on the folder i am trying to use and the Attributes and Access/Type options all had check marks next to them, so i seem to have the permissions set right. And i know i'm spelling everything right. Any ideas? Thanks.

  5. Set the permissions of that directory to 777 (CHMOD 777). More info: http://www.tamba2.org.uk/wordpress/ftp/chmod/index.html

  6. goochiegirl
    Member
    Posted 9 years ago #

    I am having the same problem as spark12. When I go to my cpanel's file manager, I select "change file permissions" and change it from 755 to 777, and when I hit "change", it simply goes back to 755. My webhost doesn't allow anonymous logins to my FTP, and so it's possible they won't allow permissions to be changed? Is this pretty standard?

  7. It sounds like your webhost doesn't allow anything to be set to 777. Have you contacted your webhost?

  8. Glo
    Member
    Posted 9 years ago #

    If you just typed 777 into the number field in cpanel instead of unchecking the boxes until the numbers changed, it will return to the default 755 when you try to save it. You have to uncheck the appropriate boxes and then save it.

  9. goochiegirl
    Member
    Posted 9 years ago #

    Done!

  10. divva
    Member
    Posted 7 years ago #

    777 is a very insecure permission. Everyone can Read, Write AND Execute. Is this "surf safe"? Am I going to regret this later?

  11. vkaryl
    Member
    Posted 7 years ago #

    It's NOT a good idea.

  12. DianeV
    Member
    Posted 7 years ago #

    Ditto. However, the latest versions of WordPress make it easy to upload images directly from your desktop for use in posts --- and make it easy to link to them as well.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.