WordPress.org

Ready to get started?Download WordPress

Forums

Logout Out Error (3 posts)

  1. Nieceye
    Member
    Posted 7 years ago #

    I just installed WP Grins and I added custom smileys therefore I had to edit wp-config.php. As a result after I try to log out of my wordpress I got this error:

    Warning: Cannot modify header information - headers already sent by (output started at /home/xblaque/public_html/herint/wp/wp-config.php:63) in /home/xblaque/public_html/herint/wp/wp-login.php on line 12

    Warning: Cannot modify header information - headers already sent by (output started at /home/xblaque/public_html/herint/wp/wp-config.php:63) in /home/xblaque/public_html/herint/wp/wp-includes/pluggable.php on line 325

    Warning: Cannot modify header information - headers already sent by (output started at /home/xblaque/public_html/herint/wp/wp-config.php:63) in /home/xblaque/public_html/herint/wp/wp-includes/pluggable.php on line 326

    Warning: Cannot modify header information - headers already sent by (output started at /home/xblaque/public_html/herint/wp/wp-config.php:63) in /home/xblaque/public_html/herint/wp/wp-includes/pluggable.php on line 327

    Warning: Cannot modify header information - headers already sent by (output started at /home/xblaque/public_html/herint/wp/wp-config.php:63) in /home/xblaque/public_html/herint/wp/wp-includes/pluggable.php on line 328

    Warning: Cannot modify header information - headers already sent by (output started at /home/xblaque/public_html/herint/wp/wp-config.php:63) in /home/xblaque/public_html/herint/wp/wp-includes/pluggable.php on line 275

    Any ideas how to fix it?

  2. Nieceye
    Member
    Posted 7 years ago #

    Also heres a copy of my wp-config.php:

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'xblaque_wrdp1'); // The name of the database
    define('DB_USER', 'xblaque_wrdp1'); // Your MySQL username
    define('DB_PASSWORD', 'rj2D6dmKtz3m'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value

    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = 'wp_'; // Only numbers, letters, and underscores please!

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');

    /* That's all, stop editing! Happy blogging. */

    define('ABSPATH', dirname(__FILE__).'/');
    $wpsmiliestrans = array(
    ' :)' => 'smile.gif',
    ' :angry:' => 'angry.gif',
    ':cheer:' => 'cheer.gif',
    ':biggrin:' => 'biggrin.gif',
    ':doze:' => 'doze.gif',
    ':sad:' => 'sad.gif',
    ':shock:' => 'shock.gif',
    ':hmm:' => 'hmm.gif',
    ':neutral:' => 'blank.gif',
    ':cry:' => 'cry.gif',
    ' :tongue:' => 'tongue.gif',
    ':evil:' => 'evil.gif',
    ':dead:' => 'dead.gif',
    ':crazy:' => 'crazy.gif',
    ':wink:' => 'wink.gif',
    ':blush:' => 'blush.gif',
    ':music:' => 'music.gif',
    ':annoyed:' => 'annoyed.gif',
    ':yuck:' => 'yuck.gif',
    ':kiss:' => 'kiss.gif',
    ':satisfied:' => 'satisfied.gif',
    ':depressed:' => 'depressed.gif',
    ':blank:' => 'blank.gif',
    ':glare:' => 'glare.gif',
    ':confused:' => 'confused.gif',
    ':happytear:' => 'happytear.gif',
    ':cynical:' => 'cynical.gif',
    ':cool:' => 'cool.gif',
    ':lol:' => 'lol.gif',
    ':rolleyes:' => 'rolleyes.gif',
    ':smile2:' => 'smile2.gif',
    ':stfu:' => 'stfu.gif',
    ':cunt:' => 'un.gif',
    ':yomama:' => 'yomama.gif',
    ':bitch:' => 'tch.gif',
    ':dumbass:' => 'dumbass.gif',
    ':foff:' => 'ckoff.gif',
    ':urwack:' => 'urwack.gif',
    ':cunt:' => 'c.gif',
    ':omyd:' => 'offmy.gif'
    );
    require_once(ABSPATH.'wp-settings.php');
    ?>

    Also I test out my comments and I got this error:

    Warning: Cannot modify header information - headers already sent by (output started at /home/xblaque/public_html/herint/wp/wp-config.php:63) in /home/xblaque/public_html/herint/wp/wp-includes/pluggable.php on line 275

  3. Nieceye
    Member
    Posted 7 years ago #

    Nevermind. I fixed it. I should have been adding the smilies to vars.php instead of wp-config.php. Some bogus tutorial had it wrong and it was causing me to get an error.

Topic Closed

This topic has been closed to new replies.

About this Topic