WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] logout from admin dashboard sends to 404 error page (27 posts)

  1. Barnez
    Member
    Posted 11 months ago #

    Hi,
    I have just started to have problems logging out of the wordpress dashboard. Selecting 'Log Out' sends me to the 404 error page, and does not log me out of the dashboard (a second logout is successful). I have tried disabling all the plugins and switching to the Twenty Thirteen theme but the problem remains. I've also checked and reset the file permissions for the wp-content, wp-admin and wp-includes folders, all are set to 755.

    Another issue is that logging in is either slower than usual, or twice has routed me straight back to the login page, or on one occassion I've received the following message from my browser:

    The page isn't redirecting properly
    Firefox has detected that the server is redirecting the request for this
    address in a way that will never complete.

    Any ideas??

  2. esmi
    Forum Moderator
    Posted 11 months ago #

    Can you replicate the problem using the default Twenty Thirteen theme with all plugins deactivated?

  3. Barnez
    Member
    Posted 11 months ago #

    Yes. With Twenty Thirteen active and all the plugins disabled it still sends me to the 404 error page on log out

  4. esmi
    Forum Moderator
    Posted 11 months ago #

    Site url?

    What is in your root .htaccess file?

  5. Barnez
    Member
    Posted 11 months ago #

    Thanks for getting back esmi.

    The site url is http://www.proofscience.com/

    The root htaccess contains the following:

    # STRONG HTACCESS PROTECTION</code>
    <Files ~ "^.*\.([Hh][Tt][Aa])">
    order allow,deny
    deny from all
    satisfy all
    </Files>
    Options +FollowSymlinks
    
    # disable directory browsing
    Options All -Indexes
    
    # protect wp-config.php
    <files wp-config.php>
    Order deny,allow
    Deny from all
    </files>
    
    # protect from sql injection
    Options +FollowSymLinks
    RewriteEngine On
    RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
    RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
    RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
    RewriteRule ^(.*)$ index.php [F,L]
    
    # BEGIN Expire headers
    <ifModule mod_expires.c>
        ExpiresActive On
        ExpiresDefault "access plus 5 seconds"
        ExpiresByType image/x-icon "access plus 2592000 seconds"
        ExpiresByType image/jpeg "access plus 2592000 seconds"
        ExpiresByType image/png "access plus 2592000 seconds"
        ExpiresByType image/gif "access plus 2592000 seconds"
        ExpiresByType application/x-shockwave-flash "access plus 2592000 seconds"
        ExpiresByType text/css "access plus 604800 seconds"
        ExpiresByType text/javascript "access plus 648000 seconds"
        ExpiresByType application/javascript "access plus 648000 seconds"
        ExpiresByType application/x-javascript "access plus 648000 seconds"
        ExpiresByType text/html "access plus 600 seconds"
        ExpiresByType application/xhtml+xml "access plus 600 seconds"
    </ifModule>
    # END Expire headers
    
    # BEGIN WPSuperCache
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    #If you serve pages from behind a proxy you may want to change 'RewriteCond %{HTTPS} on' to something more sensible
    AddDefaultCharset UTF-8
    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
    RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP_USER_AGENT} !^.*(2.0\ MMP|240x320|400X240|AvantGo|BlackBerry|Blazer|Cellphone|Danger|DoCoMo|Elaine/3.0|EudoraWeb|Googlebot-Mobile|hiptop|IEMobile|KYOCERA/WX310K|LG/U990|MIDP-2.|MMEF20|MOT-V|NetFront|Newt|Nintendo\ Wii|Nitro|Nokia|Opera\ Mini|Palm|PlayStation\ Portable|portalmmm|Proxinet|ProxiNet|SHARP-TQ-GX10|SHG-i900|Small|SonyEricsson|Symbian\ OS|SymbianOS|TS21i-10|UP.Browser|UP.Link|webOS|Windows\ CE|WinWAP|YahooSeeker/M1A1-R2D2|iPhone|iPod|Android|BlackBerry9530|LG-TU915\ Obigo|LGE\ VX|webOS|Nokia5800).* [NC]
    RewriteCond %{HTTP_user_agent} !^(w3c\ |w3c-|acs-|alav|alca|amoi|audi|avan|benq|bird|blac|blaz|brew|cell|cldc|cmd-|dang|doco|eric|hipt|htc_|inno|ipaq|ipod|jigs|kddi|keji|leno|lg-c|lg-d|lg-g|lge-|lg/u|maui|maxo|midp|mits|mmef|mobi|mot-|moto|mwbp|nec-|newt|noki|palm|pana|pant|phil|play|port|prox|qwap|sage|sams|sany|sch-|sec-|send|seri|sgh-|shar|sie-|siem|smal|smar|sony|sph-|symb|t-mo|teli|tim-|tosh|tsm-|upg1|upsi|vk-v|voda|wap-|wapa|wapi|wapp|wapr|webc|winw|winw|xda\ |xda-).* [NC]
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteCond %{HTTPS} on
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{SERVER_NAME}/$1/index-https.html.gz -f
    RewriteRule ^(.*) "/wp-content/cache/supercache/%{SERVER_NAME}/$1/index-https.html.gz" [L]
    
    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
    RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP_USER_AGENT} !^.*(2.0\ MMP|240x320|400X240|AvantGo|BlackBerry|Blazer|Cellphone|Danger|DoCoMo|Elaine/3.0|EudoraWeb|Googlebot-Mobile|hiptop|IEMobile|KYOCERA/WX310K|LG/U990|MIDP-2.|MMEF20|MOT-V|NetFront|Newt|Nintendo\ Wii|Nitro|Nokia|Opera\ Mini|Palm|PlayStation\ Portable|portalmmm|Proxinet|ProxiNet|SHARP-TQ-GX10|SHG-i900|Small|SonyEricsson|Symbian\ OS|SymbianOS|TS21i-10|UP.Browser|UP.Link|webOS|Windows\ CE|WinWAP|YahooSeeker/M1A1-R2D2|iPhone|iPod|Android|BlackBerry9530|LG-TU915\ Obigo|LGE\ VX|webOS|Nokia5800).* [NC]
    RewriteCond %{HTTP_user_agent} !^(w3c\ |w3c-|acs-|alav|alca|amoi|audi|avan|benq|bird|blac|blaz|brew|cell|cldc|cmd-|dang|doco|eric|hipt|htc_|inno|ipaq|ipod|jigs|kddi|keji|leno|lg-c|lg-d|lg-g|lge-|lg/u|maui|maxo|midp|mits|mmef|mobi|mot-|moto|mwbp|nec-|newt|noki|palm|pana|pant|phil|play|port|prox|qwap|sage|sams|sany|sch-|sec-|send|seri|sgh-|shar|sie-|siem|smal|smar|sony|sph-|symb|t-mo|teli|tim-|tosh|tsm-|upg1|upsi|vk-v|voda|wap-|wapa|wapi|wapp|wapr|webc|winw|winw|xda\ |xda-).* [NC]
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteCond %{HTTPS} !on
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{SERVER_NAME}/$1/index.html.gz -f
    RewriteRule ^(.*) "/wp-content/cache/supercache/%{SERVER_NAME}/$1/index.html.gz" [L]
    
    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
    RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP_USER_AGENT} !^.*(2.0\ MMP|240x320|400X240|AvantGo|BlackBerry|Blazer|Cellphone|Danger|DoCoMo|Elaine/3.0|EudoraWeb|Googlebot-Mobile|hiptop|IEMobile|KYOCERA/WX310K|LG/U990|MIDP-2.|MMEF20|MOT-V|NetFront|Newt|Nintendo\ Wii|Nitro|Nokia|Opera\ Mini|Palm|PlayStation\ Portable|portalmmm|Proxinet|ProxiNet|SHARP-TQ-GX10|SHG-i900|Small|SonyEricsson|Symbian\ OS|SymbianOS|TS21i-10|UP.Browser|UP.Link|webOS|Windows\ CE|WinWAP|YahooSeeker/M1A1-R2D2|iPhone|iPod|Android|BlackBerry9530|LG-TU915\ Obigo|LGE\ VX|webOS|Nokia5800).* [NC]
    RewriteCond %{HTTP_user_agent} !^(w3c\ |w3c-|acs-|alav|alca|amoi|audi|avan|benq|bird|blac|blaz|brew|cell|cldc|cmd-|dang|doco|eric|hipt|htc_|inno|ipaq|ipod|jigs|kddi|keji|leno|lg-c|lg-d|lg-g|lge-|lg/u|maui|maxo|midp|mits|mmef|mobi|mot-|moto|mwbp|nec-|newt|noki|palm|pana|pant|phil|play|port|prox|qwap|sage|sams|sany|sch-|sec-|send|seri|sgh-|shar|sie-|siem|smal|smar|sony|sph-|symb|t-mo|teli|tim-|tosh|tsm-|upg1|upsi|vk-v|voda|wap-|wapa|wapi|wapp|wapr|webc|winw|winw|xda\ |xda-).* [NC]
    RewriteCond %{HTTPS} on
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{SERVER_NAME}/$1/index-https.html -f
    RewriteRule ^(.*) "/wp-content/cache/supercache/%{SERVER_NAME}/$1/index-https.html" [L]
    
    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
    RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP_USER_AGENT} !^.*(2.0\ MMP|240x320|400X240|AvantGo|BlackBerry|Blazer|Cellphone|Danger|DoCoMo|Elaine/3.0|EudoraWeb|Googlebot-Mobile|hiptop|IEMobile|KYOCERA/WX310K|LG/U990|MIDP-2.|MMEF20|MOT-V|NetFront|Newt|Nintendo\ Wii|Nitro|Nokia|Opera\ Mini|Palm|PlayStation\ Portable|portalmmm|Proxinet|ProxiNet|SHARP-TQ-GX10|SHG-i900|Small|SonyEricsson|Symbian\ OS|SymbianOS|TS21i-10|UP.Browser|UP.Link|webOS|Windows\ CE|WinWAP|YahooSeeker/M1A1-R2D2|iPhone|iPod|Android|BlackBerry9530|LG-TU915\ Obigo|LGE\ VX|webOS|Nokia5800).* [NC]
    RewriteCond %{HTTP_user_agent} !^(w3c\ |w3c-|acs-|alav|alca|amoi|audi|avan|benq|bird|blac|blaz|brew|cell|cldc|cmd-|dang|doco|eric|hipt|htc_|inno|ipaq|ipod|jigs|kddi|keji|leno|lg-c|lg-d|lg-g|lge-|lg/u|maui|maxo|midp|mits|mmef|mobi|mot-|moto|mwbp|nec-|newt|noki|palm|pana|pant|phil|play|port|prox|qwap|sage|sams|sany|sch-|sec-|send|seri|sgh-|shar|sie-|siem|smal|smar|sony|sph-|symb|t-mo|teli|tim-|tosh|tsm-|upg1|upsi|vk-v|voda|wap-|wapa|wapi|wapp|wapr|webc|winw|winw|xda\ |xda-).* [NC]
    RewriteCond %{HTTPS} !on
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{SERVER_NAME}/$1/index.html -f
    RewriteRule ^(.*) "/wp-content/cache/supercache/%{SERVER_NAME}/$1/index.html" [L]
    </IfModule>
    
    # END WPSuperCache
    
    #Gzip
    <ifmodule mod_deflate.c>
    AddOutputFilterByType DEFLATE text/text text/html text/plain text/xml text/css application/x- javascript application/javascript
    </ifmodule>
    #End Gzip
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    
    RewriteCond %{HTTP_REFERER} !^http://proofscience.com/.*$      [NC]
    RewriteCond %{HTTP_REFERER} !^http://proofscience.com$      [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.proofscience.com/.*$      [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.proofscience.com$      [NC]
    RewriteRule .*\.(jpg|jpeg|gif|png|bmp)$ - [F,NC]
  6. esmi
    Forum Moderator
    Posted 11 months ago #

    Have you tried resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    Also do ensure that you turn off your caching plugin correctly and empty the cache.

  7. Barnez
    Member
    Posted 11 months ago #

    Thanks for the suggestion. I have just reset the plugins folder through FTP, and ensured that the plugin cache was cleared. The issue still remains through.

    I'm not sure if this is related, but I can see high CPU use in the Resources Usage details in cPanel. There are peaks of 100% there over a 24 hr period, even through the site sees only moderate traffic.

  8. esmi
    Forum Moderator
    Posted 11 months ago #

    Your site is still cached.

    <!-- Dynamic page generated in 0.669 seconds. -->
    <!-- Cached page generated by WP-Super-Cache on 2013-09-11 19:40:12 -->

    <!-- Compression = gzip -->

  9. Barnez
    Member
    Posted 11 months ago #

    Sorry. That was a misunderstanding.

    Now the cache has been emptied and the caching plugin is turned off. Also, the gzip code has been removed from the root htaccess file.

  10. esmi
    Forum Moderator
    Posted 11 months ago #

    You still have active plugins. Can you please

    - switch to the default 2013 theme/

    - reset the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  11. Barnez
    Member
    Posted 11 months ago #

    Now switched to the 2013 theme and plugins folder reset to plugins.hold

    Log out takes me to the 2013 theme's 404 page

  12. esmi
    Forum Moderator
    Posted 11 months ago #

    Your site is not using the 2013 theme and you still have active plugins.

  13. Barnez
    Member
    Posted 11 months ago #

    I can't explain that esmi. I am logged in, and the 2013 theme is active and I can see the theme when I visit the site. Also, the plugins folder is set to plugins.hold through FTP, and no plugins are visible in the Dashboard.

  14. Barnez
    Member
    Posted 11 months ago #

    Is it possible that the issue is being highlighted by the discreprancy between what I see from the backend and what you are viewing in regard to the theme and live plugins?

  15. esmi
    Forum Moderator
    Posted 11 months ago #

    I have been looking at a fresh copy of your site each time. Perhaps your hosts run a web cache? Have you ever asked them about this?

    I can now see the site using 2013 and there no longer appear to be any active plugins. Without changing anything, try logging out of your site now.

  16. Barnez
    Member
    Posted 11 months ago #

    I haven't spoken to the hosts about their use of web cache so couldn't comment there.

    Without changing anything, with the 2013 theme still enabled and no plugins active, the problem still remains the same.

  17. Barnez
    Member
    Posted 11 months ago #

    Have updated to WordPress 3.6.1 but this hasn't solved the issue. The site is back running its normal theme and plugins, as it seems that any theme/plugins conflict has been ruled out.

    Does this mean, by process of elimination, that the issue is with the core WordPress files?

  18. esmi
    Forum Moderator
    Posted 11 months ago #

    No. This sounds like a server issue. Have you spoken to your hosts about it?

  19. Barnez
    Member
    Posted 11 months ago #

    I see. I will get on to my hosts and see what they come back with. Many thanks for your support and advice.

  20. esmi
    Forum Moderator
    Posted 11 months ago #

    No problem. Do come back if you're still having problems and we can have another go at it.

  21. Barnez
    Member
    Posted 11 months ago #

    Will do. Thanks esmi.

  22. Barnez
    Member
    Posted 11 months ago #

    I contacted my hosting company, and there are no known issues on the server, and a double check on the error logs in cPanel shows no errors that would indicate a server issue. They suggested looking into WordPress as the origin of the issue, and so the ball is back in my court.

  23. Barnez
    Member
    Posted 11 months ago #

    I'm still trying to resolve this issue. In the last week I have had the site deep scanned for malware, replaced all the WordPress files, installed fresh plugins, reinstalled the theme, and reset the .htaccess file. Still getting redirected to the error 404 page on log out, the occasional return back to the login page after trying to log in, and seeing high cpu usage.

    I'm wondering of the next best step is to reset the database using wordpress reset, or to manually delete the database and create a new one using the same database prefix and username.

  24. esmi
    Forum Moderator
    Posted 11 months ago #

    Try a fresh install with a fresh database in a sub-folder and see if you have the same issues.

  25. Barnez
    Member
    Posted 11 months ago #

    I installed a new database, and uploaded a fresh copy of wordpress to a sub-folder /test/ . However, the log in/out issue is the same. Some logins in /test/ lead to the following message:

    The page isn't redirecting properly
    Firefox has detected that the server is redirecting the
    request for this address in a way that will never complete

    And all log outs from the /test/ dashboard lead to the 404 error page:
    http://www.proofscience.com/test/wp-login.php?action=logout&_wpnonce=89dd0c59cd

    The only change I can see as a result of running the new database and wp from the sub-folder is that the cpu usage levels have dropped when working in the dashboard (creating/saving posts & pages) from 0-100% for the main site and original database, to 0-50% in the /test/ site with the new database.

    While this may please my host if I go ahead and create a new database, the 404 error remains a mystery.

  26. Barnez
    Member
    Posted 10 months ago #

    Am still seeing the 404 error on log out.

    Have recently tried logging into the dashboard through an Ipad with the Safari browser. The first login attempt takes me back to the login page, but the second attempt takes me to the dashboard. Logging out is fine every time.

    Does this mean the issue is browser related? (The 404 error is repeated in Firefox, Chrome and Internet Explorer)

    Also, one thread here discussing log out issues suggests setting zlib.output_compression=on (on) in the ini.php . I don't have access to the ini.php but could ask my host to make the change. Could this be an avenue to explore?

  27. Barnez
    Member
    Posted 10 months ago #

    This issue is now resolved. The update from WordPress 3.6.1 to 3.7 has repaired the logout issue.

Reply

You must log in to post.

About this Topic