WordPress.org

Ready to get started?Download WordPress

Forums

A5 Custom Login Page
[resolved] Logo wird nicht angezeigt (9 posts)

  1. Racle
    Member
    Posted 11 months ago #

    Alle funktioniert wunderbar, leider wird mein Logo nicht angezeigt. Der Tag des Bildes ist da, nur keine Grafik. Was kann ich tun?

    Zweite Frage der Container ist nicht Mittig, kann ich das ändern?

    Vielen Dank für Eure Antworten

    http://www.ellernschule.de/wp-login.php

    Try to translate in english :-)

    Verry Good Plugin!! Thanks a lot - But i Cant see my Logo. What is the Problem?

    How can i center the container?

    See here:
    http://www.ellernschule.de/wp-login.php

    Thanks for your answer.

    http://wordpress.org/plugins/custom-login-page/

  2. tepelstreel
    Member
    Plugin Author

    Posted 11 months ago #

    Hi,

    du hast mich da auf einen kleinen Fehler aufmerksam gemacht. Position links solltest du leer lassen und die position sollte relative sein nicht absolute, wie ich das programmiert habe.

    Such bitte im file custom-login-page.php nach der Zeile 1173 und ändere sie von:

    if (!empty(self::$options['logindiv_top']) || !empty(self::$options['logindiv_left']) || self::$options['logindiv_top']=='0' || self::$options['logindiv_left']=='0') $logindiv_style .= $eol.$tab.'position: absolute;';

    in folgendes um:

    if (!empty(self::$options['logindiv_top']) || !empty(self::$options['logindiv_left']) || self::$options['logindiv_top']=='0' || self::$options['logindiv_left']=='0') $logindiv_style .= $eol.$tab.'position: relative;';

    Danke! Ich werde es bei Gelegenheit ändern und eine neue Version zur Verfügung stellen, aber das ist für dich erstmal das schnellste.

    Grüße

  3. tepelstreel
    Member
    Plugin Author

    Posted 11 months ago #

    Und zum Logo kann ich dir nur sagen, die Datei unter der Adresse http://www.ellernschule.de/?attachment_id=91 produziert einen 404. Deshalb auch nicht sichtbar.

  4. esmi
    Forum Moderator
    Posted 11 months ago #

    These are English language forums, so please use English. Alternatively, use a WP support forum in your language.

  5. Racle
    Member
    Posted 11 months ago #

    Hi tepelstreel,

    thanks a lot for your help. The 404 is because i try to select different files (gif, png, etc. ) to solve the problem. the last one i have already delete. Now i insert the correct Link, but i still not see the Logo.

    Your code:
    The Container is now in the center. Thanks! But the Login Box is not in Center of the container.

    Sorry Admin ;-) now again in German:

    Danke für Deine schnelle Hilfe. Hab öfter mal die Dateien gewechselt da ich dachte das Problem liegt an der Grafik. Hatte in der Tat den Link auf eine bereits gelöschte Datei stehen. Habs aber nun korrigiert aber die Grafik ist noch immer nicht sichtbar. Wodran kann das denn noch liegen?

    Bzgl. Deines Codes:
    Klappt wunderbar, die Eingabemaske ist nun zentriert. Aber die Loginbog ist nicht Zentriert, sondern ein wenig nach rechts gerückt. Kann ich das auch noch irgendwie ändern?

    Thanks a lot for your answer!

  6. tepelstreel
    Member
    Plugin Author

    Posted 11 months ago #

    @esmi Sorry for that one. Just was answering and planned a translation later on.

    you made me alert that there is a small mistake in deed. Position left should be empty and the position should be relative and not absolute, how I programmed it.

    Please search in the file custom-login-page.php line 1173 change it from:

    if (!empty(self::$options['logindiv_top']) || !empty(self::$options['logindiv_left']) || self::$options['logindiv_top']=='0' || self::$options['logindiv_left']=='0') $logindiv_style .= $eol.$tab.'position: absolute;';

    to:

    if (!empty(self::$options['logindiv_top']) || !empty(self::$options['logindiv_left']) || self::$options['logindiv_top']=='0' || self::$options['logindiv_left']=='0') $logindiv_style .= $eol.$tab.'position: relative;';

    Cheers! I will change it when having time and put a new version to the repository, but that one is the fastest for the time being.

    And about the disappeared logo, I just can say that the file under http://www.ellernschule.de/?attachment_id=91 is missing and therefore produces a 404. That's why it's invisible.

  7. tepelstreel
    Member
    Plugin Author

    Posted 11 months ago #

    And now @Racle again.


    http://blog.atelier-fuenf.de/wp-login.php
    http://wasistlos.waldemarstoffel.com/wp-login.php
    http://esc-blogg.atelier-fuenf.de/wp-login.php
    http://yritys-test.waldemarstoffel.com/wp-login.php

    These are links to either live or test environments of mine. As you can see, all of them show the logo. If you don't see a logo on those sites either, there might be some issue with your browser settings. Changing the permalink structure of your installation might help as well. Sorry for not being able to help further on that one.

    I will report on the input fields as soon as I find something.

    Cheers!

  8. tepelstreel
    Member
    Plugin Author

    Posted 11 months ago #

    Hi there again. You'll have to go to the settings of the Login Form and change the input field for the Margin to 0.

    That should do the job with the Login Box. If not, you just have discovered another bug ;)

  9. Racle
    Member
    Posted 11 months ago #

    Hi tepelstreel,

    the solution of the logo was the permalink. I change the link and it works. Thanks a lot!

    But the input field for the margin is blank and the input box isnt in center of the container.

    it makes me feel uncomfortable may i in fact discovered anothe bug? ;-)

    I try to work with the following: 0px 0px 0px 0px than the input box is from the left to the right magin of the container.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.