WordPress.org

Ready to get started?Download WordPress

Forums

Logins Still Hang to Blank Page - What I've Tried (25 posts)

  1. Catherine_B
    Member
    Posted 4 years ago #

    Greetings -

    I've spent countless hours this week and tried everything possible I can. Can anyone please help?

    Running WordPress 2.8.4 on godaddy, Linux, PHP 5+

    HISTORY:

    - Blog was working fine before this
    - Needed to move blog to a new server
    - Backed up database
    - Installed fresh wp files via godaddy (files automatically installed)
    - Preserved new fresh wp-config file with new database name
    - Restored database 'into' new database (worked fine)
    - Copied all other former files over 'but for' the former wp-config file

    [I have done the above three times now]

    Newly relocated blog populated and looks and is working fine.

    http://mountainridgerealtyga.com/

    PROBLEM NOW: The login page hangs on a BLANK PAGE after entering login and password so no one can log in.

    - Worked fine on other server before the move
    - Worked fine on a 'practice install' on another directory
    - Same problem on IE and Firefox
    - Browser caches and cookies emptied repeatedly
    - Did a Comodo system cleanup to ensure cache fully empty
    - Reinstalled 2 times (so 3 times total); all have same problem
    - Deactivated (renamed) plugin directory (all were current)
    - Confirmed by phpMyAdmin database table that urls, username are correct
    - Reset password and replaced appropriate MD5 encoded pw
    - Replaced wp_login file with fresh untouched version (same file size)
    - Moved .htaccess file, didn't work, so put it back
    - Confirmed no extra blank lines at end of functions.php file
    - Tried logging out with the longer manual logout string
    - Requesting new passwords do not resolve the issue

  2. Samuel B
    moderator
    Posted 4 years ago #

    wow - looks like you about covered it
    blank pages are indicative of php problems
    might try to turn on php error report ing for that file

    also, for the hec of it - see if it's running out of php memory
    add this to your wp-config.php

    define('WP_MEMORY_LIMIT', '128M');

  3. Member111
    Member
    Posted 4 years ago #

    Hi,

    The same thing has happened to me except that I didn't move hosts.

    I increased my memory limit too. You have mentioned a php error, so how would I check that?

  4. Samuel B
    moderator
    Posted 4 years ago #

    http://www.bradino.com/php/error-reporting/
    basically put the code in the file you want to test

  5. Member111
    Member
    Posted 4 years ago #

    I am a newbie to php coding, should I put this in login.php?

  6. Samuel B
    moderator
    Posted 4 years ago #

    wp-login.php would be a good start

  7. Member111
    Member
    Posted 4 years ago #

    haven't done the php thing yet but

    Warning: Cannot modify header information - headers already sent by (output started at /home/thedeenc/public_html/wp-config.php:36) in /home/thedeenc/public_html/wp-login.php on line 290

    Warning: Cannot modify header information - headers already sent by (output started at /home/thedeenc/public_html/wp-config.php:36) in /home/thedeenc/public_html/wp-login.php on line 302

  8. Samuel B
    moderator
    Posted 4 years ago #

    error is saying
    wp-config.php:
    has a blank line or carriage return at end of file

  9. Catherine_B
    Member
    Posted 4 years ago #

    Hi Samboli -

    Thank you for trying to help!

    I will try those. I looked at the php link you sent and will try that. I'm not very familiar with php.

  10. Member111
    Member
    Posted 4 years ago #

    Okay I put the php thing and this is what i got:

    Notice: Constant ABSPATH already defined in /home/thedeenc/public_html/wp-config.php on line 36

    Strict Standards: Assigning the return value of new by reference is deprecated in /home/thedeenc/public_html/wp-settings.php on line 601

    Strict Standards: Assigning the return value of new by reference is deprecated in /home/thedeenc/public_html/wp-settings.php on line 616

    Strict Standards: Assigning the return value of new by reference is deprecated in /home/thedeenc/public_html/wp-settings.php on line 623

    Strict Standards: Assigning the return value of new by reference is deprecated in /home/thedeenc/public_html/wp-settings.php on line 630

    Strict Standards: Assigning the return value of new by reference is deprecated in /home/thedeenc/public_html/wp-settings.php on line 666

    Thanks.

  11. Member111
    Member
    Posted 4 years ago #

    bump.

  12. Member111
    Member
    Posted 4 years ago #

    The error is still there and I don't know what I am required to do so if anyone knows please post here, thanks.

  13. Samuel B
    moderator
    Posted 4 years ago #

    look at your wp-config.php
    it has a blank line or carriage return at the end
    also, if not present - add the
    ?>
    at the very end after removing spaces

  14. Catherine_B
    Member
    Posted 4 years ago #

    I've been struggling all day and still can't get in. The godaddy hosting team said it's not a server problem.

    I've done another new install to try it again. The newly installed wp-config has an extra blank line + 1 return at the end.

    Of course I can log in 'until' I import the database and/or copy over the files. I did go ahead and take out the 2 blank lines, and can still log in. I added the ?> to the end and can still log in.

    So I'm going to copy over the files (again) and then restore the database (again).

  15. Catherine_B
    Member
    Posted 4 years ago #

    This is almost beyond endurance. I am getting the white screen again!! WHY!!!

    I created a new directory, new database and wordpress install via godaddy. This time I used the same login as the original database. Login worked. Copied over files from before. Used new database wp-config file with new database name. (No extra lines at the bottom.) Login still worked.

    THEN:
    Restored the dabase from the original database. The home page came up: http://thecomputercat.com/3.

    Opened db from phpMyAdmin and changed the 2 url references in options to the new subdirectory location from the original http://mountainridgerealtyga.com url; i.e., 'http://domain.com/3'.

    Got the home page. Tried to log in, got the invalid password error (this happened each time before). Requested a new password. It doesn't work! Login hangs to the WHITE SCREEN!

    WHAT can I check, please - what could it be??? This has been going on since Tuesday; can anyone please tell me what else to check or how to resolve this???

    I was hoping to create a successful install on this test directory to determine what is wrong on the original one. I don't understand how it WORKED on a test directory 2 weeks ago; now I move the real deal and try 5 is it? other reinstalls and EVERY time get that white screen on login!

  16. Member111
    Member
    Posted 4 years ago #

    I took off the blank line. ?. is already there. Still doesn't work.

  17. Samuel B
    moderator
    Posted 4 years ago #

    if either one of you want me to look at it I will.

  18. Member111
    Member
    Posted 4 years ago #

    Thanls. What's the come up? comeuphither one word?

  19. Samuel B
    moderator
    Posted 4 years ago #

    yes

    edit - just got a notice my email server is down temporaily
    if it does not go through, try again in a while

  20. Member111
    Member
    Posted 4 years ago #

    Yep server down.

  21. Member111
    Member
    Posted 4 years ago #

    Please inform us of when server is up again.

    I think wp-supercache is the problem.

    I deleted the plugin but in my wp-content folder there is still a folder called 'cache' and even after deleting it, it reappears.

  22. Samuel B
    moderator
    Posted 4 years ago #

    look in wp-config.php for this line
    define('WP_CACHE', false);
    if yours is true , set to false and test

  23. Catherine_B
    Member
    Posted 4 years ago #

    I will be in touch as well, THANK YOU.

    I think something is clashing in the database. Perhaps I can take out some of the plugins in phpMyAdmin. Perhaps simply renaming the plugins folder is not enough.

    Last time when I moved and it worked, I could disable things in the admin panel, like permalinks, then reenable them. I am wondering if changing the database 'before' restoring is the key.

  24. Samuel B
    moderator
    Posted 4 years ago #

    Resolutions to these problems

    Member111
    had two carriage returns in wp-config.php

    Catherine_B
    her problem was a bit trickier. As you can see from her OP, she did almost everything you would think would work and I repeated most of her steps to verify.
    As it turns out, here premium theme's functions.php had two misplaced carriage returns in the middle of the file. Removing these made the admin side of the site come up.

  25. Member111
    Member
    Posted 4 years ago #

    Thank you!

Topic Closed

This topic has been closed to new replies.

About this Topic