WordPress.org

Ready to get started?Download WordPress

Forums

Login with IE6 impossible... (9 posts)

  1. Anonymous
    Unregistered
    Posted 10 years ago #

    I'ts impossible to login with Internet Explorer 6. It's redirect me after a successful login back to the login page with following URI wp-login.php?redirect_to=%2Fwp-admin%2F. Cleaning cockies and temporary internet files doesn't work. With every other browser (Mozilla, Firefox, Konqueror) the login works. The bug still exist in the final 1.2 release. What is different in WordPress from other login procedures?

  2. badmin
    Member
    Posted 9 years ago #

    Joining in to say I'm experiencing this problem also, using WP 1.5. It's been suggested elsewhere that the cause could be that IE refuses cookies from sites using non-RFC compliant hostnames. But by hostname is RFC-compliant, so this is not the cause for me. Does anyone have any other ideas? I'm surprised a problem as big as this one has existed for so long.

  3. badmin
    Member
    Posted 9 years ago #

    this may be relevant.... my blog site exists as a a subdirectory on my larger site, but I have an individual domain name for the blog. I am using cloaked web forwarding to point any requests for the blog domain to the subdirectory. The cookies that WP sets are defined as having come from the parent site. Could IE be having trouble because its getting confused by the cloaked DNS? Could it be rejecting access to the cookies because it thinks the request is coming from a third party site? I'm not sure how to test for this, or how to correct it if this is the problem.

    PS, sorry for posting to multiple threads about this, but there were several started about this subject already. From now on, I'll limit my discussion to this thread.

  4. Nick Momrik
    Member
    Posted 9 years ago #

    IE doesn't have any idea about your cloaked DNS. Your web server simply sends HTML to your browser. Everything else is done on the server end.

  5. badmin
    Member
    Posted 9 years ago #

    It was just a theory, but I thought that maybe since the cookie is coming through as having been set by the parent domain, IE denies access to the cookie when the request is coming from the blog (the child domain).

    If that's not it, does anyone have another idea? I'd really love to get my blog working on IE.

    thanks!

  6. badmin
    Member
    Posted 9 years ago #

    OK, so here's the update: I haven't solved the IE login problem, but I have verified that it IS caused by my blog's DNS settings.

    I get nowhere trying to login with IE from the cloaked and webforwarded domain:

    http ://www.[cloaked domain]/wp-login.php.

    But I have no trouble whatsoever if I log in from a URL that reflects the actual path for the login page on my webserver:

    http ://www.[parent domain]/[subdirectory]/wp-login.php.

    IE is setting cookies from my blog as if they are coming from the parent domain. But when the same blog tries to access these same cookies, IE steps in the way because it thinks the request is coming from a third-party domain.

    This then, is not a WordPress issue. Like most of my web development headaches, it is an IE issue. But I wonder is anyone able to suggest how to fix it? I guess I need to either:

    1) find a way to set the cookie from the child domain, rather than the parent domain. (preferable, but likely not possible)

    or

    2) find a way to request the cookie from the parent domain -- ideally without using the parent domain in the URL.

    Thanks very much!

  7. sue_mmcxii
    Member
    Posted 9 years ago #

    I'm having this same problem in IE6, NS 7, and Firefox. >:|

  8. c0y0te
    Member
    Posted 9 years ago #

    I had the same problems myself but managed to solve them after some nifty searching the net for a solution :)

    I documented the fix on my blog. Browse to the link below and you will be sorted!

    http://www.avalon5.com/index.php/archives/18

    Feel free to leave any comments or ask any questions. I will do what I can to help.

    c0y0te

  9. frankj
    Blocked
    Posted 7 years ago #

    Hi

    I have found what the issue is with this:

    1) You may have added this site to the "blocked cookie list" - delete it from there
    IE: tools > internet options > privacy > sites > look under managed sites
    If your site is there, delete it

    2) Make sure your browser is accepting cookies for this site
    Between the login and the re-direct to the correct admin page it seems like WP reads
    the cookie, if it ain't there, it will just redirect to the wp-admin page again
    IE: tools > internet options > privacy > sites > in address of website type your
    url with http:// in front and click "allow"

    3) Test by setting your security level to low.
    IE: tools > internet options > privacy > drag lever down to "accept all cookies"

    You may need to apply just 1 or all of them for it to work.

    Hope you get it working & God Bless

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.