WordPress.org

Ready to get started?Download WordPress

Forums

Login trouble: Host may have disabled mail function (6 posts)

  1. Jeremy Bosman
    Member
    Posted 2 years ago #

    Dear WordPress users

    I am using Webmatrix and IIS7.

    I have the following issue.

    I installed a plugin:"new-user-approve" and accidentally denied my own (login) user email address in above plugin menu. I was using Gmail.

    I have tried deactivating all my plugins but this doesn't seem to help.

    When I try to login into WordPress with my Username or Gmail address I get following message:ERROR: The password you entered for the username ******* is incorrect. Lost your password?
    When I go to Lost your password I enter my Username to receive new password. Then I get the message:The e-mail could not be sent.
    Possible reason: your host may have disabled the mail() function...

    I do not know how to solve this! Can someone please assist.

    Thanks in advance
    Best regards
    Jeremy

  2. Brad Markle
    Member
    Posted 2 years ago #

    Hi Jeremy. Do you know if the php mail function is working on your server? You may want to put up a test php script that tries to use the mail function to send you an email.

    This post may also help:

    http://wordpress.org/support/topic/your-host-may-have-disabled-the-mail-function

    Thanks! This worked.

    Just to make it clear for anyone else with the problem:

    Under >Options >General >E-mail Address

    Change the account to "wordpress@yourdomain.com". And make sure you create an actual e-mail/alias account for that address in your domain management tools. I used to have a Gmail address as my account address and I'm guessing maybe that field needs to be filled by something with your domain in it? (And that it doesn't necessarily need to be "webmaster? I'm too lazy to test this.)

  3. Brad Markle
    Member
    Posted 2 years ago #

    Hi Jeremy Bosman, were you able to make any progress on this issue?

  4. Jeremy Bosman
    Member
    Posted 2 years ago #

    Hi Brad, thanks a lot for your help.

    I am new to WordPress so I asked a friend to help me with the test script & the account change but he doesn't have time at the moment.

    At the moment I don't know how to do these things. I probably need a step by step tutorial for this :) Pretty silly, I know.

    Kind regards
    Jeremy

  5. Brad Markle
    Member
    Posted 2 years ago #

    If you're running IIS, it may take a bit more to get the php mail function to work.

    I found this thread that has a suggestion:

    The e-mail could not be sent.

    I understand that this post is very old, but...

    Possible reason: your host may have disabled the mail() function...
    My question is how can I enable it I am hosting the site on a windows 2003 server with IIS 6. Exchange server. Please help.

    PHP on windows requires some extra effort to get SMTP to work. It can be a pain in the ass if you are hosting on your own windows server at home. Open php.ini and find this:

    [mail function]
    ; For Win32 only.
    SMTP = localhost
    smtp_port = 25

    ; For Win32 only.
    ;sendmail_from = me@example.com

    ...and alter the info to reflect the mail account given to you by your isp.

    I got hit with this one today too. Now my site is effectively down.

    Got hit with what? I don't think anyone really knew what you were refering to.

    I m *not* trying to send emails but load my blog into the browser and I get the error message

    A link to your CURRENT WordPress installation may get a response. The one in your profile is dead.

  6. Brad Markle
    Member
    Posted 2 years ago #

    Hi Jeremy. Were you able to take a stab at adjusting your php.ini settings, or do you think you're going to wait on your friend to help you?

    If you get it working, I'm curious to know the solution, so keep us updated!

Topic Closed

This topic has been closed to new replies.

About this Topic