WordPress.org

Ready to get started?Download WordPress

Forums

Login Problems with IE, cookies and web forwarding (8 posts)

  1. davea38
    Member
    Posted 8 years ago #

    Hello

    I have WP 2.0.1 up and running on my personal webspace and am using a Domain name forwarding service to make it easy for people to get to my site. This basically means that WP is run inside a frame which is all well and good, however IE by default is set to block cookies that come from websites setup in this manner.

    So other than telling people to use Firefox or paying for some expensive hosting service is there any way to stop this behaviour?? ie. Can you use the Admin interface without cookies? Maybe just use Session variables (if they exist in PHP)? Or is there a work around for this??

    Any help would be most appreciated!

  2. hotkee
    Member
    Posted 8 years ago #

    I cant help with this, I am having the same problem.

    Its just not wordpress experience this problem.

    I have a laptop and a desktop.

    On the desktop everything works, I have ie7 beta, mozilla and firefox, all work as expected with norton 2005.

    On my laptop, wireless connection to my router with zonealarm, I started experiencing problems about 2 days ago, before that all was ok.

    I did install IE7 on there and this has some buggy things in it which cause authentication failures in outlook express.

    But with wordpress and other blog software, I get the problem of trying to login, it keeps going to login even with correct user/pass. I then place cursor in address bar, press enter and i am logged in.

    The problem persists with all further navigation.

    I have tried ie7, mozilla and firefox all same.

    Also I found that whilst using an online hardware site, it would not recoginize the fact that I selected an item to add to the basket - this happened on the laptop again. On my desktop its all fine.

    so is there a virus going around?
    is it a problem with zonelarm?
    is it a problem with ie7 (which does have lots of known problem its only beta issue)

    i suspect a virus or firewall problem.

  3. jmd4eva
    Member
    Posted 8 years ago #

    It's probably caused by your firewall - referrers need to be enabled by your firewall for wordpress to recognise you.

    Turning your firewall off and then logging in may do it?

    Or look through the options in your firewall to see something about enabling referrers.

  4. davea38
    Member
    Posted 8 years ago #

    I'm 100% my problem is actually with the web forwarding / embedded frame issue rather than being firewall etc based.

    Reasons for this are that if I use the proper URL to login (rather than the easy frame one) the login system works 100% ok.

    Also when using my forwarded address a security alert appears within IE in the bottom right of the window listing blocked cookies that wordpress uses for authentication. This is when the security level set for the Internet zone is Medium (SP2 default)

    If you set the level to Low and reload the site using the forwarded address everything works ok.

    Does anyone kow any workaround I can use to circumvent this behaviour so that people do NOT have to change the security level on their browser and i do not have to spend money on a proper hosting!!!!

  5. hotkee
    Member
    Posted 8 years ago #

    I have tried disabling zonealarm, still no good.

    Desktop with Norton Internet Security 2005,all ok all browsers work.

    On laptop with zonelarm and AVG Antivirus, no good, on trying to login it fails to redirect. Meaning it keeps going back to the login screen.

    Put username/password in and then press Login, goes to login screen.
    Go to the address bar and press enter after url, it logs in.

    Try to post a new post to blog, fails.

    It is the redirect and it is not just IE, it seems to be on Firefox and Mozilla.

    Dont think its firewall, more likely some issue with windows xp???

    I have also cleared the cache onthe web server.

    And problem also presists on other systems like nucleuscms.

  6. hotkee
    Member
    Posted 8 years ago #

    Correct myself and agree with davea38, it does seem more a problem in IE then other browsers.

  7. jmd4eva
    Member
    Posted 8 years ago #

    I had the same problem...

    I now use Firefox to log in, and when I do i disable all the virus programs I have, especially the Internet Security ones as they can restrict referrers.

  8. Wolf_22
    Member
    Posted 7 years ago #

    I too have been battling the same issue as dave38, and just like he said, it works in IE if you lower your security or use the full-version URL.

    Does anyone know of a fix to this!? It's silly to have to use ONLY Firefox or do all these different things to fix this. I've heard that forwarding isn't the same thing as using some sort of "Park server", but I'm not too knowledgable about any of this.

    PLEASE SOMEONE HELP!

Topic Closed

This topic has been closed to new replies.

About this Topic