WordPress.org

Ready to get started?Download WordPress

Forums

Login Problems but a bit more than that? (3 posts)

  1. jayjames
    Member
    Posted 7 months ago #

    Hi Folks,

    Please excuse any vague-ness from this WordPress newbie but for the life of me I can't figure out why I'm having login problems.

    Simply put, I'm a leader of a local scout group and I thought I would put a site together and pretty much present the whole thing to them and bring the group up to the modern age and persuade them to pay for proper hosting. I have previous website building experience and I'm completely self taught when it comes to the likes of HTML & PHP so, speak to me in complete layman's terms instead of any jargon as I probably have different names for things.

    Anyway, I decided to create it as a "local" site here on my mac (Snow Leopard 10.6.8, MAMP 2.2). All is well with the install. I can do everything that I'd expect to do with the admin panel of WordPress.

    The problem I have now found is that once I shutdown either the MAMP software or the mac itself, and then come back and re-launch the server I can not get into the admin panel as the error "ERROR: Cookies are blocked or not supported by your browser. You must enable cookies to use WordPress." is shown. I know that it's not a browser cookie issue as I've now tried getting the admin panel using Chrome, Firefox & Safari.

    As this was somewhat p****** me off I borrowed one of my families windows laptops (win7 64bit, WAMP server) installed wamp and followed the same procedure of setting up wordpress doing nothing different to what I had done on my mac. The admin panel works everytime and even works from all the browsers on the mac too... hence why I know it's not a browser cookie thing.

    I've spent a few hours now going through google trying to figure out whats wrong and what's right and trying the "solutions" that's given in the codex about changing the wp-login.php file etc and nothing still works when it comes to getting it running on the mac.

    The pages that came as default with wordpress all load up great. It's just the admin panel and login.

    I may well have missed something important out but hopefully someone will be kind enough to help me out a bit.

    Thanks for your time and patience.

    Jay

  2. jayjames
    Member
    Posted 7 months ago #

    For what it's worth I've been digging around a little more and found the following post: http://wordpress.org/support/topic/localhost-cant-log-in-to-admin?replies=10

    I turned on debugging as shown in the above linked post and this is what I get from the php_error.log:

    [12-Dec-2013 16:20:54 UTC] PHP Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /Applications/MAMP/htdocs/wp-includes/wp-db.php on line 1142
    [12-Dec-2013 16:20:54 UTC] PHP Warning: Cannot modify header information - headers already sent by (output started at /Applications/MAMP/htdocs/wp-includes/wp-db.php:1142) in /Applications/MAMP/htdocs/wp-login.php on line 412
    [12-Dec-2013 16:20:54 UTC] PHP Warning: Cannot modify header information - headers already sent by (output started at /Applications/MAMP/htdocs/wp-includes/wp-db.php:1142) in /Applications/MAMP/htdocs/wp-login.php on line 424
    [12-Dec-2013 16:22:37 UTC] PHP Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /Applications/MAMP/htdocs/wp-includes/wp-db.php on line 1142
    [12-Dec-2013 16:22:37 UTC] PHP Warning: Cannot modify header information - headers already sent by (output started at /Applications/MAMP/htdocs/wp-includes/wp-db.php:1142) in /Applications/MAMP/htdocs/wp-login.php on line 412
    [12-Dec-2013 16:22:37 UTC] PHP Warning: Cannot modify header information - headers already sent by (output started at /Applications/MAMP/htdocs/wp-includes/wp-db.php:1142) in /Applications/MAMP/htdocs/wp-login.php on line 424

    and apache_error.log:

    [Thu Dec 12 16:19:11 2013] [notice] Digest: generating secret for digest authentication ...
    [Thu Dec 12 16:19:11 2013] [notice] Digest: done
    [Thu Dec 12 16:19:11 2013] [notice] Apache/2.2.25 (Unix) mod_ssl/2.2.25 OpenSSL/0.9.8y DAV/2 PHP/5.5.3 configured -- resuming normal operations
    [Thu Dec 12 16:20:33 2013] [error] [client ::1] File does not exist: /Applications/MAMP/htdocs/wp-content/themes/everydayadventure/images/footer-scout-logo.gif, referer: http://localhost:8888/

    and the mysql_error.log is empty

  3. jayjames
    Member
    Posted 7 months ago #

    OK, just another update...

    Been digging around and found out by accident that wordpress released their new version so I let it update itself... had to re-install wordpress to find that out.

    Been messing around with different things on the mac and again by chance, removed the theme and everything seems to work. Added the theme back in and it brings up this cookie problem everytime. But only on the Mac. Works fine with windows.

Reply

You must log in to post.

About this Topic