WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Login problems after upgrading to 2.8 (17 posts)

  1. dma999999
    Member
    Posted 5 years ago #

    I just upgraded to WordPress 2.8. I did the upgrade through the cool new feature in WP itself to download and upgrade. Unfortunately the upgrade seems to have introduced a small problem - I can't login anymore.

    More specifically, when I try to login, I get an error message that says "ERROR: Invalid username. Lost your password?". I am positive that the username and password are correct (I store them in FF3 and have not changed them). Initially, if I tried a few times, I could eventually login. Now, however, I can't login at all.

    In addition, I get the following text at the very top when the login fails:

    WordPress database error: [MySQL server has gone away]
    SELECT option_value FROM wp_options WHERE option_name = 'DF_the_checkbox' LIMIT 1

    WordPress database error: [MySQL server has gone away]
    SELECT * FROM wp_users WHERE user_login = '[username]'

    WordPress database error: [MySQL server has gone away]
    SELECT * FROM wp_users WHERE user_login = '[username]'

    Where [username] is my username.

    I am not quite sure how to go about fixing this. If anyone has any suggestions they would be most appreciated.

    Thanks.

  2. MichaelH
    Member
    Posted 5 years ago #

    As message such as [MySQL server has gone away] typically means your database server is down. Wonder if you host might shed some light on that?

  3. dw1234
    Member
    Posted 5 years ago #

    wow... I just posted a similar question earlier today. I can't get the system to keep my password either... I don't know which version I have of WordPress as this is very new to us and I am not the web creator for our company... just an admin on the account... As Michael stated above I doubt that our server was down because I would not be able to access anything else if it was... I also tried it from a different computer and locale and it didn't work for me there either....

    Any suggestions?

  4. MichaelH
    Member
    Posted 5 years ago #

    dw1234 - your topic here http://wordpress.org/support/topic/28162 is a different problem likely because there's a plugin involved.

  5. dma999999
    Member
    Posted 5 years ago #

    Thanks Michael. MySQL server does appear to be up and running, according to phpMyAdmin. The blog that it runs also seems to be working as well. It's just the admin/login pages I'm having trouble with.

  6. MichaelH
    Member
    Posted 5 years ago #

    Got a link for that dma?

  7. dma999999
    Member
    Posted 5 years ago #

    The phpMyAdmin page? I do but it requires a login to access. Is there a way I could upload a screenshot or PDF or send to you directly?

  8. MichaelH
    Member
    Posted 5 years ago #

    Okay, nevermind that. If you disable all plugins what happens?

    If necesssary:
    How to deactivate all plugins when not able to access the administrative menus?

  9. dma999999
    Member
    Posted 5 years ago #

    Thanks. When I disable all plugins per your linked page I get a completely blank page when attempting to go to /wp-admin to login - no errors, no text, nothing at all, even when I try to view source.

  10. MichaelH
    Member
    Posted 5 years ago #

    Delete the wp-admin and wp-includes folders, then upload those from the 2.8 distribution available via the Download tab at the top of this page.

    Related;
    Uploading WordPress to a remote host

  11. dma999999
    Member
    Posted 5 years ago #

    Done, but unfortunately no change - no login screen.

  12. MichaelH
    Member
    Posted 5 years ago #

    But your blog is working minus being able to administer...?

  13. dma999999
    Member
    Posted 5 years ago #

    Yes, that does seem to be the case.

  14. MichaelH
    Member
    Posted 5 years ago #

    Link to see blog, please.

  15. dma999999
    Member
    Posted 5 years ago #

    Just managed to get back in. My service provider put in a workaround that got rid of the MySQL error message and allowed me to login. So it looks like the problem has been resolved, I think. I am awaiting details from them on the fix they applied and will post it here for the benefit of others that might encounter this same problem.

    Thanks very much for your assistance.

  16. dma999999
    Member
    Posted 5 years ago #

    FYI for anyone else that might experience this issue, I contacted my service provider who increased wait_timeout for MySQL not to kill connections after 15 seconds. Seemed to do the trick.

  17. black_attacker
    Member
    Posted 4 years ago #

    i think you can try this one guys
    install the workaround, download the “workaround” or “workaround-old” version of the wp-db…phptxt file, rename it to wp-db.php, and copy it to wp-includes/wp-db.php (overwriting the old file). You may want to backup the old file instead of overwriting it. You’ll need to do this each time you upgrade WordPress (a pain, I know), with the appropriate version of wp-db.php for that version of WordPress

    cmiiw :)

Topic Closed

This topic has been closed to new replies.

About this Topic