WordPress.org

Ready to get started?Download WordPress

Forums

login problem when installing locally (4 posts)

  1. indigo
    Member
    Posted 9 years ago #

    Successfully installed WP on my webserver but wanted to install on my PC's - localhost to speed up development and save bandwidth etc.
    All goes fine right up to the instruction to use 'admin' as user and the 'unique' password.
    When I enter these in the login page I get nothing. To be precise, I seem to get returned immediately to the login screen (with my recent inputs now empty) That's it - no error message, just dumb insolence.
    WP seems to be installed ok, the mysql database looks ok, and I can go to the site front page but I'm locked out of admin!
    I am running php 4.2.2 (could that be the problem?) / apache /win 2000 PC
    I've tried searching the support area but can't seem to find a similar problem/solution.
    any suggestions?

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Give this lot a whirl ?
    Login problems
    http://faq.wordpress.net/view.php?p=68

  3. karenjg
    Member
    Posted 9 years ago #

    Possibly something to do with javascript support on your localhost? I ask because I usually browse with javascript disabled unless I need it, generally for sites that use a javascript login process (as WordPress appears to). It might not have anything to do with your problem, but I've noticed that if I don't have it enabled when I try to log in to such sites (including my WordPress installation) I get the same thing - it just takes me back to the login screen as if I'd never entered my information. No error message, just a re-display of the blank login screen.

  4. rdsmes
    Member
    Posted 9 years ago #

    I spent the last few days fighting this problem. I found that I had two real problems - and actually found solutions for them!
    1) I was using the Foxserv setup on WinXP Home, which was running Apache 2.0.39 & PHP 4.2.2. There IS a problem in PHP 4.2.2 which I believe will prevent the login process from working correctly. The problem is that during the login process, WP attempts to generate two cookies to send to your browser. With PHP 4.2.2, only one of the two cookies (the last one generated) actually goes out in the HTTP headers on the reply to the login attempt. I do not believe there is a workaround for this problem other than to upgrade to a newer PHP version. After fighting unsuccessfully to upgrade the Foxserv PHP, I installed the latest XAMPP package and switched to PHP 4.3.8 (XAMPP was great - installed real easy). If you want to examine some PHP discussion on this cookie issue, you can check out http://bugs.php.net/bug.php?id=16626.
    2) Once I got around that problem, and the server was actually sending both cookies out, I found that my browser was not returning the cookies to WP as it should. After more digging on this problem, I found that Internet Explorer, in response to security issues, will not accept cookies from servers with 'non-compliant' host names. I was using my machine name in the http address to access WP, and my machine name had a '_' (underscore) in it. That made the machine name non-compliant, and the IE browser would not accept the cookies that WP sent at login. I changed my machine name to remove the underscore, and VOILA - I was able to login to WP.
    Your mileage may vary - I just thought I'd share the info since it might help a few others to overcome this login issue.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.