WordPress.org

Ready to get started?Download WordPress

Forums

Login / Password problems ? (18 posts)

  1. Mark (podz)
    Support Maven
    Posted 10 years ago #

    A summary of what's around the forums.
    Try to login after each step.
    #1. Clear your cookies
    Cookies are in your computer.
    In windows they are in
    C: / docs and setting / username / Cookies folder.
    #2. Clear the temp cache on your computer
    #3.Edit wp-login.php
    Go to the "case 'retrievepassword':" section.
    Just under the the comment:
    // redefining user_login ensures we return the right case in the email
    Replace:
    $user_login = $user_data['user_login'];
    with:
    $user_login = $user_data->user_login;
    #4. Your blog host should provide you with phpMyadmin access to your databases for you to do this.
    Open phpMyadmin, and click on the users table in the left menu (it could be wp_users, or yourprefix_users)
    Click "Browse"
    Click on the edit button next to the admin user.
    Delete whatever is in the password field.
    Now go to http://bfl.rctek.com/tools/?tool=hasher
    enter your desired password, and copy the hash that it generates
    Paste the hash in the password field for admin
    Save the info in the database.
    Login to WordPress using "admin" and the password you used to create the hash.

  2. Mark (podz)
    Support Maven
    Posted 10 years ago #

    #1. If your host supplies an sql database, they usually also supply phpmyadmin as a tool for sql administration. It allows you to look inside, and alter, the database.
    You could contact your host to see if it is available.
    #2. In 1.2mingus, the line in question is number 204:
    case 'retrievepassword':
    $user_login = $_POST["user_login"];
    $user_data = get_userdatabylogin($user_login);
    // redefining user_login ensures we return the right case in the email
    $user_login = $user_data['user_login'];
    $user_email = $user_data->user_email;

  3. Anonymous
    Unregistered
    Posted 10 years ago #

    '#2. In 1.2mingus, the line in question is number 204:
    case 'retrievepassword':
    $user_login = $_POST["user_login"];
    $user_data = get_userdatabylogin($user_login);
    // redefining user_login ensures we return the right case in the email
    $user_login = $user_data['user_login'];
    $user_email = $user_data->user_email;
    '

    What does this MEAN? Replace what with what????

  4. Mark (podz)
    Support Maven
    Posted 10 years ago #

    It means to *delete* this line
    $user_login = $user_data['user_login'];
    and instead, put this line in there:
    $user_login = $user_data->user_login;
    It does work - I've done it too.

  5. lovethebomb
    Member
    Posted 10 years ago #

    I ran into a similar problem running off an https server. After trying all the solutions on this page, I found the solution here: http://wordpress.org/support/3/6429 it seems you gotta make sure the cookies are set for https as well

  6. elmsblog
    Member
    Posted 10 years ago #

    If one has the e-mail turned off, is it still necessary to change the line under 'case retrieve password'?
    I did change it, and I still can't login, but I was just curious.
    Thanks.

  7. jslutzky
    Member
    Posted 10 years ago #

    <i>I ran into a similar problem running off an https server. After trying all the solutions on this page, I found the solution here: http://wordpress.org/support/3/6429 it seems you gotta make sure the cookies are set for https as well</i>
    Podz's solution didn't work for me, but this one did. I guess my office uses secure HTTP while my home doesn't.

  8. Joey
    Member
    Posted 10 years ago #

    unfortunately, after I replaced the original text password with the hashed one, this is what I get:
    Database error: [You have an error in your SQL syntax near 'WHERE user_login = 'Joey' AND user_pass = '21232f297a57a5a743894a0e4a801fc3'' at line 1]
    SELECT ID, user_login, user_pass FROM WHERE user_login = 'Joey' AND user_pass = '21232f297a57a5a743894a0e4a801fc3'
    Warning: Cannot modify header information - headers already sent by (output started at /home/virtual/site129/fst/var/www/html/wp/wp-includes/wp-db.php:80) in /home/virtual/site129/fst/var/www/html/wp/wp-login.php on line 110
    Warning: Cannot modify header information - headers already sent by (output started at /home/virtual/site129/fst/var/www/html/wp/wp-includes/wp-db.php:80) in /home/virtual/site129/fst/var/www/html/wp/wp-login.php on line 111
    Warning: Cannot modify header information - headers already sent by (output started at /home/virtual/site129/fst/var/www/html/wp/wp-includes/wp-db.php:80) in /home/virtual/site129/fst/var/www/html/wp/wp-login.php on line 112
    Warning: Cannot modify header information - headers already sent by (output started at /home/virtual/site129/fst/var/www/html/wp/wp-includes/wp-db.php:80) in /home/virtual/site129/fst/var/www/html/wp/wp-login.php on line 113
    Warning: Cannot modify header information - headers already sent by (output started at /home/virtual/site129/fst/var/www/html/wp/wp-includes/wp-db.php:80) in /home/virtual/site129/fst/var/www/html/wp/wp-login.php on line 117
    I think the more feasible solution is to provide a method that prevents wordpress from hashing the password.

  9. cmarina
    Member
    Posted 10 years ago #

    I'm getting the same problem and I don't know what to do. I used this and it worked on my pc and on my mac, now on a different pc, it's not working. I tried this solution and the one mentioned here:
    http://wordpress.org/support/3/6429
    Can anyone recommend something to try? Is this a normal problem for WordPress or did I mess up the installation somehow?

  10. Anonymous
    Unregistered
    Posted 10 years ago #

    Ignore steps 1-3 and just do 4, it worked for me

  11. cmarina
    Member
    Posted 10 years ago #

    Actually, I never installed a nightly build, only the releases. I tried what you suggested and it didn't work. If I install it again, will I lose all my data, registered users and posts? I don't want to start over. :(

  12. Anonymous
    Unregistered
    Posted 9 years ago #

    Sorry to wake this thread up again. I recently tried to upgrade from WordPress 1.2 to WordPress 1.2.1 and encountered this problem, where on trying to log in I would hit a redirection loop. I've tried all of the above suggestions, and those in some other threads: http://wordpress.org/support/3/6429 http://wordpress.org/support/3/7229 and http://wordpress.org/support/2/9257
    I also tried turning register_globals to On, but (thankfully) that made no difference either.
    No success. This is not browser specific, and deleting cookies makes no difference.
    --
    Rachel

  13. lex2000
    Member
    Posted 9 years ago #

    This is an excellent solution. Thanks for the info!

  14. paperlion
    Member
    Posted 9 years ago #

    The solution by fridgepimp here is also important if you get email errors on a lost password in 1.2.x

    http://wordpress.org/support/topic.php?id=19504

  15. pts
    Member
    Posted 9 years ago #

    I am new to wordpress. I have installed php4 and mysql on win2k. When I login to wordpress, I get the default error page HTTP Error 403 - Forbidden
    Internet Explorer
    you are not authorised to view this page

    What am I missing?

  16. Check the permissions on the files in /wp-admin/, they should be 644. Also, check the permissions on the directory /wp-admin/, they should be 755.

  17. AndyHingston
    Member
    Posted 9 years ago #

    Hi, I had just installed WordPress (latest stable version) on my Linux host and was able to login at first. The next time I attemped to login using my new Windows XP machine and IE 6 I entered the correct details and the login screen refreshed but no admin and empty login details. I purposely entered an incorrect password and the dialog higlighted this error...correct password and a brief flash of the screen and still no longin!!! I followed all posts on the forum, but all to no avail. This morning I tried a different machine and hey presto, so I looked into IE settings and found that the Privacy setting in IE needs to be set to at least LOW before I am able to login. I hope that this post saves others the frustration!! Regards Andy

  18. wghayes
    Member
    Posted 8 years ago #

    I had the exact same problem as Andy a few days ago. I could log-in on a different computer, but not the one I usually use (both run Windows 2000). After trying several suggested "solutions" without success, merely rebooting the computer solved the problem. Until then I could not log-in using Firefox or IE. As with many PC problems, rebooting is one of the first things to try.
    WordPress powers our entire church web site - I love it!
    WG Hayes

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.