WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Login page keeps redirecting back to itself (12 posts)

  1. azn137
    Member
    Posted 1 year ago #

    I've just migrated a WordPress site from one physical server to another. Everything went smoothly, except now the login page doesn't work. When I punch in my username/password, it gives no error, but it doesn't redirect me to anywhere else, regardless of what the URL says.

    Please help me.

    I've been reading a lot on WordPress Codex and forums, none of the suggestions works so far.

  2. azn137
    Member
    Posted 1 year ago #

    It feels like the site isn't accepting any cookie, if that makes sense.

  3. esmi
    Forum Moderator
    Posted 1 year ago #

    Have you checked the error logs?

  4. azn137
    Member
    Posted 1 year ago #

    Thank you esmi. I JUST thought to enable error. This is what I see:

    Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /var/www/vhosts/fstoppers.net/fstoppers.com/wp-includes/functions.php on line 2638 Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /var/www/vhosts/fstoppers.net/fstoppers.com/wp-includes/functions.php on line 2638 Notice: get_theme_data is deprecated since version 3.4! Use wp_get_theme() instead. in /var/www/vhosts/fstoppers.net/fstoppers.com/wp-includes/functions.php on line 2638 Notice: Undefined index: logo in /var/www/vhosts/fstoppers.net/fstoppers.com/wp-content/themes/fstoppers-lite/admin/admin-functions.php on line 161 Notice: get_profile is deprecated since version 3.0! Use get_the_author_meta() instead. in /var/www/vhosts/fstoppers.net/fstoppers.com/wp-includes/functions.php on line 2638

  5. esmi
    Forum Moderator
    Posted 1 year ago #

    They're all notices. No showstoppers there. What about the server's error logs?

  6. azn137
    Member
    Posted 1 year ago #

  7. azn137
    Member
    Posted 1 year ago #

    Anything you can think of to help?

  8. azn137
    Member
    Posted 1 year ago #

    It looks like one of these options worked:

    define('WP_HOME','http://fstoppers.com');
    define('WP_SITEURL','http://fstoppers.com');
    define('DOMAIN_CURRENT_SITE', 'fstoppers.com' );
    define( 'COOKIE_DOMAIN', 'fstoppers.com' );
    define('ADMIN_COOKIE_PATH', '/');

    Thanks.

  9. bobby.noonan
    Member
    Posted 1 year ago #

    hey, I'm having the same problem. Where did you put this code?

  10. Phil
    Member
    Posted 1 year ago #

    Most likely wp-config.php or functions.php

  11. azn137
    Member
    Posted 1 year ago #

    In your wp-config.php.

  12. cscottb
    Member
    Posted 1 year ago #

    I had the same problem a couple of days ago. It ended up being an entry in the .htaccess file.

Topic Closed

This topic has been closed to new replies.

About this Topic