WordPress.org

Ready to get started?Download WordPress

Forums

Google Authenticator
[resolved] Login not working from time to time (11 posts)

  1. _OMEGA_
    Member
    Posted 1 year ago #

    Hi all,

    great plugin. I like it so much and I can sleep better with this enabled.
    I just have one question for you.
    It happens that I have to try several times to be able to log in, sometimes just 2 times, but some times more that 6 times to be able to log in.

    Maybe could it have some incompatibilities with some plugin? (Better WP Security, for example??)

    http://wordpress.org/extend/plugins/google-authenticator/

  2. Henrik Schack
    Member
    Plugin Author

    Posted 1 year ago #

    Hi _OMEGA_

    It could be caused by in inaccurate clock on your server or phone.
    Best regards
    Henrik Schack

  3. _OMEGA_
    Member
    Posted 1 year ago #

    I think could be on the server. I will check it.
    And I will check if the other admin (with Galaxy S2, instead I have an iPhone) has the same problem.

    If you are interested, I will write updates here.

    Thank you and Best Regards.

  4. _OMEGA_
    Member
    Posted 1 year ago #

    Faster as the speed of light :)
    I checked and the server is -1 hour based on my real time.

    So what can I do? I cannot work on the server, I am not the sys admin.
    Do I have to change the hour on my phone everytime I want to log in?

  5. Henrik Schack
    Member
    Plugin Author

    Posted 1 year ago #

    Hi
    I would create a support ticket at the webhost, asking to have an openntp daemon installed.

    btw how did you check the time at the server ?

    Best regards
    Henrik Schack

  6. _OMEGA_
    Member
    Posted 1 year ago #

    Hey hey,

    please, do not laugh at me if I made something wrong, but I just change a line in a file and then saved. The hour is -1.

    Is this not a good way?

  7. Henrik Schack
    Member
    Plugin Author

    Posted 1 year ago #

    I guess it depends on your locale settings, on my webhost I have
    TZ=Europe/Copenhagen (server is in the US)
    Causing all my date/time settings to be displayed in Denmark time.

    Perhaps some tiny PHP script displaying the time is better.

    Best regards
    Henrik Schack

  8. _OMEGA_
    Member
    Posted 1 year ago #

    Wonderfull,
    I will do some more tests.

    Do I have to ask to my webhost to install something or do I have to write some code to retrieve the exact time on server?

    Thank you very much for the detailed explanation.

  9. Henrik Schack
    Member
    Plugin Author

    Posted 1 year ago #

    Hmm well if the webhost doesn't keep the time accurate I would ask them to do so.
    But it could be your phone as well, or perhaps a conflict with the plugin you mentioned. Did you try disabling it ?

    Btw important info: It's the servers UTC time that has to match the phone UTC time. All calculations in the Authenticator app and my plugin are performed using UTC time.

    Best regards
    Henrik Schack

  10. _OMEGA_
    Member
    Posted 1 year ago #

    Ok, fine.

    I will ask to the webhost.
    Thank you again for the fast and kind answers.

  11. _OMEGA_
    Member
    Posted 1 year ago #

    Fixed by enabling the 4mins in the plugin.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.