WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Login Never Worked (25 posts)

  1. amanitam
    Member
    Posted 7 years ago #

    Installation seems to be ok. The problem is every time I try to login to the admin area I get redirected back to the login page???

    Thx - Susan

  2. Doodlebee
    Member
    Posted 7 years ago #

    what URL are you trying to log in to? Does it tell you "wrong username" or "wrong password"?

  3. amanitam
    Member
    Posted 7 years ago #

    Neither!

    From:

    /wordpress/wp-login.php

    It tries to redirect to:

    /wordpress/wp-admin/

    But cannot so it reloads the login.php! But no error messages.

    There is another thread on same problem at
    http://wordpress.org/support/topic/108923?replies=4

  4. Doodlebee
    Member
    Posted 7 years ago #

    do you have a link?

  5. amanitam
    Member
    Posted 7 years ago #

  6. Doodlebee
    Member
    Posted 7 years ago #

    Hmm...I see nothing in the source code that's off - of course, it's PHP so I guess I wouldn't. But putting in the incorrect password is doing what it's supposed to be doing.

    I don't know, have you checked the wp-login.php file on your hard drive (that you uploaded) against the file on the server? If they aren't the same filesize, it could have been corrupted in the transfer....

    I'm at a loss here.

  7. amanitam
    Member
    Posted 7 years ago #

    Me too :'(

    I'm not the only one with this problem. But still, I would like to know why, or how I can fix this.

    Thx

  8. Doodlebee
    Member
    Posted 7 years ago #

    Did you try reinstalling with fresh files? That's the only thing I could think, is that something got corrupted.

    Or maybe clear your cache? That might be doing it, too.

  9. obscure
    Member
    Posted 7 years ago #

    Do you have your browser set to accept cookies by default? If your browser is blocking cookies then WP will do exactly what you describe.

    Alternatively, even if it is accepting cookies, it could be a corrupted cookie. In which case you need to delete cookies for your site and try again.

  10. amanitam
    Member
    Posted 7 years ago #

    Okay.

    I cleared my database tables uploaded fresh copies of wp-config.php, etc. Reinstalled. Successfully repopulated database. Still same problem!

    I hav emptied the cache, removed the cookies.

    Still same problem!

    I'm willing to try anything at this point :-{

  11. amanitam
    Member
    Posted 7 years ago #

    BTW, this is the URL generated by the login.

    http://the-garrison.com/member%20folders/barney/wordpress/wp-login.php?redirect_to=%2Fmember%2520folders%2Fbarney%2Fwordpress%2Fwp-admin%2F

    at first blush it looks okay. But I noticed an "extra" bit of URL encoding in the redirect

    member%2520folders

    instead of

    member%20folders

    Am I reaching?

  12. scarecr0w
    Member
    Posted 7 years ago #

    I am having same exact same problem. Reinstalled, etc.

    I have a lousy workaround:
    If I place my cursor to the end of the URL and hit enter, THEN it takes me to the Admin page or whatever page was referred in the redirect.

    This tells me it is the REDIRECT in the URL that is failing.

    Firefox and Internet Explorer same thing.
    Please help?

  13. Doodlebee
    Member
    Posted 7 years ago #

    Ahhh...you have a space in your URL! You have "member folders" instead of "member-folders" or "member_folders".

    Can you change that? (of course, if you do, you'll probably need to update your database with the new URL - otherwise it'll disappear - it's easy enough to do if you have phpMyAdmin access to your databases) That could be what's screwing things up. Because WordPress will put in dashes for things with spaces - like for your category slugs and such? I'd say that's why it's doing it.

  14. amanitam
    Member
    Posted 7 years ago #

    Unfortunately, I did not set up the site architecture. And it's more than updating the database. It's updating every single link from hundreds of pages.

    But before we say "Eureka!" I am going to reinstall WP in the home directory and see if that makes a difference.

  15. Doodlebee
    Member
    Posted 7 years ago #

    Okay - that'd be a good idea. I'm not *positive* that the space it's what's doing it - but it's definitely a possibility.

    There also may be a way around it...I know there was another case a while back where the space in the links was causing an issue, but I'd have to search around and try to find it (it's been a while) and see what the solution is.

    Maybe you could just use .htaccess to rewrite the URLs on the site? That's a possibility.

    Options +FollowSymlinks
    RewriteEngine on
    RewriteRule ^member%20folders/... members_folders... [nc]

    I know that last line is wrong - I'm not .htaccess expert. But I know you can do something like that to help rewrite the URL so that you're directed to the proper place - hopefully someone better versed in it can come along and assist in the proper format. But you could also look it up and find some .htaccess tutorials on how to write it and experiment.

    But you'd need to place the .htaccess file in the /barney folder - maybe it's the /barney/wordpress folder - but I think it's the upper level that you need to place it in.

    Seriously, I hope someone better versed in .htaccess can improve upon my idea here, but I think it would work.

  16. dossp
    Member
    Posted 7 years ago #

    Hey,

    I've experienced the exact same thing here

    I started out having WordPress installed in a /wordpress folder, and install goes well, tables made everything a success, get to the login page and enter info and it redirects from

    http://www.archangelfireworks.com/wordpress/wp-login.php

    to

    http://www.archangelfireworks.com/wordpress/wp-admin

    If i enter incorrect data into the login area, it does stop me so i know that that part of it is working.

    I actually got in once, and used it for a bit, but uppon logging out and then trying again i have the redirect issue.

    So....I cleared my tables, and deleted the directory, and re-uploaded the WP files directly onto the root directory...and i get the same thing

    http://www.archangelfireworks.com/wp-login.php

    redirects to

    http://www.archangelfireworks.com/wp-admin

    and i get:

    Directory Listing Denied
    This Virtual Directory does not allow contents to be listed.

    on my page. I've tried this in IE and FireFox to no avail...

    Is There any way to fix this that anyone has found yet?

  17. Doodlebee
    Member
    Posted 7 years ago #

    Directory Listing Denied
    This Virtual Directory does not allow contents to be listed.

    That's a IIS error. You're running WordPress on a host that uses a windows server, and is running PHP - probably as a CGI program.

    Windows servers don't like .htaccess. Also, when you moved your blog, did you install it first? (You didn't mention that step - you just said you cleared the tables, then moved the files and tried to login.)

    Putting WordPress on a Windows server opens up a whole new world of issues.

  18. dossp
    Member
    Posted 7 years ago #

    Hey,

    I sent my last post to my Hosting provider as well and they made some changes and now everything works!

    Blogtastic!

    Thanks for the info though!

  19. amanitam
    Member
    Posted 7 years ago #

    Okay. WordPress does NOT like odd URLs. I installed it in the home directory and it works.

    Problem is I need to have it work in the badly named "member folders" directory. I tried doodlebee's url rewrite and that generated a 500. But I think she's got the best idea here. Anyone have input on the correct syntax for the .htaccess file?

    Please ... :-D

  20. Doodlebee
    Member
    Posted 7 years ago #

    I tried doodlebee's url rewrite and that generated a 500.

    You should post what your syntax *was* - it's possible that your server doesn't have mod-rewrite enabled. In that case, nothing you do with .htaccess will work - what I directed you to do *required* mod_rewrite to be enabled on your server. So be sure you have that (you'll have to ask your host to see if it's enabled).

    Another *possibility*...I don't know how well this will work - but you can try to change your URI to incorporate the space. But to do this, you need to have phpMyAdmin access. So, instead of "member folders", you could purposely put in that character for the space that keeps showing up.

    To do that, you need to log into your phpMyAdmin, and go to "wp_settings" (I think? It's towards the bottom of your list) - inside, you're looking for the "blog_url" table. Check the box next to it, and click "browse" at the top. You'll see an area that has your current URL in there:
    "http://the-garrison.com/member folders/barney/wordpress/"

    Change it to add in the character for the space... "member folders" gets changed to "member%20folders", then save your changes.

    That *may* help. I'm not 100% sure it will, but it's possible. You can give it a shot and see, and if it doesn't it's just a matter of undoing the change you just made (to get back to where you are). That would be the easiest method to try, I think.

  21. amanitam
    Member
    Posted 7 years ago #

    Thx Doodlebee. Bear with me here, as I'm pretty much stumbling around.

    I used your suggestions for the .htaccess file. RewriteEngine activates the mod-rewrite on the server. So, I think it's the last line for the RewriteRule

    My PHPMyAdmin access is limited to the actual databases. And there is nothing immediately obvious except for the user tables in the WordPress database.

    Thx again for helping out here.

  22. Doodlebee
    Member
    Posted 7 years ago #

    My PHPMyAdmin access is limited to the actual databases.

    Right - that's fine. You just need to look for the "blog_url" table in the database. Unless you're saying the only access you have is to create or delete databases, and nothing more? "cause that would be very sad, indeed - I'd get a new host if I were presented with that info.

  23. amanitam
    Member
    Posted 7 years ago #

    I can query, empty, drop, etc via PHPMyAdmin.

    But ... there is no "blog_url" table in the database??? There are ten "user" tables that were created at install. (I changed the "wp_" as I hope to use one database for multiple blogs) They are:

    susan_categories
    susan_comments
    susan_link2cat
    susan_links
    susan_options
    susan_post2cat
    susan_postmeta
    susan_posts
    susan_usermeta,
    susan_users

    Sorry i'm just not seeing it. Chances are good I am looking in the wrong place :-{

  24. Doodlebee
    Member
    Posted 7 years ago #

    But ... there is no "blog_url" table in the database???

    As I said in the post above ("you need to log into your phpMyAdmin, and go to "wp_settings" (I think? It's towards the bottom of your list) - inside, you're looking for the "blog_url" table."), the blog_url is located within one of the last few tables - I *think* it's the "options", not "settings" as mentioned in the previous post, apologies for that - table, but it could be one of the other ones - you'll have to look for it.

  25. amanitam
    Member
    Posted 7 years ago #

    There is something very funny about this. But first ...

    Thank you doodlebee for all your help!!!

    I went in to the _options table, found something called blog_id, and inside was "siteurl" and this was where it got squidgy. It had set the site url to

    http://the-garrison.com/member%20folders/

    which u'ld think was correct. I edited to have the space instead so it looked like this

    http://the-garrison.com/member folders/

    And "Eureka!" I'm in.

    Thx for ur help, and patience -S

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags