WordPress.org

Ready to get started?Download WordPress

Forums

Google Authenticator
[resolved] Login issues with new iOS device (self-hosted) (3 posts)

  1. scriptedgenius
    Member
    Posted 1 year ago #

    I got a new iPad Mini and I could not log in. I changed passwords, app passwords, and secret keys, to no avail. I tried every suggestion provided thus far with no success. Finally, I downloaded .43 and installed via ftp to my plugin folder. From there, I set up my devices all over again, and it worked with all devices. When I upgraded to .44, the devices still had access.

    I solved my own issue here after about a week of troubleshooting, but I am putting this in as a reference in case anyone else has issues. There is a difference between .43 and .44 that prevents users from adding the iPad Mini as a new device with the app password, and I am not sure why. If you have this problem, I recommend following these steps:

    1. Delete all files for Google Authenticator plugin.
    2. Download .43 from http://wordpress.org/extend/plugins/google-authenticator/developers/.
    3. Install via FTP in your plugins folder (transfer zip file and extract once transferred. Delete zip file after extraction).
    4. Set all devices up.
    5. Upgrade back up to .44 using the update links inside WordPress.

    Dev - I would recommend finding the issue in .44 that prevents the iPad Mini. I tried to replicate the issue on iPhone 4S and iPhone 5, as well as iPad 2. Only the iPad Mini had problems with login credentials, and this was the only fix to work thus far.

  2. Henrik Schack
    Member
    Plugin Author

    Posted 1 year ago #

    Really strange there is no "real" changes between 0.43 and 0.44 mostly just minor stuff, and certainly not something that changes how an app performs a login.

    Best regards
    Henrik Schack

  3. scriptedgenius
    Member
    Posted 1 year ago #

    The new update to the WordPress iOS app fixed all login issues. Apparently, there was a "delay" in the login, causing codes to deactivate before submitting.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic