WordPress.org

Ready to get started?Download WordPress

Forums

Login doesn't stick (18 posts)

  1. JordonK
    Member
    Posted 8 years ago #

    Before upgrading to 2.0, I would allow WordPress 1.5 to remember my password, and I would be logged in until I cleared my cookies. Now with 2.0, I have to log in again after I leave the backend of my site. It can get quite annoying. I never click the "Sign out" link, and checking the "Remember me" box doesn't help. I've deleted my cookies and tried again to no avail. What's the problem?

  2. citeewurkor
    Member
    Posted 8 years ago #

    I noticed that as well. I just don't leave the admin screen. Kind of weird, though.
    I do kind of like the security aspect of it though.

  3. johnoz
    Member
    Posted 8 years ago #

    Before upgrading to 2.0, WordPress would remember my password and I would be logged in until I cleared my cookies. Now with 2.0, I have to login fresh each time and neither Firefox nor Camino will remember my details. Cookies are saved and I have cleared them and reset everything I can think of to no avail.

    BTW I can login to the Dashboard from my site without an issue.

    Is this a bug??

  4. Kainzy
    Member
    Posted 8 years ago #

    Hi all, I too have the exact same problem that wasn't apparent with WP1.5. I tick the remember box from Firefox but no luck. Even tried clearing the cookies but had the same result too. Login details aren't remembered.

  5. GaryPetersen
    Member
    Posted 8 years ago #

    The Codex page for WordPress cookies (1) still suggests that you ought to stay logged in (and bypass the login screen directly t the Admin page). And the v2.0 Changelog (2) doesn't mention login behavior as having changed.

    Perhaps this is a bug.

    (1) http://codex.wordpress.org/WordPress_Cookies
    (2) http://codex.wordpress.org/Changelog/2.0

  6. Ryan Boren
    WordPress Dev
    Posted 8 years ago #

    If using Firefox, make sure it's not overriding the expiration.

    Got to Edit->Preferences in Firefox. Click on "Privacy". Go down to "Cookies". "Keep Cookies:" should say "until they expire".

    If that is set correctly, click "View Cookies". Scroll down until you see the name of your site. Look for a cookie named "wordpresspass_*" where * is a bunch of hex digits. Click on that cookie. The "Expires" field should be set to a date about a year from now.

  7. GaryPetersen
    Member
    Posted 8 years ago #

    Thanks, Ryan. I have three WordPress blogs at my countrykeepers.com site. The cookie for each of them is set to expire either in November or December, 2006. And Keep Cookies - Until They Expire is set in my Firefox v1.5 installation.

    I haven't tried it in Internet Explorer yet, but I will.

  8. johnoz
    Member
    Posted 8 years ago #

    Ryan, I also want to confirm that Firefox is setup as you say and that I still have the problem. Same with Safari and Camino --all MacOSX browsers.

  9. xionos2k
    Member
    Posted 8 years ago #

    I have this problem as well, I did notice that when I replace the v2.0 wp-login.php with the old v1.5 file, it allows me to stay logged in like before, but the main page doesn't show me as being logged in, even though I am, it still says "Register" and "Login", I'm guessing it's just a bug that will hopefully be resolved soon.

  10. Ryan Boren
    WordPress Dev
    Posted 8 years ago #

    Okay, wp-login.php isn't redirecting. If you visit wp-login.php directly, it will ask you to login even if you already are. However, if you visit anywhere in wp-admin/, those pages will recognize your current login. So, you don't really have to login again, it just looks like you do. This is annoying, however, so here's a fixed wp-login.php. Copy it over the top of your existing wp-login.php file.

  11. Ajay
    Member
    Posted 8 years ago #

    Is the corrected wp-login.php updated in the download?

  12. Ryan Boren
    WordPress Dev
    Posted 8 years ago #

    No, the 2.0 release is what it is. The fix will be in a maintanence release, or you can grab the next nightly build to get that fix plus all of the other fixes for 2.0 so far.

  13. Kainzy
    Member
    Posted 8 years ago #

    Thank you so much Ryan, that updated login is working perfectly it seems. Having to login each time was getting mildy irritating :)

  14. xionos2k
    Member
    Posted 8 years ago #

    Thanks for the updated wp-login.php, but it seems to be doing the same thing as the 1.5 file did, it keeps me logged in, but still shows "login" and "register" on my front page, instead of "site admin" and "logout" Guess I'll just have to take the good with the bad and suck it up :)

  15. Kainzy
    Member
    Posted 8 years ago #

    Hmm, the updated login was working and keeping me logged in. Except just now when I returned to the blog I ended up at the login screen with both boxes empty...going to check the expiration settings as mentioned above now.

  16. johnoz
    Member
    Posted 8 years ago #

    Works okay now, thanks! Seems I had to login one more time to set it...

  17. GaryPetersen
    Member
    Posted 8 years ago #

    I've been using the new file for a week now and it works just fine. Thanks.

  18. jadr
    Member
    Posted 8 years ago #

    Using the new php now with success, thx folks.
    jakob
    boyer-draeby.dk

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags