WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [closed] Login 404 After Upgrade to WordPress 3.5.2 (36 posts)

  1. Troy Dunn
    Member
    Posted 1 year ago #

    I run a WordPress mulitisite system on a dedicated GoDaddy server. Yesterday I ran a WordPress update from 3.5.1 to 3.5.2 and now if I try to login to any of my sites, I get a 404 page.

    I've tried replacing the wp-admin folder, renaming the plugins folder, replacing the wp-login.php file, and deleting the .htaccess file. I checked the file permissions on wp-admin and the wp-login.php. Those are OK too.

    I also checked the file permissions on wp-admin and the wp-login.php. Those are OK too.

    I also ran the sitecheck.sucuri.net and my site is "Verified Clean".

    Oh, and I also verified the domain in the database using PhpMyAdmin to look up the "wp_options" "siteurl".

    And I verified that the "db_version" was "22442". :(

  2. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Reset your permalinks temporarily to default and see if the error goes away.

  3. Troy Dunn
    Member
    Posted 1 year ago #

    How do I reset the permalinks if I can't access the dashboard?

  4. Troy Dunn
    Member
    Posted 1 year ago #

    In the database I see the permalink_structure is set to: /blog/%postname%/.

    I tried changing it to "/?p=n", "/?p=n/", "/%post_id%/", "/blog/?p=n/". That didn't change anything.

  5. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Try adding the following to your .htaccess file (at the beginning) and see if it helps:
    RewriteRule ^post/([0-9]+)?/?([0-9]+)?/?$ /index.php?p=$1&page=$2 [QSA]

  6. Troy Dunn
    Member
    Posted 1 year ago #

    That did not help.

    Here's my primary sites domain: http://LittleGreenAgency.com/

  7. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    OK, please remove it from the .htaccess file.
    Using FTP/ cPanel, try deactivating all plugins and revert to Twenty Twelve theme temporarily to see if that makes any difference. Please keep it that way. Also link to your site so that I can have a look at it.

  8. Troy Dunn
    Member
    Posted 1 year ago #

    I've deactivated all of the plugins and changed the theme to "twentytwelve".

    And I had edited a comment above to include a link to my site.

    One more thing, I spoke with GoDaddy and they said there isn't anything happening to the server that would cause this. They are not blocking direct access to the index.php as indicated in this post.

  9. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Can you replace the Twenty Twelve theme (delete it first) and replace it with an unedited freshly downloaded copy?
    http://wordpress.org/themes/twentytwelve

  10. Troy Dunn
    Member
    Posted 1 year ago #

    Deleted and replaced.

  11. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Sorry I get the same errors in the theme. A freshly downloaded copy of the theme would not produce the same errors.

    In the meanwhile, you may also try replacing the wp-login.php file as I see that the login form tries to load and either gives a 404 error or goes into an unending loop.

  12. Troy Dunn
    Member
    Posted 1 year ago #

    I clicked the link you gave me, downloaded a fresh copy, deleted the existing folder via FTP, and uploaded the new one. Not sure what to tell ya.

    I downloaded WordPress 3.5.2 and replaced my wp-login.php file from the new folder. Still getting the same 404 error.

  13. Troy Dunn
    Member
    Posted 1 year ago #

    I've downgraded from 3.5.2 to 3.5.1 and I'm still getting the same 404 when trying to access the wp-admin.

    I've also repaired every database table and that didn't do anything either.

  14. Troy Dunn
    Member
    Posted 1 year ago #

    The issue seem to be focused on the wp-login.php. If you try to access this page after upgrading to WordPress 3.5.2 the page enters into a redirect loop.

  15. meshmarketer
    Member
    Posted 1 year ago #

    I have been getting the same problems. My server folks said it was a permissions problem. They were able to fix that for one of my WPMS installs but not the 2nd one.

    I am very interested in a solution as well and I think it's really crappy that they would roll this out on a Friday when the senior server experts aren't working.

  16. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    In the meanwhile, you may also try replacing the wp-login.php file as I see that the login form tries to load and either gives a 404 error or goes into an unending loop.

    Downgrading is not a solution for many reasons. If you can, you may try to manually upload WordPress except wp-content and wp-config.php

  17. Troy Dunn
    Member
    Posted 1 year ago #

    @meshmarketer - Thanks for the thoughts. I checked the folder/file permissions. That didn't help me though. Not much you can do about a security roll-out. There're going to happen when they happen.

    @krishna - Thank you for all of your help today on this too! I replaced all of the site files (including wp-login.php) with WordPress 3.5.1, except the "/wp-content/" and the "wp-config.php". I also verified that the database was rolled back to "22441".

    I've also flushed my cache and cookies, tried using incognito, and another browser.

  18. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    Please contact your host. They may be running something to limit log in attempts.
    http://wordpress.org/support/topic/brute-force-attacks-and-wordpress?replies=2

  19. Troy Dunn
    Member
    Posted 1 year ago #

    I did contact my host and they said they they are not running something to limit log in attempts. This is on a dedicated server.

  20. Troy Dunn
    Member
    Posted 1 year ago #

    I also just tried redownloading 3.5.2 and replacing all of the files except wp-content/ and "wp-config.php". I then checked the "wp-admin/upgrade.php" file and it says "Your WordPress database is already up-to-date!"

    I verified this in the db. It is "22442".

  21. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    Sorry missed that above.

  22. meshmarketer
    Member
    Posted 1 year ago #

    @Troy. I appreciate the sentiment that "They're going to happen when they happen." but it's only when enough people start requesting it that it can change. It's like the NSA spying on everyone. It will change when enough people say they want something else.

  23. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    Chrome and FF show javascript errors. I haven't delved into yet.

  24. Troy Dunn
    Member
    Posted 1 year ago #

    I disabled all of the plugins and switched back to twentytwelve. The site is WordPress 3.5.2 and the wp-login.php file is set to permission "775".

    This is what my .htaccess file says:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
  25. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    @meshmarketer - please don't hijack someone else's thread - you have your own thread already on this request - http://wordpress.org/support/topic/wordpress-updates-on-fridays?replies=2

  26. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    Save your htaccess file. Then replace it with this.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
  27. Troy Dunn
    Member
    Posted 1 year ago #

    Saved, updated, uploaded, tested...no change. :(

  28. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Tried this? Adding to the wp-config.php file
    define( 'CONCATENATE_SCRIPTS', false );

  29. Troy Dunn
    Member
    Posted 1 year ago #

    I tried adding your code to the wp-config.php file and uploading to the server. Unfortunately, that didn't resolve the issue either.

    I've removed that from the file and reuploaded the config file.

    Because I'm hosting several live sites from this one installation, I'm turning the plugins and custom theme files back on.

    Again, when I try to login to any of my websites (http://littlegreenagency.com/ or http://spaceunited.org/ or http://spaceupdenver.org/) I get a 404 error. If I try to access the /wp-login.php file (permissions 755) I get a redirect loop error.

    I believe there is an issue with the WordPress 3.5.2 wp-login.php file that is causing a redirect loop and preventing users from logging into any of my WordPress Multisite sites.

    The code that's changed in the wp-login.php file is this. Here is version 3.5.1:

    case 'postpass' :
    	require_once ABSPATH . 'wp-includes/class-phpass.php';
    	$hasher = new PasswordHash( 8, true );
    
    	// 10 days
    	setcookie( 'wp-postpass_' . COOKIEHASH, $hasher->HashPassword( stripslashes( $_POST['post_password'] ) ), time() + 10 * DAY_IN_SECONDS, COOKIEPATH );
    
    	wp_safe_redirect( wp_get_referer() );
    	exit();
    
    break;

    And here is 3.5.2:

    case 'postpass' :
    	if ( empty( $wp_hasher ) ) {
    		require_once( ABSPATH . 'wp-includes/class-phpass.php' );
    		// By default, use the portable hash from phpass
    		$wp_hasher = new PasswordHash(8, true);
    	}
    
    	// 10 days
    	setcookie( 'wp-postpass_' . COOKIEHASH, $wp_hasher->HashPassword( stripslashes( $_POST['post_password'] ) ), time() + 10 * DAY_IN_SECONDS, COOKIEPATH );
    
    	wp_safe_redirect( wp_get_referer() );
    	exit();
    
    break;

    I've tested in multiple browsers, clearing cache and cookies, checked permissions, turned on the twentytweleve theme, turned off all plugins, check the .htaccess log code, tested the upgrade.php file, downgraded and upgraded WordPress files except wp-config.php and /wp-content/.

    (Update: I also just lowered the db_version to 22441, loaded the upgrade.php file, this time it asked to update the db, I ran the update, verified that the db_version was back to 22442 and tested the wp-admin and wp-login.php -- both failed.)

  30. ahiddleston
    Member
    Posted 1 year ago #

    Hi Troy!

    I had this exact same thing happen on one of my main websites.

    Don't know if it's the same problem, but here's what I did to fix it:

    - V3.5.2 seemed to update okay but I was kicked out of the dashboard right after it finished patching

    - could not get back in

    - noticed the 404 URL string was referencing "wp-admin/upgrade.php" could not be found

    - copied in a new and fresh upgrade.php file

    - WordPress prompted that the DB was out of date and need patching

    - DB patched -- everything working great again.

    Don't know if this helps...but I can relate to the frustration. Let me know if this solves it for you.

    Andrew

Topic Closed

This topic has been closed to new replies.

About this Topic