WordPress.org

Ready to get started?Download WordPress

Forums

login 404 (12 posts)

  1. dgswilson
    Member
    Posted 2 years ago #

    using easel theme, since 2.8 (?), at some point log in returns 404 (but) I am logged in. The url for the 404 is domaindotcom/wpfolder/wpfolder/ - which should be domaindotcom/wpfolder/wp-admin/

    Now the admin bar is up on the top so I just click dashboard or other links. All working.

    The other thing that's happening is "empty spam" or "select-all/delete" (spam comments) takes me to my site's error page (not the wordpress 404 page like login does)

    Checked settings in phpMyAdmin, all set that I know how to set.

    plugins:

    AddToAny
    Akismet
    All in One SEO Pack
    Anti-Captcha
    Broken Link Checker
    WP htaccess Control

    I'm not sure but this may have happened with last wp update. Other themes not affected.

    I guess thats about it.

  2. samfusion
    Member
    Posted 2 years ago #

    It may be permission issue, make sure you have 644 as file permission and 755 as folder permission for all WP files. Else just give the wp installation link.

  3. dgswilson
    Member
    Posted 2 years ago #

    those are set right, dgswilson.com/wpsite/

  4. samfusion
    Member
    Posted 2 years ago #

    I see 404 Error at:
    http://www.dgswilson.com/wpsite/wp-admin/

    I know, you can directly access wp-login.php . You must have played with installation.

    Try to fix this way:
    Login to the database where WordPress installed.
    Click on "wp-options" and click on browse.
    You can see all the rows, for the row "home" and "siteurl" change the link as:
    http://www.dgswilson.com/wpsite/ and click on "go". Clear browser cache and check the site.

  5. dgswilson
    Member
    Posted 2 years ago #

    I just took the login widget out and put the meta widget in to see if that made a difference. I guess that wouldn't effect the rest (spam edit/ check all)

    "for the row "home" and "siteurl" change the link as"

    Did you mean, change the link to?

    I've tried phpAdmin settings both ways. wp codex says NO trailing slash (doesn't it?) Do you have a trailing slash at the end of your urls?

    I have other blogs that work fine - I've set this one the same (cleared cache).

    Remember: The url for the 404 is domaindotcom/wpsite/wpsite/ (extra directory)

    and wp/bar takes me right to admin, so I'm thinking settings in wp_login.php or something

    Any other thoughts

  6. dgswilson
    Member
    Posted 2 years ago #

    just rechecked working blog and /options/home is blank: I'm gonna see what that does.

  7. dgswilson
    Member
    Posted 2 years ago #

    phpadmin home blank worked for login

  8. Frumph
    Member
    Posted 2 years ago #

    If this happens intermittently with Easel (or any other theme) and you are using a custom-header (appearance -> header), disable the custom header and see if you still get the same 404 intermittently (randomly).

    Its been told that the custom header part of Easel gives off random 404 errors with the wp-admin.

  9. dgswilson
    Member
    Posted 2 years ago #

    I have easel because I wanted three columns. not using custom header. but I think it may have something to do with easel and latest wp/update.

    3 col theme suggestions?

    I usually strip things down to the bare bones. I use the seo plugin but only have don't index tags as archives as a setting.

    So far with the phpMyadmin>options>home>blank - things seem to be working.

    The wp/install is the watching the world blog on my domain you're welcome to go hit some buttons if you like, see if everything works. That would be helpful for me, thanks for responses. Doug

  10. Frumph
    Member
    Posted 2 years ago #

    http://www.dgswilson.com/wpsite/wp-login.php

    That does exist, its just not from the /wpsite/wp-admin/ redirect which is odd - what happens when you disable all plugins, is it still the same?

    can you access the wp-admin after logging on?

  11. dgswilson
    Member
    Posted 2 years ago #

    "That does exist" - you lost me, what exists?
    "can you access the wp-admin after logging on?" Yes

    I took the login widget out and put the meta widget back in. Thought maybe wp-login.php might be set up wrong.

    I did disable plugins when I started looking for problem, no effect.

    What I have now is a 404 when I choose to empty(all) spam. Delete permanently one at a time works, but not select-all delete or empty spam.

    I may have to replace easel php files (wp-login, edit-comments.php etc.). Which ones have database settings? Do you know? I'd rather leave them alone if possible.

  12. Frumph
    Member
    Posted 2 years ago #

    .. it's recommended that your hosting disables its handling of error pages and use an .htaccess that will let wordpress manage it.

Topic Closed

This topic has been closed to new replies.

About this Topic