WordPress.org

Ready to get started?Download WordPress

Forums

logging into wordpress 2.5 returns me to wp-login.php (17 posts)

  1. benoburdy
    Member
    Posted 5 years ago #

    i'm sorry if this exact problem has already been discussed. i tried to search the forums for it but did not come up with anything exactly like this right away.

    i usually login to my account via wp-admin. a few days ago, something strange happened. in the middle of writing an entry, the section that shows my autosave status suddenly popped up with a login window. thankfully, i quickly copied my unsaved text and pasted it into an e-mail to myself. then, i reloaded wp-admin. i had my usual wp-login.php screen. i tried to login with the correct username and password but ended up back at the wp-login.php. i tried the admin username. still the same thing. i tried purposely mistyping the password. only then did i get an actual "ERROR: Incorrect password." message. when i use the correct passwords for the correct usernames, i just end up back at the wp-login.php screen; over and over.

    i tried clearing my cookies. i tried restarting my browser. i tried uploading a new copy of wp-login.php (from wordpress 2.6) to the directory. i tried adding the line "@define(’ADMIN_COOKIE_PATH’, ‘/’);" to my wp-config.php file.

    i don't get what's happening.

  2. benoburdy
    Member
    Posted 5 years ago #

    does anyone have any advice?

  3. benoburdy
    Member
    Posted 5 years ago #

    in case it helps at all, my blog url is http://www.ocf.berkeley.edu/~beno/journal/journal.

    if that's too long, then http://www.benomix.com/fjournal

  4. benoburdy
    Member
    Posted 5 years ago #

    i can't login to manage my blog or write any entries... i'm just stuck at the login page.

  5. benoburdy
    Member
    Posted 5 years ago #

    bump, bump, bump.

  6. bfrench47
    Member
    Posted 5 years ago #

    Just solved this on mine - clearing cookies, restarting didn't work for me either. But I noticed the admin log out was visible on my home page, clicked that and problem was solved.

  7. benoburdy
    Member
    Posted 5 years ago #

    unfortunately, no "admin log out" link appears for me. i guess i'll upload fresh versions of all the directories except for wp-content.

  8. benoburdy
    Member
    Posted 5 years ago #

    also, i tried the "?action=logout" method; and that didn't work.

  9. benoburdy
    Member
    Posted 5 years ago #

    oh, and i tried the "/wp-admin/comment.php?action=mac&c=1" method, and that didn't work.

  10. alinush
    Member
    Posted 5 years ago #

    Anyone found the solution yet?

    Same thing happens for me. I tried ?action=logout but it didn't work.

    What host are you using?

  11. gbvivek
    Member
    Posted 5 years ago #

    I'm having the same problem with WP 2.6.2 - I log in at wp-login.php, and it returns me to the same page.

    My host is Dreamhost.

  12. bitzer
    Member
    Posted 5 years ago #

    I'm having the same trouble. Mine started a couple of days ago. My wife was in the middle of typing a post, was logged out and, since, we've been unable to get beyond wp-login.php. It'll recognize an incorrect login, but a correct login returns you to the username/password prompt as well. I've, since, upgraded to WP 2.6.3, but have seen no change. Coincidentally, my hosting provider is Dreamhost, also.

  13. bitzer
    Member
    Posted 5 years ago #

    For what it's worth, I've resolved my issue. I had to rename the plugins directory (I used old.plugins). After that, when trying to login, I received an error saying my Database was out of date and needed to be updated. I clicked the "do whatever" button and 2 seconds later I was at my dashboard. I renamed old.plugins back to plugins, activated all my old plugins and everything's working fine so far. Not quite sure what caused it, though. Hope this helps someone.

  14. surblimity
    Member
    Posted 5 years ago #

    bitzer - I think that many people owe you many thanks. I was just able to fix a blog that's been having this problem for weeks now. My hunch is that all of you have the same plugin installed that was interfering with logging in to update the WP database. By renaming the plugin directory, you effectively disabled that plugin, stopping the interference and allowing you to get to the DB update page.

    Hurray!

  15. surblimity
    Member
    Posted 5 years ago #

    btizer - out of curiosity, after you were able to login in did you encounter an error like this one upon going to the Manage Plugins page in admin:

    The plugin ../../../../../../../../../../../../../../../../../../../../tmp/tmpiNR1gx/sess_7b0e28c049ba9da373a1e901574c02a8 has been deactivated due to an error: Invalid plugin.

  16. kwickimom
    Member
    Posted 5 years ago #

    I am a MAJOR newbie having this exact issue. Where do I rename the plug in directory at? In my FTP or Cpanel? I tried it in both and it didn't fix my problem. thanks in advance

  17. stanleydankoski
    Member
    Posted 5 years ago #

    Possible solution:

    This happened to me yesterday, after I changed the Blog URL in the WP Settings, from "domain.com/" to "domain.com/index.php".

    I did this hoping I could put the blog on the live server while keeping a static index.html there as we roll out changes to the blog. Any links in WP point to /?p=x which pointed to my static html page rather than to the blog's index.php.

    What I didn't know is that changing the blog URL affects the URL of the dashboard pages as well. So in effect, I locked myself out of the admin area!

    I was able to go to the mysql server and figure out where the blog URL value was stored and edited it back to just "domain.com/". I WAS LUCKY that I had the access to the mysql server. My domain for this project is on Dreamhost.

    Hope this helps.
    STAN

Topic Closed

This topic has been closed to new replies.

About this Topic