WordPress.org

Ready to get started?Download WordPress

Forums

Logging in after installation... (18 posts)

  1. Pixelation
    Member
    Posted 6 years ago #

    Hey there everyone. I have successfully uploaded each and every one of the WordPress files however I get this error message:

    Warning: Invalid argument supplied for foreach() in /home/gary/public_html/blog/wp-includes/capabilities.php on line 31

    Warning: Cannot modify header information - headers already sent by (output started at /home/gary/public_html/blog/wp-includes/capabilities.php:31) in /home/gary/public_html/blog/wp-includes/pluggable.php on line 367

    Warning: Cannot modify header information - headers already sent by (output started at /home/gary/public_html/blog/wp-includes/capabilities.php:31) in /home/gary/public_html/blog/wp-includes/pluggable.php on line 368

    Warning: Cannot modify header information - headers already sent by (output started at /home/gary/public_html/blog/wp-includes/capabilities.php:31) in /home/gary/public_html/blog/wp-includes/pluggable.php on line 329

    What have I done wrong and am I able to fix it easily? Just as a note, I have tried reinstalling WordPress numerous times as well as deleting and remaking databases and usernames...

    Thanks in advance!

  2. moshu
    Member
    Posted 6 years ago #

    I'd try to get a fresh copy of the capabilities.php and upload it.

  3. Pixelation
    Member
    Posted 6 years ago #

    Meaning download WordPress again and upload that file only?

  4. moshu
    Member
    Posted 6 years ago #

    Yes, that's exactly what I meant.

  5. Pixelation
    Member
    Posted 6 years ago #

    Ok moshu, I have done what you told me to do however I still get the same error message coming up... Could this be a small bug or is there something wrong with the coding in that particular file?

    Get back to me soon.

  6. Pixelation
    Member
    Posted 6 years ago #

    I really want to start up my WordPress blog as soon as possible so hopefully someone can help me out with this problem...

  7. pramodd
    Member
    Posted 6 years ago #

    You should upload capabilities.php and pluggable.php to wp-includes folder again. Also, verify file size after you upload both the files.

  8. Pixelation
    Member
    Posted 6 years ago #

    I have done that pramodd and still not successful. I don't know what is wrong with it... Usually I have NO problems whatsoever with installing WordPress blogs; this is the first time.

    Anyways let me know of another thing I can do to fix it up.

    Thanks a lot for your help.

  9. MichaelH
    Member
    Posted 6 years ago #

    If your host gives you access to cPanel, upload the complete wordpress-2.2.zip file and then extract the zip once it is uploaded to your host.

  10. Pixelation
    Member
    Posted 6 years ago #

    Done EXACTLY what you told me to do MichaelH, but no luck AT ALL. o_O

    Is there something wrong with my cPanel? I am the host owner so I can have a look at particular specs if you need that type of information. Just let me know if you do...

    Get back to me soon.

  11. moshu
    Member
    Posted 6 years ago #

    Is there something wrong with my cPanel? I am the host owner

    Unfortunately, we cannot support server setup issues, that's beyond the scope of this forum.
    Try to get help in a specialized forum.

  12. Pixelation
    Member
    Posted 6 years ago #

    That's fine, but can someone please provide some more assistance. I have tried using Fantastico De Luxe to install WordPress and have tried doing it manually multiple times but still no luck. I am a user of WordPress before and never had problems as stated before on this topic and all I want is for this WordPress blog to work for me... It's a must have for my website and I will be losing quite a bit of traffic due to this.

    My blog is located at http://www.studio-blueprint.thefreezing.com/blog. I need some help and the answer to this problem extremely soon...

  13. MichaelH
    Member
    Posted 6 years ago #

    Well you are self hosted and still having the same problem after you try to login.

    Might check your apache and php configurations.

  14. RaisedEyebrow
    Member
    Posted 6 years ago #

    I'm feeling your pain, oh Master of the Pixel, as the same thing happened to me. I have 2 blogs, and didn't even notice until I tried to go login. I upgraded through Fantastico, but what I finally realized was that when I used to do it all myself, I had to follow all the steps, and with Fantastico it seems so easy that I forgot to deactivate the plugins. As it turns out, I was able to fix it by going back to my FTP client, renaming the plugins file (temporarily), and reloading the admin page, which then prompted me to update the database with one click, and wa la, it worked. Then I went back to rename the plugins file and that allowed me to reactivate the plugins so that all was well.

    I hope this helps- I know how it can seem hopeless when it just posts some strange code error.

  15. RaisedEyebrow
    Member
    Posted 6 years ago #

    okay- I spoke too soon. I haven't been able to reactivate any plugins yet. Maybe I was a bit premature with that advice.

  16. Pixelation
    Member
    Posted 6 years ago #

    Damn, I thought that there would have been a fix... Any luck yet RaisedEyebrow?

  17. cliffeotc
    Member
    Posted 6 years ago #

    I'm a long time wordpress user. I've been through more than 10 worpress installs. Just recently I had someone install the latest version on a new church site I'm doing a podcast for. I'm having the same issue posted in this message.

    It seems as though this is is not our server side info, but instead since mulitiple people are having this issue that it is something on the wordpress end of things..

    Any help woul be appreciated.

  18. MichaelH
    Member
    Posted 6 years ago #

    Probably too late for you cliffeotc but a possible solution is here:
    http://wordpress.org/support/topic/122367?replies=9

    Essentially need to turn off magic_quotes_runtime.

Topic Closed

This topic has been closed to new replies.

About this Topic