WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7 reCAPTCHA Extension
logged users with hidden captcha can't send messages (4 posts)

  1. andamira
    Member
    Posted 1 year ago #

    I have WP 3.5.1, CF7 3.3.3, WP-reCAPTCHA 3.1.6 & CF7 reCAPTCHA Extension 0.0.12

    Email is sent and received when the the reCaptcha is shown and properly filled, throught the CF7 form.

    But it doesn't work if the form is filled by a logged user, and the option to hide captcha for logged users is active in WP-reCAPTCHA options (Target Hide for Registered Users).

    It gives this error message when trying to send (translated from spanish):

    Validation error occurred. Please confirm the fields and submit the form again.

    I think it's a bug of this plugin.

    http://wordpress.org/extend/plugins/contact-form-7-recaptcha-extension/

  2. eric_the_grey
    Member
    Posted 1 year ago #

    I noticed the same thing, although until I read your post I didn't realize what the issue was.

    I'd really like to avoid using the reCAPTCHA with registered users, so hopefully there is an option to allow them to be able to send without using it if they are logged in.

    I'll be watching this post. :)

    Eric the Grey

  3. diskoremote
    Member
    Posted 1 year ago #

    I have the same problem. When there are registered users who use the form, the captcha is correctly hidden, but the form asks you to verify the validation settings. So the messages are not sent.
    someone has solved the problem?

  4. jfarts
    Member
    Posted 1 year ago #

    Same problem here, took me a while to figure out this option was causing my form to fail. If anybody has got any solutions I would be very grateful.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic