WordPress.org

Ready to get started?Download WordPress

Forums

Locked Out -- Redirect on Login - Firefox/IE (14 posts)

  1. plainsman
    Member
    Posted 9 years ago #

    I'm having this problem. On login, I get this string added to the end of the URL:

    /wp-login.php?redirect_to=%2Fwordpress%2Fwp-admin%2F

    This began after Firefox went buggy and (for what reason, I do not know) launched in 'Safe Mode'

    Well, I removed extensions. Re-installed Firefox. Still goofy.

    I believe I am actually logged in. I can view all of the administration pages, but upon clicking "Save", for instance, to post... more redirect to login page.

    Any ideas? I searched but did not find this?

    Edit: By the way, I tried logging in with IE and got the same results. Seems to be adding spaces, maybe, to some string? Hence the "%2"?

    Thank you.

  2. plainsman
    Member
    Posted 9 years ago #

    Has anyone else experienced this problem before?

    I get it now for every instance of an admin page. And it keeps bumping me back to the login page.

    wp-login.php?redirect_to=%2Fwordpress%2Fwp-admin%2Flink-manager.php

    Thanks.

  3. There are plenty of threads here on this issue. I can't guarantee that any have solutions, but please search for them.

  4. e-head
    Member
    Posted 9 years ago #

    yeah ... i get this all the time.

    if your server is on your LAN, i've noticed you can have problems. it's possible you ARE logged in, but the redirection just isn't working .. this was my problem. Just type the address in manually to see if this is the case.

    if that's not it, try the alternate wp-login.php file floating around.
    see this site too:
    http://codex.wordpress.org [Moderator: fixed URL - .org, not .com]

  5. plainsman
    Member
    Posted 9 years ago #

    Oh, I find things that 'mention' the problem. Not any solutions. Sorry if I did not make that clear.

    The one example of using:

    wp-login.php?login=name&pass=password

    does get me there, but it won't work for posting. Just bumps me back to login page. Nothing has been changed before this started happening. The only thing that did happen, and I do not know how/why was - I restarted my computer. Double clicked on the Firefox icon on the desktop and Firefox opened in Safe Mode. I changed that with the 'run' command they provide. Went through the uninstalls/extension dropping, etc. ... still, nothing.

    And, as I said, it is happening in IE, too.

    Yes, I believe I am logged in... but, how to 'unlogin' and then get back to posting. And, it is only happening to me on 'this' computer. Weird? The laptop - on the same lan - is working fine.

    I just don't understand. I've cleared cache, dropped old cookies, i have no 'author' cookies, dropped histories, uninstalled firefox (although it happens in IE, too) re-installed firefox ... nothing is working.

    I've run out of things I know to try. ;o(

  6. 404studios
    Member
    Posted 9 years ago #

    I'm having this same issue with a new install and have searched for a solution here and google, but cant get it going... is there any news on this?

  7. NuclearMoose
    Member
    Posted 9 years ago #

    What version of WordPress are you folks using?

  8. Read "Site URL Resetting or Redirecting under WP v1.5b" here:

    http://codex.wordpress.org/Login_Trouble

  9. 404studios
    Member
    Posted 9 years ago #

    Thank you, Macmanx - the alternate wp-login.php worked like a charm to get me logged in!

  10. Ryan Boren
    WordPress Dev
    Posted 9 years ago #

    Aside from the siteurl which is now fixed, this is usually caused by having your WordPress Address and Blog Address side-by-side. Example:

    WordPress Address: http://example.org/wordpress/
    Blog Address: http://example.org/blog/

    Unless you have a very recent nightly, this is an unsupported configuration. The wordpress address must be a subdirectory of the blog adddress. With a side-by-side configuration, the alternate wp-login.php will break some things, but it will fix your main concern -- logging in -- simply because it sets the cookie in the wordpress address rather than the blog address. This same affect can be achieved by changing the following line in vars.php.

    define("COOKIEPATH", preg_replace("|https?://[^/]+|i", "", get_settings("home") . "/" ) );

    Change it to:

    define("COOKIEPATH", preg_replace("|https?://[^/]+|i", "", get_settings("siteurl") . "/" ) );

    NuclearMoose et al, when we see these login threads, ask for the WordPress Address and Blog Address settings. I'd like to see how many of our login problem reports are due to this. This configuration should be supported in the latest nightlies, but is not supported in 1.2.2 or earlier nightlies.

  11. NuclearMoose
    Member
    Posted 9 years ago #

    rboren,
    Noted.

  12. Mark (podz)
    Support Maven
    Posted 9 years ago #

    rboren - got it, thanks :)

  13. natasp
    Member
    Posted 9 years ago #

    thanks rboren, this fixed my redirect on login problem after migrating to a new server

    v 121

    cheers

    n

  14. frankj
    Blocked
    Posted 7 years ago #

    Hi

    I have found what the issue is with this:

    1) You may have added this site to the "blocked cookie list" - delete it from there
    IE: tools > internet options > privacy > sites > look under managed sites
    If your site is there, delete it

    2) Make sure your browser is accepting cookies for this site
    Between the login and the re-direct to the correct admin page it seems like WP reads
    the cookie, if it ain't there, it will just redirect to the wp-admin page again
    IE: tools > internet options > privacy > sites > in address of website type your
    url with http:// in front and click "allow"

    3) Test by setting your security level to low.
    IE: tools > internet options > privacy > drag lever down to "accept all cookies"

    You may need to apply just 1 or all of them for it to work.

    Hope you get it working & God Bless

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.