WordPress.org

Ready to get started?Download WordPress

Forums

Events Manager
[resolved] Locations and 404 error (11 posts)

  1. Antonio
    Member
    Posted 1 year ago #

    Events Manager version 5.3.1.

    I know this problem has to do with my theme, I am using directorypress from premiumpress. I would like a best advice.

    Eveything runs ok except for the single location page. It is throwing a 404. I have done the following

    Changing my permalink structure (all options tested)
    Changing the type of location (page or post)
    changing the slug (not working either, cant change it to other than 'location')

    I am reluctant to go to the code but I will do it if I have to, I just need advice as to what to look for and what to test.

    Thank you

    http://wordpress.org/extend/plugins/events-manager/

  2. agelonwl
    Member
    Posted 1 year ago #

    Hi,

    how about if you create brand new pages and assign those as new event pages? you can call them whatever you want to begin with, reassign them in EM settings, and test them out, just to see if it works.

    Then, you can rename the slugs etc. of these pages and make them children of the events page, hopefully it’ll still work.

  3. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 1 year ago #

    changing the slug (not working either, cant change it to other than 'location')

    why is this not working? what happens when you try to change it?

  4. Antonio
    Member
    Posted 1 year ago #

    @agelonwl, will do and report back.

    @Marcus, I change and save, everything ok, but when I go to an event (from the Events listing within WP admin) the URL keeps pointing to the previous slug. Click the link, I am able to see that no problems, go to the location link and it still shows again the previous slug.

  5. Antonio
    Member
    Posted 1 year ago #

    sorry, forgot to add, if I type the new slug directly in the URL bar, it will not work.

  6. Antonio
    Member
    Posted 1 year ago #

    Some more information

    Changing the slugs for events (an I assume categories also) its working.

    But for locations it is not. I think this is related to the problem with the 404 I am getting. If I change the slug to something else, the links for locations won't reflect it. If I type it directly in the URL bar it will revert to the "location" slug.

    I am willing to let someone with knowledge access my test site as admin and check it out.

  7. Antonio
    Member
    Posted 1 year ago #

    Oh by the way, agelonwl, I changed the pages but it didn't make any difference.

  8. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 1 year ago #

    so are locations basically not working regardless of the slugs you assign it?

    Also, if your new slugs aren't being updated/reflected in your links, could it be because you have a caching plugin enabled?

  9. Antonio
    Member
    Posted 1 year ago #

    Hello Marcus, no, I have no caching plugin activated. I resorted to just not having locations link anywhere on site, I had to put the location information in the single event post.

  10. keny27
    Member
    Posted 1 year ago #

    Getting the same problem with the location page throwing a 404, if I change to a standard theme all works well but once I go back to directorypress theme the location page goes again, I would really appreciate a fix for this.

  11. agelonwl
    Member
    Posted 1 year ago #

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic