WordPress.org

Ready to get started?Download WordPress

Forums

Localisation problem on php5 (7 posts)

  1. extrem
    Member
    Posted 8 years ago #

    I have a problem with localisation on php5 - it geves me 3 warnings. 2 warnings in file gettext.php I solved with a hack, but it still shows me a warning:

    Warning: fread() [function.fread]: Length parameter must be greater than 0 in /DISK3/WWW/renatavalkova.com/www/wp-includes/streams.php on line 146

    It mayby has somemthing to do with wrong variable in gettext.php or in function read() in streams.php.

    It cuases the annoying warning in top of the page (warnings on server are on and I cannot switch them off) and also bugs in callender and menu stlye. If I switch to deafault language, everything is ok, but I really need to have it in my native language. On php4 everything worked fine.

    Thanx for help

  2. bob58
    Member
    Posted 8 years ago #

    Which version of wp are you running ?

  3. extrem
    Member
    Posted 8 years ago #

    version 1.5.2

  4. bob58
    Member
    Posted 8 years ago #

    I think, the error comes from CachedFileReader in stream.php. Is your localisation file available at the given directory (I think, wp-content/languages) and is the entry in wp-config.php spelled correctly (especially lower an upper case) ?

  5. moshu
    Member
    Posted 8 years ago #

    bob58, the languages/ directory should be in wp-includes/

    extrem, there was a fix/hack for earlier verisions to avoid this error, maybe it works:
    http://www.fredfred.net/skriker/index.php?p=84

  6. extrem
    Member
    Posted 8 years ago #

    I have the localisation file in the propper directory and the case is right - i wrote it worked fine untill the PHP version had been upgraded to version 5.

    I've also installed that hack, but it solved only par of the problem - 2 warnings in gettext.php, but this one: "Warning: fread() [function.fread]: Length parameter must be greater than 0." still apears. I think it should fix this warning too, but it didn't. Mayby because that hack is for earlier version.

  7. extrem
    Member
    Posted 8 years ago #

    Really nobody uses WP with localized MO file on PHP5 server?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.