WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] localhost works can't see on wife's PC (9 posts)

  1. twist-throttle
    Member
    Posted 6 years ago #

    I am trying to setup my development environment at home.

    My PC is an 7.10 Ubuntu Linux box with Apache2, PHP5, MySQL, PHPMyadmin, Static IP behind my router/gateway to my cable modem & etc.

    I have a local wordpress install for development, which seems to be working just fine on the Linux Dev PC, I can view my local wordpress site via http://localhost and/or 127.0.0.1, BUT my problem is that I can not see this same local site from my wife's PC, which is on the same network/workgroup.

    From her Windows XP PC, when I type in the browser my Linux IP address of 192.168.2.200, I do see the wordpress directory listed, as well as the single test.php file that I have there. Still from my wife's PC, when I click on the test.php file that is on my Linux PC, this file displays in her browser as it should, displaying my Linux PHP info that the file is supposed to do.
    But when I click on the wordpress directory from her PC (as well as enter the url of 192.168.2.200/wordpress), the browser pauses for a second or two, then just gives me the generic browser error: IE7 – “IE can not display the webpage” & Firefox says - “can't establish a connection to localhost”... wait! That might be something... the url now says localhost, instead of the Linux IP address... her PC has no localhost running, so of course that would error out... her browser should still keep the 192.168.2.200 IP address in the url.
    Hmmm... IE7 doesn't say localhost in it's url after the error, it still says 192.168.2.200/wordpress.

    Oh, so my Apache Access Logs say that I'm getting a 301 error:
    192.168.2.100 - - [07/Nov/2007:19:13:47 -0600] "GET /wordpress/index.php HTTP/1.1" 301 - "-" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; InfoPath.1)"
    192.168.2.100 - - [07/Nov/2007:19:13:59 -0600] "GET /wordpress/index.php HTTP/1.1" 301 - "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9"

    So yea, on my Linux PC, I can view the test.php & wordpress site just fine. But from her PC, I can only display the test.php file in the browser & see the directory listing of the wordpress install... but clicking the wordpress directory in her browser... this doesn't work.

    1. It seems that PHP is working fine on the Linux server
    2. It seems that her Windows browser is not being blocked from the Linux apache server.
    3. I can view the local wordpress site on the Linux PC, but not on her PC that is on the same network.

    Finally, I am posting this both on the wordpress & Ubuntu forums... I appreciate any advice or directions for me to search further.

  2. Kafkaesqui

    Posted 6 years ago #

    What are your WordPress and Blog address settings (Options > General) in WordPress? localhost (or 127.0.0.1), or 192.168.2.200?

  3. twist-throttle
    Member
    Posted 6 years ago #

    I didn't think of this.
    I had them both as http://localhost/wordpress

    So now I just switched them both to 192.168.2.200/wordpress but that didn't change my results on her PC. I did restart Apache after this, just to make sure... but it is still behaving the same.
    This sounds like it could be something that I need to adjust though... do you have any more suggestions?

    Thanks

  4. twist-throttle
    Member
    Posted 6 years ago #

    Oh, wait! I redid this one more time...
    I set both of these to http://192.168.2.200/wordpress and it seems to be working now.

    Now my local url on the Linux Dev PC is http://192.168.2.200/wordpress/ instead of http://localhost/wordpress/

    I suppose that this fine, it just seems weird to not have it localhost or 127.0.0.1
    Do you see any issues with this?

    Thank you very much for your assistance.

  5. moshu
    Member
    Posted 6 years ago #

    Every machine in the world thinks of localhost as being itself! So, you will never see anything from another machine if the URI is set as localhost...

  6. twist-throttle
    Member
    Posted 6 years ago #

    Well now both on her PC, as well as my PC where I have Apache & my local install of my Dev worpdress... I'll use the url of 192.168.2.200/wordpress to access my development install of my site.

    Yes, I expected to use the 192.168.2.200 IP from her remote PC, but not from the Dev PC where that is it's own IP... I expected either localhost or 127.0.0.1.

    But anyways... enough of the IP's, huh :)

    I consider this issue resolved & now I'm up & running as I needed.
    Thanks for your help on this.

  7. jq66
    Member
    Posted 6 years ago #

    If entering http://localhost/wordpress/ returns the main parent directory index of wordpress, have I installed it incorrectly?

  8. Chris_K
    Member
    Posted 6 years ago #

    You really should've started a new topic. Aside from the word "localhost" there's no relation...

    And to answer your question, configure your web server to recognize index.php as a default.

  9. dpmcalister
    Member
    Posted 6 years ago #

    I've got the same problem as twist-throttle. I can see the WordPress installation fine on my laptop but when I try to connect from my desktop it defaults to localhost. I've changed both entries in General Settings to read the IP address of my laptop in place of localhost and even restarted Apache (I'm running XP Pro with xampp) but no joy.

    I can see other, non-WordPress stuff on my laptop from my desktop (and can even log into phpMyAdmin from the desktop so it's not a MySQL problem (that I can see)).

    Any help gratefully received. It's not urgent as I only want to use the desktop to test different screen resolutions (my laptop caps out at 1024x768) but I would like to get it working :)

    Thanks.

    Edit: Apologises if I should have started a new topic, but I thought it easier to use this one as it's the same problem.

Topic Closed

This topic has been closed to new replies.

About this Topic