WordPress.org

Ready to get started?Download WordPress

Forums

Localhost no access to my blog (18 posts)

  1. garyward22
    Member
    Posted 3 years ago #

    Hi, Not sure what I am doing wrong but this is what I have done. Downloaded my blog from web host iPage.
    Installed WAMP server on my PC which seemed to install OK. Moved my blog into the folder www - this might be my first problem?
    When I click on any file in my blog it opens up Dreamweaver (which I have installed on this Laptop) this might be my second problem.

    I assume I have to put some settings into wordpress to access my blog on localhost? However any file I open still opens Dreamweaver - which I don't want to uninstall.

    Is there anybody that can guide me through how to resolve this issue?

    Thanks

  2. arrentan
    Member
    Posted 3 years ago #

    Have you downloaded your database backup dump and restored it to your MySQL server?

    Also, you will need to change your database host localhost if your database was previous hosted other than localhost. You will need to check it on your wp-config.php file.

  3. 2ninerniner2
    Member
    Posted 3 years ago #

    Howdy,

    1) create a folder within WWW and place your WP files in there; keeps things more organized and is easier to maintain; this folder name will then be how you access your local site:

    http://localhost/folder_name <"front end" of site ... what you would see on the web

    http://localhost/folder_name/wp-admin <access to the "back end" log in>

    2) as mentioned above, you must also export your WP database that is on your iPage installation; I am not familiar with that set up so you may want to install a plugin such as myEASYbackup to make that easier; once you have this database export file (it should have the .sql extension), you will then need to create a new, empty database from withing WAMP and then import into it, the above noted .sql file

    3) most importantly: WAMP MUST BE RUNNING!!! You MUST start Apache and MySQL before you can either do any of the database items (requires accessing phpMyAdmin) or viewing your site or accessing site admin area.

    NOTE: ALL this assumes you had a WordPress installation on this "iPage" account; as I said, I know nothing about this; if, however, this is a "blog" that is set up by iPage, then that is another story!

    And ALSO: WordPress is NOT, I say again, is NOT an executable that you "double-click" to start/run!!! It is a web PROCESS that is accessed by your browser from a web server!!! (which in your case presented here, is what WAMP is doing).

    Cheers!
    Lyle

  4. govpatel
    Member
    Posted 3 years ago #

    Did you change the urls in Settings General as they should be http://localhost/foldername

  5. garyward22
    Member
    Posted 2 years ago #

    HELP - Im still struggling. The blog shows on the Internet fine so that all works http://www.jowyndhamward.com

    Update to where I am.

    1) Couldn't get Apache running - found out that Skype on Port 80 was causing the server not to run - fixed
    2) have Apache and MySql running in XAMPP (InGreen and running and can access service status
    3) Imported the database from my webhost (iPage) and that seems to have imported there OK - exported from webhost and imported locally
    4) I am sure there are some other settings I should change in wordpress
    5) When I click on Admin in XAMPP for either Apache of MySQL should anything happen?
    6) I assume I do not have to install wordpress locally and then copy over my blog. I have assumed that if I move everything (admin,content,includes etc)from my webhoster that is the complete wordpress install.
    7) Everytime I try to open one of the wordpress files - Dreamweaver opens it - cant seem to stop that!
    8) To access my blog locally http/localhost/www/joblog - correct? and add wp-admin to access dashboard?
    9) Just managed to open wp-admin with Notepad. The current DB hostname shows 'jowyndhamwardcom.ipagemysql.com' - should I change this to 'localhost'
    I did not know where "urls in Settings General" were so didnt do that

    I think I am close and just need a little more guidance!! Many thanks

  6. govpatel
    Member
    Posted 2 years ago #

    Your site may be opening fine as may be it is still coming from your host as you still have not changed the urls.

    You will need to change In your localhost phpmyadmin use one of the methods here
    http://codex.wordpress.org/Changing_The_Site_URL

  7. garyward22
    Member
    Posted 2 years ago #

    Hi, Perhaps I missed saying that I only want to use the localhost to make alterations/testing before I go live. The site will remain on my webhosting service (iPage)and of course that is still fully operational. It is the local version of my Blog that I am trying to get up and running so I can make changes, test and otherwise edit before doing it for real. Hope that makes more sense.

    Thanks

  8. govpatel
    Member
    Posted 2 years ago #

    Yes even then you will need to change urls as you are using the copy database that is installed locally so matter of fact you have completely separate database to test and alter once you are satisfied with changes you make locally do the same on online server.

  9. garyward22
    Member
    Posted 2 years ago #

    OK - I have looked at the link but now more confused. In wp-config I have changed it to localhost as below. Should this be more explicit - like localhost/www/joblog or something else.

    Please remember that this is a standard install - I have only created one folder called JoBlog in the folder www which has all the downloaded files from my webhosting server

    /** MySQL hostname */
    define('DB_HOST', 'localhost');

    Apologies for my stupidity!

  10. govpatel
    Member
    Posted 2 years ago #

    /** MySQL hostname */
    define('DB_HOST', 'localhost');

    In wp-config.php file in your lacal install is fine

    It is urls in settings general which are saved in database are the ones you need to change in
    local install it should be
    http://localhost/JoBlog

  11. garyward22
    Member
    Posted 2 years ago #

    Hi,

    I am still none the wiser - where do I locate urls in settings general so that I can change to
    http://localhost/JoBlog

    I need the idiots guide.

    Thanks

  12. govpatel
    Member
    Posted 2 years ago #

    Is there any way for you log in local admin panel http://localhost/JoBlog/wp-admin if so click on Settings General and you will see the urls there if you can not log in then you can change theme following instructions in link I posted above
    http://codex.wordpress.org/Changing_The_Site_URL
    or if you like you can see videos on my website

  13. garyward22
    Member
    Posted 2 years ago #

    Hi As the title says - no access to my blog - or anything else! However in my search for a solution an earlier poster said put my blog in a folder called www. However in reading problem solving for XAMPP I have found out it should be in htdocs. I have moved it there and def feel I am getting closer to displaying something. Now when I try localhost/JoBlog I get an error saying cannot establish database connection. I have checked again in the file wp-admin (still opens in Dreamweaver)which i manually choose notepad to open the file and all the info seems to be correct DB name, DBuser, password , hostname. These are the ones downloaded from my web hosting service and seem to match the file names which appear in Mysql locally when I look at Myphpadmin. My only thought is should hostnmae be localhost/JoBlog? Other then that I am stuck again. Very frustrating - didn't think this would be that hard to do!

    Thanks again if anybody can assist me.

  14. garyward22
    Member
    Posted 2 years ago #

    Maybe closer. Have accessed the sql database and have located the file wp-options. I have edited two filelds siteurl and home and entered http://localhost/JoBlog in both. However I still have a database error connection could not be established. Should this path be http://localhost/htdocs/JoBlog?

    Desperate!

  15. govpatel
    Member
    Posted 2 years ago #

    recheck your wp-config.php file and see if you right info for the database as it will different from online server install

  16. Furniture
    Member
    Posted 2 years ago #

    I have the same problem ...

  17. garyward22
    Member
    Posted 2 years ago #

    Rechecked wp-config. The file is located in C:/xampp/htdocs/JoBlog. This what it looks like - not sure if I am risk by publishing some of this but I assume without the password its OK. Please delete this post if not safe - I also have made some small changes to the names in this post as well just in case! In MySQL database which I downloaded from my web hosting service and imported locally - I made the following changes -

    In the database

    localhost - wrd_1cdh7he999 - wp_options I changed in wp-options

    siteurl - to http://localhost/JoBlog (should this be the URL of the Blog)??? http://www.jowyndhamward.com
    home - to http://localhost/JoBlog

    Below is the wp-config file - the only item I am unsure about here is the MySQL database username - this is obviously the user name which was created when I set up WordPress on the Web Hosting service. I cannot find where this is stored in MySql or wordpress but assume this is all correct.

    / ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'wrd_1cdh7he999');

    /** MySQL database username */
    define('DB_USER', 'wrd2Ou0aak2');

    /** MySQL database password */
    define('DB_PASSWORD', '123456789');

    /** MySQL hostname */
    define('DB_HOST', 'localhost');

    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');

    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');

  18. garyward22
    Member
    Posted 2 years ago #

    To add some more info to the problem - I looked in the error log for Apache and found these entries - these occured when I cahnged the sysntax to access the blog. Does it matter that it is accessing the IP address rather than localhost? Also it seems to be looking thru two xampp folders - not sure why?

    [Thu Aug 04 15:06:15 2011] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/JoBlog
    [Thu Aug 04 15:06:44 2011] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/jowyndhamward.com
    [Thu Aug 04 15:06:54 2011] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/jowyndhamward
    [Thu Aug 04 15:07:18 2011] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/htdocs

Topic Closed

This topic has been closed to new replies.

About this Topic