WordPress.org

Ready to get started?Download WordPress

Forums

Local WordPress (Xampp) Permalink Problems (6 posts)

  1. mrleesimpson
    Member
    Posted 4 years ago #

    Hi all!

    I'm trying to get a local version of WordPress running using Xampp however for whatever reason I can not get Permalinks to work along side Static Homepage.

    Permalinks work using '/?page_id=x' but not in any other format.

    I have already tried the solution explained here and various other places, but still nothing.

    Can anyone shed any light on this?

    I'm not sure if it makes any difference but I'm using a live database.

    Thanks!

  2. Kailash
    Member
    Posted 4 years ago #

    If mod_rewrite is loaded then custom permalink should work. Make sure you have added the required code in your .htaccess file. Also, are you receiving any error message?

    Note: If you have just enabled mod_rewrite then you may need to restart Apache.

    Kailash

  3. mrleesimpson
    Member
    Posted 4 years ago #

    @Kailash1

    Check, check and check.

    Got all those done.

    Still not working though.

  4. mrleesimpson
    Member
    Posted 4 years ago #

    I've just tried to reinstall Xampp and by default

    LoadModule rewrite_module modules/mod_rewrite.so

    has no #.

    Is this normal?

  5. mrleesimpson
    Member
    Posted 4 years ago #

    I've just tried this using Wamp and I get the same results. I'm thinking that prehaps my .htaccess possibly isn't right after all.

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
  6. Paul Phillips
    Member
    Posted 4 years ago #

    Try changing the configuration back to default and then back to the one you want. WordPress should update the .htaccess file. If it doesn't you need to make sure the .htaccess is writeable.

Topic Closed

This topic has been closed to new replies.

About this Topic