WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Local server is missing categories (4 posts)

  1. Keys88
    Member
    Posted 4 years ago #

    I'm not sure if this question belongs here ... I hope so ...

    Using my Mac's internal Apache server to develop my theme, everything works fine except that it's missing the category listings. I would appreciate help with fixing this.

    I’m working with Classic 1.5 theme, but the response is identical when I switch to Default 1.6.

    I had changed the default Uncategorized to Notes, and then to test this problem I added several other categories (Notes 2, Notes 3, etc) and assigned my sample post to all of them.

    All these categories show up in my sample post, in the sidebar menu, and in the admin screens -- everywhere you’d expect to see any reporting of Categories.

    In the Categories screen, all the slugs show up as being correctly written, and when I change the name of a Category or add a new one, the change appears immediately in all the expected places.

    But ...

    When I click in the post or in the sidebar menu on any of the category names to see what’s listed there, I get error 404:

    | “The requested URL /[mysite]category/notes-5/ was not
    | found on this server.”

    Everything else in the whole site works perfectly.

    Any guidance will be much appreciated.

    Thank you.

  2. Keys88
    Member
    Posted 4 years ago #

    The problem is more serious than I'd thought.

    I can see my posts in the front page, but when I click on them for their individual pages, I get the same error message: "not found on this server".

    And when I click on Archives, same: "not found on this server".

    I have two pages (About and another one) that do show up just fine.

  3. Keys88
    Member
    Posted 4 years ago #

    A self-repairing problem ...

    I went through all my admin settings and tried to make everthing look as generic as possible ... and now the problem is cleared up.

    I wish I could report the solution, in case anyone else ever has this problem, but I'm not sure. Something to do with the date formats?

    Maybe it's just simply: "Be careful when fiddling with settings".

  4. Mark / t31os
    Moderator
    Posted 4 years ago #

    It means your permalinks are not working, if you set them to default does everything then work... i'll take a guess and say yes it will...

    Test default anyway..

    Then once you've done that check mod_rewrite is enabled in apache, if not, enable it, and restart apache.. then try setting the permalinks again....

    If it's enabled already (mod_rewrite), then try adding the following at the top of .htaccess.

    Options +FollowSymLinks

    .. and test again..

    EDIT:: Or maybe not then... if it's working again .. forget the above.. ;)

Topic Closed

This topic has been closed to new replies.

About this Topic