WordPress.org

Ready to get started?Download WordPress

Forums

Local Installation of WP Multisite (14 posts)

  1. topracer6969
    Member
    Posted 3 years ago #

    At Andrea's request, I'm starting a new thread on this seemly complex (yet simple) issue of trying to setup a local development workflow.

    Background: I have a site that is currently live: http://jobs.localjobs.com

    It was setup using multisite....subdomain setup.

    I wanted to be able to work on WordPress locally - and utilize Dreamweaver CS5 as an authoring tool as it has some rather nifty new features that make working with PHP, CSS and other file formats real easy for a newbie like myself.

    So, in thinking that i needed to emulate the kind of environment I wanted to have ultimately LIVE (multisite w/subdomains) - I needed to set that up locally as well. I may be wrong here based on Andrea's last post in another thread.

    So - first question. Is this accurate? Do I need to setup a subdomain version locally in order to ultimately publish that same site to a web server for public viewing. If not, then I'm sure I can easily setup the subfolder approach...as that is pretty straight forward.

    Heres the tricky part....after reading an older thread on this same subject....it sounded like I needed to make some modifications to a few files on my local machine in order to be able to add new sites to a network install of WP. So, here's where I"m at:

    Here's my configuration: I'm on a MAC, using MAMP.

    A few background setup items of note:

    1. My local WP site is NOT yet in 'multisite' mode - still in standard WP install mode (latest version 3.0.1) as I didn't know whether to choose 'subdomain' and just ad virtual hosts (which is what I tried to prep for as noted below), or 'subfolders' approach.

    2. I've updated my 'hosts', 'httpd.conf' and 'vhosts.conf' files....pretty much exactly as outlined in this article on 'How to setup a virtual hosts in the Mamp environment': http://danilo.ariadoss.com/how-to-setup-virtual-hosts-mamp-environment/

    3. I'm using the following 'hosts' file settings:
    # localhost is used to configure the loopback interface
    # when the system is booting. Do not change this entry.
    ##
    127.0.0.1 localhost
    255.255.255.255 broadcasthost
    ::1 localhost
    fe80::1%lo0 localhost
    127.0.0.1 localhost
    127.0.0.1 pbn.dev pbn-asheville.dev

    and the following 'httpd.conf' Virtual Hosts section text reads:

    NameVirtualHost *:8888
    Include /Applications/MAMP/conf/apache/vhosts.conf

    And the following 'vhosts.conf' section:
    #
    # Virtual Hosts
    #
    # VirtualHost example:
    # Almost any Apache directive may go into a VirtualHost container.
    # The first VirtualHost section is used for all requests that do not
    # match a ServerName or ServerAlias in any <VirtualHost> block.
    #
    # <VirtualHost *:8888>
    # ServerAdmin webmaster@dummy-host.example.com
    # DocumentRoot "/www/docs/dummy-host.example.com"
    # ServerName dummy-host.example.com
    # ServerAlias http://www.dummy-host.example.com
    # ErrorLog "/private/var/log/apache2/dummy-host.example.com-error_log"
    # CustomLog "/private/var/log/apache2/dummy-host.example.com-access_log common"
    # </VirtualHost>
    #
    # <VirtualHost *:8888>
    # ServerAdmin webmaster@dummy-host2.example.com
    # DocumentRoot "/www/docs/dummy-host2.example.com"
    # ServerName dummy-host2.example.com
    # ErrorLog "/private/var/log/apache2/dummy-host2.example.com-error_log"
    # CustomLog "/private/var/log/apache2/dummy-host2.example.com-access_log common"
    # </VirtualHost>
    #

    <VirtualHost *:8888>
    ServerName localhost
    DocumentRoot /Applications/MAMP/htdocs/PBN/
    <Directory /Applications/MAMP/htdocs/PBN/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Order allow,deny
    allow from all
    </Directory>
    </VirtualHost>

    ----------------------------(my separation line)--------

    My problems:

    1) I can login via my browser by using: http://pbn-asheville.dev:8888/ or http://pbn.dev:8000 - however, any links I click end up going to a page that reads:

    Not Found
    The requested URL /PBN/ was not found on this server.
    Apache/2.0.63 (Unix) PHP/5.3.2 DAV/2 Server at localhost Port 8888

    2) I'm under the impression that I should be able to login using simply http://pbn.dev -- in other words, without having to use port number at the end. However, when I try this I just get the following error:
    Safari can’t open the page “http://pbn.dev/” because Safari can’t connect to the server “pbn.dev”.

    Please advise what I'm doing wrong here. Am I almost there. Do I need to start over. Or, ......???? Looking forward to some REAL direction here. Thanks.

  2. IIRC, you can't use subdomains on localhost without some DNS jiggering.

  3. topracer6969
    Member
    Posted 3 years ago #

    I'm sorry, but that doesn't tell me anything helpful. Can you be more specific on my last sentences.

    I've had Andrea tell me you can't use subdomains with wildcard, but you CAN "if' you want to put them in manually. So which is it...need a final answer of either YES YOU CAN USE SUBDOMAINS or NO YOU ABSOLUTELY CANNOT use subdomain setup locally?

    If YES, isn't what I did above the correct way to do this?
    If NO, then I guess the only option is to reinstall WP, make it subfolder setup and then figure out how to use a local version that's subfolder setup...yet, a live site that's subdomain.

    Aaaaarrrrrggggg. Solid direction anyone? Thanks in advance to all takers.

  4. Well, the answer is yes, it CAN be done, but you have to change your local computer's DNS setup to redirect. And I have no idea how to do it, BUT I know if you google something like "wpmu localhost subdomains" you should find something. Its been gone over here before.

    So you CAN do it. But it does NOT work out of the box.

  5. topracer6969
    Member
    Posted 3 years ago #

    From what I've read...modifying correctly the vhost, hosts and httpd files can get this going correctly. But, I'll still have to manually enter the new subdomains into the 'hosts' file. Am looking for someone that has done this to review my file code above and confirm if I'm there.

  6. Given the above, it looks like you *can* use virtual subdomains on MAAMp. So, no worries there.

    the actual problem you have is the port number in the URL. Setting up a network won't work with the port number.

    Change your named virtual host to not have the port, if you can. (No, I dunno how to do that locally on a Mac.)

  7. This guy touches on I think what may be the answer: http://mu.wordpress.org/forums/topic/16760

    But ... There's a reason I don't do MAMP on my mac anymore ;) In theory, it's the same as any *nix install.

  8. topracer6969
    Member
    Posted 3 years ago #

    OK....am taking the 'path of lesser resistance here - going to start over and go the subfolder approach to install.

    So - I deleted all...reinstalled WP, tried to setup multiuser and got the proverbial error message - Error: You cannot install a network of sites with your server address. You cannot use port numbers such as :9016. HOWEVER, I am able to pull up something if I enter: http://pbn.dev:8888/ -- when I do this, I get the "Index of / screen with the root folder PBN -- which I can click that and the site opens. When it opens, the URL is: http://pbn.dev:8888/PBN/

    Uggghhh. I just want it to open with http://pbn.dev (which would be the main site for a multisite blog).

    So, followed the thread (ABOUT THE 20TH TIME) at http://wordpress.org/support/topic/wordpress-3-network-multisite-on-a-local-development-site?replies=43 - and made the mods suggested to my 'hosts' and 'httpd.conf' files. I still can't open up the page in a browser. Getting the following error messages:

    Safari can’t connect to the server.
    Safari can’t open the page “http://pbn.dev/” because Safari can’t connect to the server “pbn.dev”.

    Here is the text of my 'hosts' file:

    # localhost is used to configure the loopback interface
    # when the system is booting. Do not change this entry.
    ##
    127.0.0.1 localhost
    255.255.255.255 broadcasthost
    ::1 localhost
    fe80::1%lo0 localhost
    127.0.0.1 PBN.dev

    Here is the bottom portion of the 'httpd.conf' file:
    NameVirtualHost *
    <VirtualHost *>
    DocumentRoot "/Applications/MAMP/htdocs/"
    ServerName localhost
    </VirtualHost>

    <VirtualHost *>
    DocumentRoot "/Applications/MAMP/htdocs/"
    ServerName PBN.dev
    Alias /PBN.dev "/Applications/MAMP/htdocs/PBN"
    <Directory "/Applications/MAMP/htdocs/PBN">
    Options Indexes FollowSymLinks Includes ExecCGI
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>
    </VirtualHost>

    -------------- Can someone please advise me of where I'm going wrong here. SO MUCH thanks in advance. I've seriously been pulling what little hair I have left out of my head for the last two days trying to get a local dev environment setup. Waiting with eager anticipation.

    FYI...I have MAMP running using default port settings for both Apache and MySQL and my site is stored in the /Applications/MAMP/htdocs/ folder....

  9. So - I deleted all...reinstalled WP, tried to setup multiuser and got the proverbial error message - Error: You cannot install a network of sites with your server address. You cannot use port numbers such as :9016. HOWEVER, I am able to pull up something if I enter: http://pbn.dev:8888/ -- when I do this, I get the "Index of / screen with the root folder PBN -- which I can click that and the site opens. When it opens, the URL is: http://pbn.dev:8888/PBN/

    Uggghhh. I just want it to open with http://pbn.dev (which would be the main site for a multisite blog).

    So, followed the thread (ABOUT THE 20TH TIME) at http://wordpress.org/support/topic/wordpress-3-network-multisite-on-a-local-development-site?replies=43 - and made the mods suggested to my 'hosts' and 'httpd.conf' files. I still can't open up the page in a browser. Getting the following error messages:

    That thread doesn't have anything to do with making your server respond to local domains without the port number.

    You absolutely have to clear that up first - over and above any WordPress issues.

  10. topracer6969
    Member
    Posted 3 years ago #

    Yes I know....that's my problem. Do the two system files 'hosts' and 'httpd.conf' look correct?

  11. topracer6969
    Member
    Posted 3 years ago #

    So - can anyone tell me if the two files I'm using are accurate give the desire to host a local wp multisite Dev environment? At this point I'm looking for someone who has successfully setup a Local host WP multiuser Mac platform using MAMP. Thanks....

  12. topracer6969
    Member
    Posted 3 years ago #

    The first link (Andy's video) are what I followed initially. Didn't work. However, the second link worked like a charm. I'm good so far. I'm not at the point of configuring the site as a multiuser WP install....and while my site is running fine, I'm a bit stumped as to a few more settings. Will create a new post for those. Thanks.

  13. los1sol
    Member
    Posted 3 years ago #

    In case this helps anyone, the problem you were having all along seems to be you left your port settings as MAMP had them listed by default. I followed a tutorial that had me change them to 80/3306 from the start (http://wpcandy.com/teaches/how-to-install-wordpress-locally-on-a-mac). This probably may have avoided your initial problem I'm guessing.

    In any case, looks like you got it working anyway. That's a nice tutorial as well. Tempted to follow it...

Topic Closed

This topic has been closed to new replies.

About this Topic