WordPress.org

Ready to get started?Download WordPress

Forums

Local installation of WP 2.7 with EasyPHP not working (21 posts)

  1. lucianosb
    Member
    Posted 5 years ago #

    I am trying to install WordPress 2.7 running a local Apache server built with EasyPHP. I use this installation for development porpuses only and it has always worked until version 2.6.5

    After configuring and installing the database via wp-admin/install.php, I can't access no other page. Wp-login.php becomes a blank page and so does the root directory.

    I've tried it in Google Chrome, Flock, IE7, FF2. And haven't got any luck with these browsers.

    What could possibly be the problem? Thanks in advance...

  2. whooami
    Member
    Posted 5 years ago #

    use error logging.

  3. elfin
    Moderator
    Posted 5 years ago #

    I have various versions of WordPress running on 2 different version of easyphp with no problem here.

    I'd suggest you check that all the wordpress files were correctly copied to your www (htdocs or whatever) correctly.

  4. djpushplay
    Member
    Posted 5 years ago #

    I have this exact same problem on 2 computers using the latest EasyPHP running on Vista 32bit and 64bit and WP2.7. The previous version worked fine but for some reason, 2.7 seems to time out for some reason. This happens even when looking at a regular (non-admin) page. I tried upgrading to 2.7 as well as a clean new install with the same results.

    Interestingly, the same files when uploaded to my real servers work fine, and am having this problem ONLY on my local computers running EasyPHP.

    To ELFIN (last poster), what version of EasyPHP are you running? Also what OS and WP versions? I'll try to duplicate your setup and hopefully it'll work.

    CORRECTION: After checking the EasyPHP website, I realized that I am running the previous version and not 3.0. I'll try again with 3.0 and see if that changes anything and report back here.

  5. djpushplay
    Member
    Posted 5 years ago #

    After turning on debug, I figured out that it was timing out on trying to open a stream. The warning and error produced was (URL's shortened):

    Warning: fopen(http://localhost/beta/wp-cron.php?check=cb7fcb14031d19ae88b73845b3b2e3ef) [function.fopen]: failed to open stream: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. in C:\Users\Z\Documents\My Web Sites\wp-includes\http.php on line 783
    
    Fatal error: Maximum execution time of 30 seconds exceeded in C:\Users\Z\Documents\My Web Sites\wp-includes\http.php on line 783

    I'll keep digging a little more.

  6. djpushplay
    Member
    Posted 5 years ago #

    After more digging, this is what I've come up with.

    Under Windows XP SP3, WP 2.7 and EasyPHP 3.0, everything works without any errors.

    Under Vista SP1 32bit, WP 2.7 and EasyPHP 3.0, it works but you will get the following error at the top of your pages (this is without DEBUG on):
    Warning: fopen(http://localhost/beta/wp-cron.php?check=57f2a55d70fa1b11d1b9c14d730c0b0f) [function.fopen]: failed to open stream: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. in C:\Users\Z\Documents\My Web Sites\wp-includes\http.php on line 783

    Under Vista SP1 64bit, WP 2.7 and EasyPHP 3.0, you get the same error but there will be a very long delay (probably 30+ seconds) before you see anything on the screen.

    I guess I need to find a way to dual boot XP on my computer.

  7. syncmaster1
    Member
    Posted 5 years ago #

    here another victim of this really strange behaviour.
    never saw anything like it.
    maybe we should use xamp instead of easyphp.

  8. elfin
    Moderator
    Posted 5 years ago #

    I'm still using older version, hadn't realised easyphp 3 was out.

    Yes with WP2.7 there was a definite slow down locally, but after the initial timeout everything works fine. If easyphp3 is causing a problem, try using version 2, it might help.

  9. syncmaster1
    Member
    Posted 5 years ago #

    elfin,
    which version do you use?
    i use 2.0b1 with vista. never had a problem with other php/sql sites before.
    but i cannot even make a new post. sometimes suddenly it works but most of the time i get a blank page after a minute......
    as i understand it is the same with version 3..

  10. elfin
    Moderator
    Posted 5 years ago #

    generally I use easyphp 1.8, with occasional tests via easyphp2.

  11. solomenu
    Member
    Posted 5 years ago #

    apache + easyPHP + vista + wordpress 2.7 (en español)

    la SOLUCIÓN es:

    substituir: fopen($url, 'r', false, $context);
    por: fopen($url, 'rb', false, $context);

    adiós!!

  12. solomenu
    Member
    Posted 5 years ago #

    sorry, se me olvidaba...

    hacer los cambios en http.php

  13. djpushplay
    Member
    Posted 5 years ago #

    Previously, I stated that I had DEBUG off, which was not correct. In all versions, I had the following code added to wp-config.php:

    define('WP_DEBUG', true);
    set_time_limit(0);

    Without the last line, the code simply times out with a blank screen.

    I tried adding the "binary" to the fopen as per solomenu's suggestion and found the same results as before.

  14. djpushplay
    Member
    Posted 5 years ago #

    I have come up with a working solution to this problem. I would appreciate anybody else having the problem posting here if this works for them as well.

    You must replace /wp-includes/cron.php with the previous version (WordPress 2.6.3) and the problem will go away. Only replace that one file. No other changes are needed.

    I have not figured out why 2.7 works in XP but not Vista. I'm guessing that there's a setting in Vista that needs to be changed (e.g. Firewall, UAC, virus protection) to make this work but have not been able to solve it that way.

    I noticed the version in WordPress 2.7 does not contain the following code that is in 2.6.3:

    if ($parts['scheme'] == 'https') {
    		// support for SSL was added in 4.3.0
    		if (version_compare(phpversion(), '4.3.0', '>=') && function_exists('openssl_open')) {
    			$port = isset($parts['port']) ? $parts['port'] : 443;
    			$argyle = @fsockopen('ssl://' . $parts['host'], $port, $errno, $errstr, 0.01);
    		} else {
    			return false;
    		}
    	} else {
    		$port = isset($parts['port']) ? $parts['port'] : 80;
    		$argyle = @ fsockopen( $parts['host'], $port, $errno, $errstr, 0.01 );
    	}

    I don't know if this has anything to do with it, but that's just one difference.

  15. steveste
    Member
    Posted 5 years ago #

    djpushplay,

    Nice work - I'll confirm that this solved the problem - I experienced the exact same thing (on Vista 32bit SP1).

    I can now long into Admin.

    The problem I am still encountering is that I get a blank page when trying to open index.php from the root directory. The debug output is below. Anyone have any ideas? I can't seem to remove them from within the Admin console. I did copy the database from a host site to a local system so perhaps the database got screwed up? Anyone know what settings one should copy when backing up a database?

    Notice: Undefined index: rate in \plugins\wp-postratings\wp-postratings.php on line 559

    Notice: Undefined index: pid in \plugins\wp-postratings\wp-postratings.php on line 560

    Notice: Undefined index: postviews_id in \plugins\wp-postviews\wp-postviews.php on line 536

  16. djpushplay
    Member
    Posted 5 years ago #

    Steveste:

    Looks like you need to turn off your ratings plugin but not sure why you'd get an error there. Maybe this plugin is not compatible to 2.7. I'd suggest you turn off ALL your plugins before you upgrade to 2.7 (probably too late).

    I'm glad the other fix worked for you. I was scratching my head for weeks on that one.

  17. Dylan Kuhn
    Member
    Posted 5 years ago #

    I was getting this error from http.php line 972 with

    Vista + XAMPPLite 1.6.8 + WP trunk 10943

    solomenu's solución works for me.

    muchas gracias por eso, solomenu!

  18. vicentginer
    Member
    Posted 4 years ago #

    I have a very similar problem.

    I've installed EasyPHP 2.0b1, and WP 2.7. Windows XP.

    I follow the instructions. The database is accessed correctly. The installation asks me for a name for the site and an e-mail. Then I click on "Install WordPress", but the password never appears!

    Then, if I go to the database, I see that 10 tables have been created and that there is an "admin" user in the users table, but I think the password in that table is encripted or something. I don't know which is my password, so I can't enter into the admin zone. :-(

    Any idea about where/what is the problem?

  19. mographtv
    Member
    Posted 4 years ago #

    I'm having the same problem, I guess I might have to drop Godaddy... this is garbage.

  20. vicentginer
    Member
    Posted 4 years ago #

    Still looking for a solution.

    I haven't been able to successful install Wordrpress locally on easyPHP 2.0b1. :-(

  21. vicentginer
    Member
    Posted 4 years ago #

    Hello again.

    At last, I found the problem and the solution.

    The problem is a kind of interaction with Trend Micro Internet Security (antivirus software). I disabled it and the installation of WordPress on EasyPHP went OK!!

    Previously, I had also tried with XAMPP, but the problem was the same.

    I don't know nothing about ports being used or other kinds of interactions or behaviors of Trend Micro, so I think I am going to move to another antivirus solution.

Topic Closed

This topic has been closed to new replies.

About this Topic