WordPress.org

Ready to get started?Download WordPress

Forums

Local install problems (have already searched forum) (6 posts)

  1. esentziak
    Member
    Posted 4 years ago #

    Good afternoon

    I simply cannot get the install to my PC to actually install.

    I have followed the instructions as found on the Internet:

    1) installed XAMPP
    2) downloaded WP and installed it in the C:\xampplite:htdocs directory
    3) changed the wp-config-sample.php and saved it as wp-config.php with the following:
    ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'wordpress');

    /** MySQL database username */
    define('DB_USER', 'root');

    /** MySQL database password */
    define('DB_PASSWORD', '');

    /** MySQL hostname */
    define('DB_HOST', 'localhost');

    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');

    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');

    I have created a WordPress database
    I have Apache and SQL running

    Yet when I enter : http://localhost/wordpress/wp-admin/install.php in FF (3.5.2), nothing comes up on the screen and the bottom just says "terminé".

    FF is in French, XP is in French, Apache is in English and SQL database (empty at the moment) is in English: is this my problem ?

    I am thinking of using the hosted (.com) service and eventually transferring to the .org. (I read it is possible)

    I have no experience of website, Apache, SQL, file transfers, etc, I just started reading about it on Internet today (many hours ago !) but it does not look that complicated.

    I thank you in advance for any help as I am at my wit's end.

    Best regards

    Dominique

  2. stvwlf
    Member
    Posted 4 years ago #

    I use WAMP not XAMPP so can't give you exact specifics.

    If you used the default settings for xammp, the web root folder is
    C:\Program Files\xampp\htdocs and based on your settings above you should have installed WordPress into
    C:\Program Files\xampp\htdocs\wordpress

    The Apache concept is there has to be an entry in Apache htppd.confd file for a virtual host for the the localhost, pointing to the folder you are using as web root.

    Converting my settings to Xammp default, it should look like this:
    The section name is
    NameVirtualHost 127.0.0.1

    That is followed by

    <VirtualHost 127.0.0.1>
        ServerName localhost
        DocumentRoot "C:\Program Files\xampp\htdocs"
    </VirtualHost>

    Note this is only if you used the defaults - what you want entered there is the location of the top level web root folder, wherever you put it. you would have installed WordPress into a folder within that top level folder - in this line you want the top level folder, not the WordPress folder.

  3. esentziak
    Member
    Posted 4 years ago #

    Thanks for your reply.

    I have to admit this is a bit like Greek to me and I only studied Latin. In fact I don't understand your reply at all, but I do feel I have some folder or file in the wrong place.

    This is where it is:
    C:\
    - xampplite
    - htdocs
    -wordpress
    - xampp

    The wp-config.php file is in the wordpress folder. It' s not in a folder called Program Files but in a folder of its own on the C drive, which I presume makes no difference ?

    re: The section name is
    NameVirtualHost 127.0.0.1

    This I don't understand at all: where does this line appear ?

    Again I am grateful for any help.

    Best regards

    Dominique

  4. stvwlf
    Member
    Posted 4 years ago #

    you need to find the Apache configuration file, which is called htppd.confd Somewhere in the xammp control panel you will have access to it. That is where the virtual host code goes. The directory in virtual host must match the directory that you have set up as your web root.

    As an aside, when I first set up my local install I started with Xammp. I found it confusing and not very intuitive. I switched to Wamp which I found much easier to grasp and configure.
    That was a couple of years ago, perhaps Xammp has improved their layout. If you remain lost you might look at Wamp.

  5. figaro
    Member
    Posted 4 years ago #

    Here is a step-by-step video tutorial on installing WordPress and XAMPP.

    [link moderated]

    why was this link moderated? Figaro has some excellent video tutorials that really help - I'm putting it back up...samboll
    http://educhalk.org/blog/?p=154

  6. esentziak
    Member
    Posted 4 years ago #

    Thank you both.

    To figaro: I am happy I have installed it in the C directory as per the tutorial and not in a sub-directory and I have checked the ports and stopped Skype from using them.

    To stvwlf: could not find how to access this htppd.confd file and when I did a search, it does not appear to exist on my hard drive.

    I'll have a look at Wamp.

    thanks again

    Dominique

Topic Closed

This topic has been closed to new replies.

About this Topic