WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Local install of WordPress on Mac 10.7 (5 posts)

  1. rabson
    Member
    Posted 2 years ago #

    Howdy smart people,

    I've perhaps achieved a new record in being unable to '5 minute install' WordPress locally, with it taking around 5 hours so far...

    I have MAMP installed and configured as per instructions, however I can't run 'wp-admin/install.php'. I have placed all WordPress files within my MAMP document root folder: '/Users/admin/Documents/sites/wordpress'.

    After attempting every sensible combination in my browser I can think of (see below) to no avail I have turned to your wisdom.

    http://localhost:8888/Users/admin/Documents/sites/wordpress/wp-admin/install.php
    or
    http://localhost:8888/michaels-imac.local/Users/admin/Documents/sites/wordpress/wp-admin/install.php
    or
    http://michaels-imac.local/Users/admin/Documents/sites/wordpress/wp-admin/install.php
    etc

    What am I doing wrong?

    Once you've stopped laughing at my noob lack of knowledge I'd greatly appreciate some help.

    Thanks in advance for helping little ol' me.

  2. J. C. (@ommunist)
    Member
    Posted 2 years ago #

    Have you tried to install under MAMP htdocs directory? Than just http://localhost:mamp apache port]/yourwordpressdirectory

  3. idanc
    Member
    Posted 2 years ago #

    If MAMP is like any other stack, MAMP will have a directory where your WordPress install needs to reside.

    An easy easy to visualize this, is assuming the MAMP 'web folder' is /Users/yourname/MAMP/html/:

    http://localhost:8888 == /Users/yourname/MAMP/html/

    http://localhost:8888/hello.html == /Users/yourname/MAMP/html/hello.html

    http://localhost:8888/Users/admin/Documents/ == /Users/yourname/MAMP/html/Users/admin/Documents

    NOTE: the path I chose '/Users/yourname/MAMP/html/' is just a guess, this is NOT where MAMP is actually located

    Hope this clarifies things.

  4. rabson
    Member
    Posted 2 years ago #

    Thanks for your speedy responses. Only getting a chance to try to resolve this now. The Apache port within MAMP preferences allows you to define a document root (which I had defined previously). I have redefined this as the htdocs folder '/Applications/MAMP/htdocs'.

    Sooooo, I've attempted the following in my browser:
    http://localhost:8888/Users/admin/Applications/MAMP/htdocs/wp-admin/install.php
    http://localhost:8888/Applications/MAMP/htdocs/wp-admin/install.php
    http://localhost:8888/michaels-imac.local/Users/admin/Applications/MAMP/htdocs/wp-admin/install.php
    http://localhost:8888/michaels-imac.local/Applications/MAMP/htdocs/wp-admin/install.php

    Don't know what else to try!

    Thanks again for helping...

  5. rabson
    Member
    Posted 2 years ago #

    Figured it out for anybody out there having the same problems as me.

    Turns out I was being quite silly and my directory path was incorrect. Check out this walk-through set-up tutorial here:

    http://webdesignerwall.com/tutorials/installing-wordpress-locally

    Good luck!

Topic Closed

This topic has been closed to new replies.

About this Topic