WordPress.org

Ready to get started?Download WordPress

Forums

Gamma Gallery
[resolved] Loading not stopping (js files not included) (13 posts)

  1. jay_theis
    Member
    Posted 11 months ago #

    Hi,
    first of all thanks for the plugin! Exactly what I need.
    Unfortunately there is a problem with my theme. I use a theme I created myself and the loading wheel doesn't stop spinning and no pictures show up. It works with the default theme.
    Do you have any ideas what the problem could be or where I could start looking?

    Thanks!

    http://wordpress.org/plugins/gamma-gallery/

    Edit:
    Just realised not all js files are loaded. This code is outputted at the position of the gallery:

    <link href="http://localhost/wordpress/wp-content/plugins/gamma-gallery/css/style.css" type="text/css" rel="stylesheet"></link><script src="http://localhost/wordpress/wp-content/plugins/gamma-gallery/js/modernizr.custom.70736.js"></script><noscript>
          <link rel="stylesheet" type="text/css" href="http://localhost/wordpress/wp-content/plugins/gamma-gallery/css/noJS.css"/>
        </noscript>
          <!--[if lte IE 7]><style>.main{display:none;} .support-note .note-ie{display:block;}</style><![endif]-->
        <div id="gamma-container" class="gamma-container gamma-loading">
    <ul class="gamma-gallery">
    <li><div data-max-height="2400" data-max-width="1800" data-description="<h3>IMG_7710 </h3>" data-alt="img1"> … </div></li>
    <li><div data-max-height="2400" data-max-width="1800" data-description="<h3>IMG_7712 </h3>" data-alt="img2"> … </div></li>
    <li> … </li><li> … </li><li> … </li><li> … </li>
    </ul>
    <div class="gamma-overlay"></div>
    </div>
  2. jay_theis
    Member
    Posted 11 months ago #

    Any ideas how the js files are loaded?

  3. jay_theis
    Member
    Posted 11 months ago #

    Just saw that I get this error in the Chrome console when I manually add the gamma.js file:

    "Uncaught TypeError: Cannot call method 'prefixed' of undefined" on line 161 in the gamma.js file.

  4. jay_theis
    Member
    Posted 11 months ago #

    Ok nevermind I figured it out. For anybody running into the same problem make sure to call the wp_footer() action.

  5. mattrussell
    Member
    Posted 11 months ago #

    hey there.

    I'm having the same issue.

    I have placed <?php wp_footer(); ?> in my footer.php file just before </body> but its still just showing the loading wheel.

    Any ideas?

    Thanks

  6. jay_theis
    Member
    Posted 11 months ago #

    Do you have a link to have a look at?

  7. mattrussell
    Member
    Posted 11 months ago #

  8. jay_theis
    Member
    Posted 11 months ago #

    It doesn't seem to load any images. Are you using images that you have uploaded to WP before installing the plugin? If so, try uploading them again.

  9. mattrussell
    Member
    Posted 11 months ago #

    ya am using images uploaded to wp before installing.

    ok ill try that.

    thanks

  10. mattrussell
    Member
    Posted 11 months ago #

    ok that dosen't seem to be working

    i think its a javascript issue because i was trying to use another similar plugin, and i asked the author to have a look at my site as that one wasn't working either.

    i thought that the wp_footer action might do the trick and solve it, but it didn't and instead it messed up another element on my site which is using javascript.

    anyways if you think you might have another solution i would be appreciate your help.

    if not i guess i will have to find a plugin which isn't conflicting with what i already have in my code, as im on a tight deadline and i cant spend too much time trying to debug it.

    thanks

  11. jay_theis
    Member
    Posted 11 months ago #

    that was part of the problem. The images are being loaded now but not displayed correctly. But I'm not sure where the problem could be

  12. mattrussell
    Member
    Posted 11 months ago #

    no that's because i deactivated the plugin and have edited the page. i was trying a few other things out to see if it can work.

    do you know any other nice responsive gallery plugins?

    thanks for your help

  13. jay_theis
    Member
    Posted 11 months ago #

    No problem.

    I haven't tried it but maybe this one

Reply

You must log in to post.

About this Plugin

About this Topic

Tags