WordPress.org

Ready to get started?Download WordPress

Forums

Lightbox Plus Colorbox
Loading animation & Prev/Next overlays missing in Lightbox Plus 2.4.6 (21 posts)

  1. TheNightRider
    Member
    Posted 2 years ago #

    The loading animated GIF and the Prev/Next overlays are missing in Lightbox Plus 2.4.6. Tested in 3 of the styles I use: Black, Elegant, and Shadowed. Elegant and Shadowed don't have the Prev/Next overlays like Black does, but in all 3, the animated GIF is missing. Reverting to Lightbox 2.4 restores this functionality. Not sure if broken in 2.4.5. Tested under WordPress 3.3.1, 3.3, and 3.2.1 with 7 different themes.

    http://wordpress.org/extend/plugins/lightbox-plus/

  2. thekeymaker
    Member
    Posted 2 years ago #

    I'm having the same problem with the prev and next overlays missing.
    It happened after I updated to wordpress 3.3.1 and reinstalled Lightbox Plus 2.4.6. The functionality is still there, just the buttons are missing.

  3. TheNightRider
    Member
    Posted 2 years ago #

    Hi thekeymaker,

    Do you mean that, even though the "next" and "prev" buttons are missing, you can click on the regions where they are supposed to be and you then get the next and prev images?

  4. thekeymaker
    Member
    Posted 2 years ago #

    Yes! if I click the the right half or so of the image that it goes to the next, and the same for the left and previous.

  5. TheNightRider
    Member
    Posted 2 years ago #

    Thanks, thekeymaker!

  6. Dustin
    Member
    Posted 2 years ago #

    I am having the same issue. You can still navigate between images by clicking on the left and right sides but the previous and next overlays are gone.

  7. pixeljunky
    Member
    Posted 2 years ago #

    Same fault...

    I can still navigate between images by clicking on the left and right sides but the previous and next overlays are gone.

  8. steffiiiii
    Member
    Posted 2 years ago #

    Same problem here, with the black layout, wordpress 3.3.1 and lightbox plus v2.4

  9. Peter Brock
    Member
    Posted 2 years ago #

    Me too. The next/prev overlays are missing but I can advance the slides or go back by clicking in the usual places. Please fix this soon though.

  10. 3.14fingers
    Member
    Posted 2 years ago #

    I solved this problem on my site by doing the following.

    The download for this plug in has a file called "jquery.colorbox-min.js"

    When I used the current download from the Worpress site I had the same problem as above where the "Previous" and "Next" Tags were disappearing.

    If I look inside the file called "jquery.colorbox-min.js" I see that it is listed in the header as "ColorBox v1.3.19 - jQuery lightbox plugin".

    I looked at a previous installation of the same plug-in on another blog I run and the same file was listed in the header as "ColorBox v1.3.17.2 - a full featured, light-weight, customizable lightbox based on jQuery 1.3+".

    When I replaced the current file with the older code all the tags came back again.

    Hope this helps

  11. Dustin
    Member
    Posted 2 years ago #

    I tried that and it didn't work. Neither did downgrading to 2.4 though either. . .

  12. steffiiiii
    Member
    Posted 2 years ago #

    @3.14fingers THANKS, that worked for me!

  13. tomas.halo
    Member
    Posted 2 years ago #

    hello,
    i found a typing error in style sheet which causes not show prev/next buttons overlay. #cboxPrevious.hover/#cboxNext.hover is not class, the right way is :hover element: #cboxPrevious:hover/#cboxNext:hover

    [not "." but ":"]

  14. pixeljunky
    Member
    Posted 2 years ago #

    @tomas.halo

    can not found the entry "#cboxPrevious.hover" in "lightbox-plus/admin/lightbox.admin.css"

    were can i found it?

  15. tomas.halo
    Member
    Posted 2 years ago #

    Hello,
    it's located in theme you chosen:

    /lightbox-plus/css/'theme'/colorbox.css

  16. pixeljunky
    Member
    Posted 2 years ago #

    @tomas.halo

    you are best :-))))
    the long awaited solution!
    it works..thank you.....

  17. ziolomu
    Member
    Posted 2 years ago #

    The hover bug solved the problem of next/prev images (and "close" too), but not that of loading image.

    So I solved this way:
    1) downloaded from colorbox the original file colorbox.css (inside the css folder in the archive)

    2) replaced the colorbox.css with the one of the theme I used in lightboxPlus

    3) In my case (elegant theme) I had to adjust the alignment of the box corner always in the colorbox.css

  18. Zukes
    Member
    Posted 2 years ago #

    @ziolomu
    Thanks it worked like a charm!

  19. woktoss
    Member
    Posted 1 year ago #

    @ziolomu

    yep, that solved the problem... thanks.

  20. janubande007
    Member
    Posted 1 year ago #

    @ALL & @dzappone, rather than going back to an older css, I noticed the following CSS is missing from the colorbox.css file (in my case using the Dark theme).

    #cboxLoadingOverlay, #cboxLoadingGraphic { height: 100%; }

    Can this bug be fixed?

    By modifying your own plugins colorbox.css or your theme's style.css or inserting that style into your html one way or another, brings back the loading graphic but only during 1st load (startup) & transtion between images of differing sizes. I do not see the loading graphic load when an image is waiting to become available/downloaded due to a slow connection or large image or both.

    Since I'm new to this plugin I don't know of all the cases when the loading graphic is supposed to display. Please advise as I am expecting the loading graphic to be shown while an image is coming down the (internet) pipe.

    Thanks.

  21. janubande007
    Member
    Posted 1 year ago #

    Forgot to mention - the loading graphic does not display while waiting for the image to download ONLY in Firefox & Chrome, it does display on IE though. Can this be fixed? Any CSS workarounds that I can do meanwhile?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic