WordPress.org

Ready to get started?Download WordPress

Forums

Livewriter to WordPress causes partial html (4 posts)

  1. Marielle Smith
    Member
    Posted 2 years ago #

    Hi there, I'd be grateful for some help!

    I use Windows Live Writer to write blog entries and then post draft blog entries to WordPress. This was working fine until recently, but after I updated to the latest version of WordPress (3.2.1), partial html appears in the visual window (not the html window) on drafts that have been posted from Live Writer. For instance, I just wrote this into Live Writer:

    Testing testing, I am testing my blog.

    My blog doesn’t seem to be working properly.

    But when I post the Live Writer draft to WordPress, it appears in the visual window like this:

    pTesting testing, I am testing my blog./p pMy blog doesn’t seem to be working properly./p

    I am using the Arras theme, version 1.5.0.1, and the 2011 version of Live Writer.

    Thanks so much!

  2. landseer
    Member
    Posted 2 years ago #

    Below is the post where I found the solution. I met the same problem, and couldn't solve it until I see the following post.

    Windows Live Writer WordPress Fix
    So when I first tried Windows Live Writer, it seemed to post fine. But lately it always strips out all the HTML tags and makes a mess of things. For example, if I were to post:

    <p>Hello World!</p>

    It would come across more like:

    pHello World!/p

    This post describes the problem and how to fix it, but really I was in no mood to update my PHP and libXml install. So, after a bit more searching I found this plugin that worked like a charm! Thank you Joseph Scott.

    Here is the link the plugin http://wordpress.org/extend/plugins/libxml2-fix/

    Just install this plugin and it will solve your problem.

  3. Marielle Smith
    Member
    Posted 2 years ago #

    Hi there,

    Many thanks for replying to my post! We are busy PhD students without much technical knowledge of websites and because of that our site has been offline for months while we tried, procrastinated and failed to fix it! Your suggestion worked a treat :)

    Thanks again for your kind post!

    Marielle.

  4. jlmurgas
    Member
    Posted 2 years ago #

    Hey! this plugin really work :D

    many thanks!!!

Topic Closed

This topic has been closed to new replies.

About this Topic