WordPress.org

Ready to get started?Download WordPress

Forums

Live Press 1.5.1.3 Moldy Banana Release (77 posts)

  1. unteins
    Member
    Posted 8 years ago #

    I have finally updated Live Press for WordPress 1.5.1.3. This is more than an update, it includes nifty new features. This is a beta, but it should do the trick :)

    Read More here

  2. jennmiller
    Member
    Posted 8 years ago #

    Thanks for all the hard work! I can get everything to work except the actual Journal configuration. I have my moodtheme, tags, etc. working, but there's no way for me to configure my username, password, ect. Is there a configure file missing?

    My plugin page is a mess, too. The extras entry is all code not just the identifying info.

  3. unteins
    Member
    Posted 8 years ago #

    Be sure to keep the folder structure the same as in the zip file (ie LivePress.php and a LivePress subfolder)

    You configure journals in Options>Live Press

    An update is in the works too, keep checking my site.

  4. zoe2507
    Member
    Posted 8 years ago #

    This breaks my WP - like jennmiller says my plugin page becomes a mess, but only while im uploading it. As soon as it's up my entire blog stops working, and I have to delete the files again. Help!

  5. jennmiller
    Member
    Posted 8 years ago #

    I'll keep using my hacked up old version and checking for updates. Thanks!

  6. zoe2507
    Member
    Posted 8 years ago #

    I did some playing around with it - there's a problem with the add journal - you have it pointed at the wrong directory. There are quite a few bugs, but I can't program any good myself, so I don't really have much idea - I've just been following errors round in circles. It would be cool to know when you get this working, I'd really like to be able to use it.

  7. unteins
    Member
    Posted 8 years ago #

    Well, actually it works great for my blog, so it would be helpful to know what the errors are :)

  8. zoe2507
    Member
    Posted 8 years ago #

    Uhh, there are errors all over the place. I can't really explain them cos I don't know enough - but when I get it closest to working the headers on my wordpress admin sites are messed up and the write post page only shows the mood and music sections. I spent about 4 hours last night trying to get it to work, and there was a new error every 5 minutes. I'd suggest setting up a clean install of wordpress 1.5.1.3 somewhere are installing it through. The documentation seems to be a bit lacking - where is everything meant to be installed in order for it to work correctly etc? Also, my site is in a subdomain so i had to fix a few things as they pointed to http://www.mysite.com/wp-includes/ rather than http://www.mysite.com/subsite/wp-includes

    I can't remember any more specifics right now.. If I have another shot at it later I'll try and copy and paste all the errors I find, and when/where etc.

    Hope this helps - I'd love to be able to use this.

  9. jennmiller
    Member
    Posted 8 years ago #

    On the Options page, the "Add Journal" link is busted. As zoe said, there's no way for us to configure our journal information. On the Plugins page, there are multiple "Livepress" entries, as if it's actually 5 different plugins. All but one of those entries shows the entire .php page, code and all. It stretches out the page to about 1500px. The install instructions are for version 1.2.

  10. zoe2507
    Member
    Posted 8 years ago #

    I've figured a few things out..

    I switched my journal to my domain name, and tried again. I've been intending to do that anyway - this gave me an excuse! Still didn't work though.

    In order to have just the one plugin showing, you need every thing in the following folders wp-content/plugins/Live Press 1.5.1.3/
    then have it in the same file structure as the zip.

    This solves a few of the problems I have. The Add Journal link doesn't work - takes you straight to the wp-admin dashboard instead.

    On the Write Post page, I get the following in the header (above where my journal title is)

    --------------------------------------

    Warning: array_keys(): The first argument should be an array in /home/yourwin/public_html/wp-content/plugins/Live Press 1.5.1.3/LivePress/lpextras.php on line 71

    Warning: Invalid argument supplied for foreach() in /home/yourwin/public_html/wp-content/plugins/Live Press 1.5.1.3/LivePress/lpextras.php on line 71

    Warning: array_keys(): The first argument should be an array in /home/yourwin/public_html/wp-content/plugins/Live Press 1.5.1.3/LivePress/lpextras.php on line 79

    Warning: Invalid argument supplied for foreach() in /home/yourwin/public_html/wp-content/plugins/Live Press 1.5.1.3/LivePress/lpextras.php on line 79

    Warning: Cannot modify header information - headers already sent by (output started at /home/yourwin/public_html/wp-content/plugins/Live Press 1.5.1.3/LivePress/lpextras.php:71) in /home/yourwin/public_html/wp-admin/admin.php on line 10

    Warning: Cannot modify header information - headers already sent by (output started at /home/yourwin/public_html/wp-content/plugins/Live Press 1.5.1.3/LivePress/lpextras.php:71) in /home/yourwin/public_html/wp-admin/admin.php on line 11

    Warning: Cannot modify header information - headers already sent by (output started at /home/yourwin/public_html/wp-content/plugins/Live Press 1.5.1.3/LivePress/lpextras.php:71) in /home/yourwin/public_html/wp-admin/admin.php on line 12

    Warning: Cannot modify header information - headers already sent by (output started at /home/yourwin/public_html/wp-content/plugins/Live Press 1.5.1.3/LivePress/lpextras.php:71) in /home/yourwin/public_html/wp-admin/admin.php on line 13

    -----------------------

    Obviously, when I post it doesn't update my journal - because I haven't been able to figure it. But it also completely messes up my post page as soon as I try to post.

    On the Write Post page in admin, the only additional things are
    LJ Extras: Current Music: Current Mood:
    I thought there was supposed to be an option for synching etc?

    Hope this is all helpful, and that you figure it out soon, I can't wait to use it - it looks like it will be exactly what I'm looking for.

  11. unteins
    Member
    Posted 8 years ago #

    What browser are you using?

    Do you have Javascript disabled? (LivePress uses Javascript for the Add Journal function)

    Are you using any kind of Pop-up blocker? (LivePress pops up a new window to edit journal settings)

  12. zoe2507
    Member
    Posted 8 years ago #

    Right now I'm using ie, but usually firefox - it doesn't work in either.
    Javascript is enabled, yes, and it's not a popup blocker either.

  13. zoe2507
    Member
    Posted 8 years ago #

    Hmm.. when I hover my mouse over the add journal link, it just shows it as linking to http://www.yourwinter.com/wp-admin/ rather than what it should do. Is there anyway to hack it to add my journal, to see if it solves the other problems?

  14. zoe2507
    Member
    Posted 8 years ago #

    Unteins - could you email me when you figure anything out/update this thread? zoe2507 (at) gmail (dot) com. Cheers

  15. zoe2507
    Member
    Posted 8 years ago #

    I've tried it again in FF and the add journal link now works - but I don't think that the information is actually saving

  16. unteins
    Member
    Posted 8 years ago #

  17. jennmiller
    Member
    Posted 8 years ago #

    The "Add Journal" function still won't work. The link in FF returns me to the LP Options page, and in IE leads to the Dashboard (/wp-admin). I have js enabled. The plugins page is still overflowing with code. I would leave comments on your site, but the comments require login(?).

  18. Firas
    Member
    Posted 8 years ago #

    Are your linebreaks ok, unteins? Things in the archive seem a bit odd with regards to linebreak format consistency. I'll investigate further later on, but try saving them all with unix linebreaks.

  19. masquerade
    Member
    Posted 8 years ago #

    Your problem is indeed in the linebreaks. I didn't check all the files, but I at least know that LivePress.php is a mix between Unix, Mac, and DOS style line endings (\n, \r, and \r\n respectively). Try using a sane text editor for Mac (I highly recommend TextMate) where you can specify the line endings type and _always_ use LF(unix). I also recommend using a sane zipping program, maybe zip on the commandline, since the __MACOSX directories are a hassle.

  20. unteins
    Member
    Posted 8 years ago #

    I have gone through and converted all the line endings to LF(unix)

    I don't know how I ended up with the mess of different ending, but if you could try re-downloading and letting me know if it worked.

  21. unteins
    Member
    Posted 8 years ago #

    Jenmiller - you can register yourself at my blog, I have gotten too much spam to leave open comments at the moment

  22. Brandice
    Member
    Posted 8 years ago #

    I got it installed and followed your directions, but I'm getting this when I click on "write":

    Warning: array_keys(): The first argument should be an array in /home/brandice/public_html/monkey/wp-content/plugins/Live Press 1.5.1.3/LivePress/lpextras.php on line 86

    Warning: Invalid argument supplied for foreach() in /home/brandice/public_html/monkey/wp-content/plugins/Live Press 1.5.1.3/LivePress/lpextras.php on line 86

    Warning: array_keys(): The first argument should be an array in /home/brandice/public_html/monkey/wp-content/plugins/Live Press 1.5.1.3/LivePress/lpextras.php on line 94

    Warning: Invalid argument supplied for foreach() in /home/brandice/public_html/monkey/wp-content/plugins/Live Press 1.5.1.3/LivePress/lpextras.php on line 94

    Warning: Cannot modify header information - headers already sent by (output started at /home/brandice/public_html/monkey/wp-content/plugins/Live Press 1.5.1.3/LivePress/lpextras.php:86) in /home/brandice/public_html/monkey/wp-content/plugins/post-levels.php on line 42

    Warning: Cannot modify header information - headers already sent by (output started at /home/brandice/public_html/monkey/wp-content/plugins/Live Press 1.5.1.3/LivePress/lpextras.php:86) in /home/brandice/public_html/monkey/wp-content/plugins/post-levels.php on line 43

    Warning: Cannot modify header information - headers already sent by (output started at /home/brandice/public_html/monkey/wp-content/plugins/Live Press 1.5.1.3/LivePress/lpextras.php:86) in /home/brandice/public_html/monkey/wp-admin/admin.php on line 10

    Warning: Cannot modify header information - headers already sent by (output started at /home/brandice/public_html/monkey/wp-content/plugins/Live Press 1.5.1.3/LivePress/lpextras.php:86) in /home/brandice/public_html/monkey/wp-admin/admin.php on line 11

    Warning: Cannot modify header information - headers already sent by (output started at /home/brandice/public_html/monkey/wp-content/plugins/Live Press 1.5.1.3/LivePress/lpextras.php:86) in /home/brandice/public_html/monkey/wp-admin/admin.php on line 12

    Warning: Cannot modify header information - headers already sent by (output started at /home/brandice/public_html/monkey/wp-content/plugins/Live Press 1.5.1.3/LivePress/lpextras.php:86) in /home/brandice/public_html/monkey/wp-admin/admin.php on line 13

    I also found that when I entered my LJ login info and clicked on save it directed me to my WP account info and I never actually got my livejournal listed under livepress.

    I test-posted an entry and it posted to my wordpress blog, but no LJ success.

    This is soooo close! I'm dying to use it when I get it figured out or someone can help me with whatever is wrong. :)

    ---

    Also, I registered to comment on your blog and I get an error message when I try to comment. Just a side note.

  23. unteins
    Member
    Posted 8 years ago #

    What was the error on the comment?

  24. Brandice
    Member
    Posted 8 years ago #

    error when I try to comment:

    Fatal error: Cannot redeclare class ixr_value in /usr/home/jason/www/wp-content/plugins/spam/IXR_Library.inc.php on line 12

  25. zoe2507
    Member
    Posted 8 years ago #

    I'm still having issues with the Add Journal link - in ie it just goes straight to wp-admin, then I get the following errors on the Write Post page:

    Warning: array_keys(): The first argument should be an array in /home/yourwin/public_html/wp-content/plugins/Live Press 1.5.1.3/LivePress/lpextras.php on line 86

    Warning: Invalid argument supplied for foreach() in /home/yourwin/public_html/wp-content/plugins/Live Press 1.5.1.3/LivePress/lpextras.php on line 86

    Warning: array_keys(): The first argument should be an array in /home/yourwin/public_html/wp-content/plugins/Live Press 1.5.1.3/LivePress/lpextras.php on line 94

    Warning: Invalid argument supplied for foreach() in /home/yourwin/public_html/wp-content/plugins/Live Press 1.5.1.3/LivePress/lpextras.php on line 94

    Warning: Cannot modify header information - headers already sent by (output started at /home/yourwin/public_html/wp-content/plugins/Live Press 1.5.1.3/LivePress/lpextras.php:86) in /home/yourwin/public_html/wp-admin/admin.php on line 10

    Warning: Cannot modify header information - headers already sent by (output started at /home/yourwin/public_html/wp-content/plugins/Live Press 1.5.1.3/LivePress/lpextras.php:86) in /home/yourwin/public_html/wp-admin/admin.php on line 11

    Warning: Cannot modify header information - headers already sent by (output started at /home/yourwin/public_html/wp-content/plugins/Live Press 1.5.1.3/LivePress/lpextras.php:86) in /home/yourwin/public_html/wp-admin/admin.php on line 12

    Warning: Cannot modify header information - headers already sent by (output started at /home/yourwin/public_html/wp-content/plugins/Live Press 1.5.1.3/LivePress/lpextras.php:86) in /home/yourwin/public_html/wp-admin/admin.php on line 13

  26. Brandice
    Member
    Posted 8 years ago #

    that's the same issue I'm having... at least I'm having the same problems as someone else for once! ;)

  27. zoe2507
    Member
    Posted 8 years ago #

    I think that it's most probably hanging on this Add Journal thing, maybe thats causes the problems on the post page too - I wonder if theres anyway to hack it into adding one manually

  28. unteins
    Member
    Posted 8 years ago #

    Try grabbing the files again, I was having the add journal problem as well (I hadn't noticed because I already added the journal)

    If you can, open up the Javascript console and see if there are any javascript errors reported. Make sure you have the latest zip file (just re-download the plugin)

  29. zoe2507
    Member
    Posted 8 years ago #

    how do I open up the javascript console? Sorry - I have no idea about anything when it comes to js

  30. zoe2507
    Member
    Posted 8 years ago #

    if it makes it easier - email me and I'll send you my username/password and the relevant details etc my email addy is a gmail one with the user zoe2507.

Topic Closed

This topic has been closed to new replies.

About this Topic