WordPress.org

Ready to get started?Download WordPress

Forums

[Live Blogging] Auto-updating not occuring (32 posts)

  1. itsalltech1
    Member
    Posted 3 years ago #

    Hello.

    I'm trying to setup the Live Blogging plugin on my WordPress site. Everything works fine, but auto-updating doesn't work. For example, I'll publish an update and wait five minutes for the update to automatically appear in the live blog. It doesn't.

    If I refresh the page, the update is there.

    Any ideas/thoughts?

    Thanks.

  2. chrisnorthwood
    Member
    Posted 3 years ago #

    Are there any errors in your JavaScript console?

  3. itsalltech1
    Member
    Posted 3 years ago #

    The only possible related message:

    "ReferenceError: Can't find variable: pollsL10n." The rest are related to Google Ads...

    EDIT: Here is another one:

    "Uncaught ReferenceError: swfobj is not defined"

  4. chrisnorthwood
    Member
    Posted 3 years ago #

    That doesn't sound like an error relating to Live Blogging, but if it occurs, it could stop live blog updating occuring

  5. itsalltech1
    Member
    Posted 3 years ago #

    So, how do you recommend I fix the issue?

  6. chrisnorthwood
    Member
    Posted 3 years ago #

    Without knowing more info, my first bet would be to try and find the JavaScript bug in the other plugin and fix it.

  7. itsalltech1
    Member
    Posted 3 years ago #

    I tried deactivating all of my plugins to no avail. Updates still are not being posted automatically.

  8. bplevyak
    Member
    Posted 3 years ago #

    I had the same problem today right after bumping up to 3.2. The only way to fix was to drop back down to the previous version, then auto-updating worked again.

    This plugin IS a life saver though, so THANK YOU. If there's any way you'd consider some smart logic to auto cut off text early and toss the first hyperlink it finds as a short link at the end of the tweet, that would be SWEEEEET.

  9. itsalltech1
    Member
    Posted 3 years ago #

    I am updated on WordPress 3.2, but I don't have the time to downgrade back to WordPress 3.1.

    I wonder if we can track down what the issue is on WP 3.2?

  10. chrisnorthwood
    Member
    Posted 3 years ago #

    I've just updated my blog to 3.2 to test - it appears the jQuery AJAX success function isn't being called when you use the polling method. I'll try and investigate further.

    One workaround is to use the Meteor server for updating until I fix the bug.

  11. itsalltech1
    Member
    Posted 3 years ago #

    Sounds good. Any chance you have an ETA?

  12. bplevyak
    Member
    Posted 3 years ago #

    Chris, thanks. I can't tell you how much I love this plugin.

    While you are in there, if you can check into a couple more requests...

    1. If I add a live blog entry and back-time it, can it show up at that stage when the page refreshes, rather than the time it was entered? I back-timed a couple but they just showed up with the proper time in the text, but not in the proper order (they just showed at the top).

    2. If you could figure out a way to make the auto-twitter grab the first link it finds in a live blog post, and turn it into a short bit.ly or otherwise link at the end, I know this is tough, that would be really neat. Right now it just ignores any http and only does text.

  13. chrisnorthwood
    Member
    Posted 3 years ago #

    itsalltech1: No ETA I'm afraid. Perhaps sometime this month.

    bplevyak: I'm afraid your first point is answered by the FAQ here: http://wordpress.org/extend/plugins/live-blogging/faq/ - it's not really something I have the time to commit to atm. Feel free to contribute patches though (I'm tempted to put it up on Github and use git-svn to get it back up the WordPress SVN repo).

    Number 2 is pretty tricky, but doable. However, my problem is that I don't have much time to develop this plugin at the moment, even finding time for bug fixes is tricky, so I can't promise that I'll do this, or when it'll be done.

  14. bplevyak
    Member
    Posted 3 years ago #

    I just appreciate you responding Chris. We're gonna look into Meteor too. Totally understand what a rare commodity that FREE TIME is these days.

    Again thank you so much for even taking the time to reply to this thread. Even that shows you stand by your work, really cool.

  15. buddybonesbones
    Member
    Posted 2 years ago #

    I modified the plugin so that the polling works with wordpress 3.2.1.
    I haven't done extensive testing, but it is working for me with my current setup of wordpress 3.2.1. I just thought I'd share here in case someone else would like a copy of my unofficial update.

    I'm not sure which of the following changes made it work but here are the two main things I did.

    remove the third parameter (id) from the javascript setTimout() calls and moved it into the first parameter (the function called by the timout) using a closure.

    change the jQuery.post() data type from 'application/json' to 'json' and then remove the line of code that converts the rsponse (because jquery does this automatically).

    that's all.

  16. itsalltech1
    Member
    Posted 2 years ago #

    Awesome news. Any chance you can just post the entire plugin with the update? THanks.

  17. buddybonesbones
    Member
    Posted 2 years ago #

    I just uploaded it to anyhub.net (a free file hosting service) but their server seems to be reeeeally slow. here's the link:
    http://anyhub.net/file/3xwD-live-blogging-2.1.7_updated_for_wordpress3.2.1.zip

    If you have a suggestion of somewhere better to host it, or if you want me to email it to you instead, I can do that.

  18. itsalltech1
    Member
    Posted 2 years ago #

    Thanks for uploading, but live blogging still doesn't work for me...

  19. buddybonesbones
    Member
    Posted 2 years ago #

    hmm. I just deactivated and deleted live blogging and installed it again from the folder I uploaded, and it's working for me.

    I assume, you have created a normal blog post, added the [liveblog] tag to it where you want your post to show up, and checked "Enable live blogging on this post" at the bottom right?

  20. itsalltech1
    Member
    Posted 2 years ago #

    Yep, I'm doing exactly that. Tried it on an older post that I used a live blog on and still didn't work.

    I have a DB caching tool enabled...could that be it?

  21. buddybonesbones
    Member
    Posted 2 years ago #

    I'd try disabling that (if possible) and all other plugins just to see if you can figure out what's causing the problem. Sorry it's not working for you. I wish I could help you get it working. I was pretty happy that I was able to get it working on my wordpress 3.2.1 install.

    do you happen to have firefox with firebug installed so you can see if you are sending/receiving the polling requests from the server at all? If not, would you mind sharing your blog url so I can take a look? (just out of curiosity)

  22. itsalltech1
    Member
    Posted 2 years ago #

    Just deactivated all of my plugins and re-enabled them all. Live updating works now. Weird - something must have been cached or something?

    But anyways, thanks all the help!

    Back to hosting the file, MediaFire might be a little better.

  23. chrisnorthwood
    Member
    Posted 2 years ago #

    Awesome buddybonesbones, thanks - btw, the code is on Github here: https://github.com/cnorthwood/liveblogging if you wanted to fork and issue a pull request with the changes

  24. buddybonesbones
    Member
    Posted 2 years ago #

    Did you test it chris? I just want to confirm that it worked for someone else other than just me. :)

  25. chrisnorthwood
    Member
    Posted 2 years ago #

    not yet :( am pretty busy atm I'm afraid

  26. buddybonesbones
    Member
    Posted 2 years ago #

    I hadn't noticed the post about it working for itsalltech1 until now. :) Makes me happy. Glad someone else could use my update.

  27. mindctrl
    Member
    Posted 2 years ago #

    That fix didn't work for me, but after investigating I found it was caused by the fact that I was forcing SSL on the admin, and this caused a problem with cross-site http requests since my whole site doesn't default to SSL.

  28. topdownjimmy
    Member
    Posted 2 years ago #

    buddybonesbones' modified version of this plugin works for me.

    And it looks like Chris is making these fixes: http://plugins.trac.wordpress.org/log/live-blogging/

  29. tomueberall
    Member
    Posted 2 years ago #

    just a short feedback: the modified version works for me.
    - WordPress 3.2.1
    - Twenty-Eleven theme (as a basis, but modified)

    what i did:

    - edited comments.php so there is an <ol id="commentlist" class="commentlist"> (there was only a class of this name before, no ID)

    - edited functions php with this:

    add_filter('live_blogging_build_comments', 'twentyeleven_liveblogging_comments');
    function twentyeleven_liveblogging_comments($a)
    {
        $a['callback'] = 'twentyeleven_comment';
        return $a;
    }

    though i'm not sure it is needed or works - will try to remove it again.

    until this point, id did not work.
    - I installed the version of buddybonesbones with no further modifications to the theme or plugin -> now it works.

  30. robrat
    Member
    Posted 2 years ago #

    A bit more on this. Even after your update budybones bones, mine wasn't auto updating, or so I thought.

    The CSS of new posts coming in wasn't changing from "display: none; position: absolute; opacity: 0" meaning it simply wasn't showing up.

    It's supposed to animate in the nice new post, but it just wasn't changing so I changed your JS make the style be 'block' and on line 69 I changed it to: jQuery(div_id).fadeTo(0, 1,

Topic Closed

This topic has been closed to new replies.

About this Topic