WordPress.org

Ready to get started?Download WordPress

Forums

SendPress Newsletters
List response options not working (9 posts)

  1. avbyrin
    Member
    Posted 10 months ago #

    When I submit an email through the form, it goes to the correct list.

    However, there is no notification on the user side to let them know whether the submission is successful.

    I have tried changing the response option for this list (to JSON, to default SendPress page and also to a WP generated page) but the HTML code doesn't change at all. How can I fix this?

    Here is the page that is using SendPress plugin: http://www.fantasyleaguechampion.com/

    The form is at the very bottom.

    Thanks.

    http://wordpress.org/plugins/sendpress/

  2. itdoug
    Member
    Plugin Author

    Posted 10 months ago #

    Make sure you are running 0.9.9.4. We just released it last night and it had some fixes for forms.

  3. avbyrin
    Member
    Posted 10 months ago #

    I upgraded to the latest version (0.9.4.6) and still there's nothing. FYI I'm using the PHP code for this particular form. The code is as follows:

    <form id="sendpress_signup" method="POST" class="sendpress-signup" >
    
    				<div id="error"></div>
    				<div id="thanks" style="display:none;">Thank you for subscribing!</div>
    				<div id="form-wrap" style="width:300px;margin: 0 auto;">
    					<p></p>
    											<input type="hidden" name="sp_list" id="list" class="sp_list" value="000" />
    
    											<p name="firstname">
    															<label for="firstname">First Name:</label>
    														<input type="text" class="sp_firstname" orig="First Name" value=""  name="sp_firstname" />
    						</p>
    
    											<p name="lastname">
    															<label for="lastname">Last Name:</label>
    														<input type="text" class="sp_lastname" orig="Last Name" value="" name="sp_lastname" />
    						</p>
    
    					<p name="email">
    													<label for="email">E-Mail:</label>
    												<input type="text" class="sp_email" orig="E-Mail" value="" name="sp_email" />
    					</p>
    
    					<p class="submit">
    						<input value="Submit" class="sendpress-submit" type="submit"  id="submit" name="submit">

    Also in another form (on this page http://www.fantasyleaguechampion.com/index.php/category/blog/nfl/) that uses the WordPress generated widget, I'm getting this error after submission:

    500 - Internal server error.
    There is a problem with the resource you are looking for, and it cannot be displayed.

    The emails are saved but the Thank you page is not showing up.

    I greatly appreciate your help! Thank you so much!

  4. Josh Lyford
    Member
    Plugin Author

    Posted 10 months ago #

    HI,

    Do you have access to your error logs? i am not sure where the code is having a problem and could not recreate it on our server. If you could somehow get the php error log that may help find the problem.

    Best,
    Josh

  5. Josh Lyford
    Member
    Plugin Author

    Posted 10 months ago #

    Also it looks like the permalinks are not working for the link and manage page. You should be able to fix that with these directions.

    http://sendpress.com/support/knowledgebase/emails-and-links-showing-404-page/

    Josh

  6. avbyrin
    Member
    Posted 10 months ago #

    I'll take a look at the directions.

    How do I get the PHP logs (sorry - I'm a newbie)

    Thanks.

  7. itdoug
    Member
    Plugin Author

    Posted 10 months ago #

    What are you running for your server? Cpanel? It's different for all systems. If you haven't control panel there should be a logs section.

  8. avbyrin
    Member
    Posted 10 months ago #

    I have the log now. What should I be looking for? There don't seem to be explicit errors in it.

    Josh - The permalinks are already in date/name format but I re-saved it to see if it made a difference.

  9. Josh Lyford
    Member
    Plugin Author

    Posted 9 months ago #

    hi avbyrin,

    if you could email the log to me josh@sendpress.com i will look over it. Also how did you get the index.php in the url? is the in your settings? I think this might be the issue i am trying to setup a place to test it on our system.

    http://www.fantasyleaguechampion.com/index.php/what-is-football-pool/

    Best,
    Josh

Reply

You must log in to post.

About this Plugin

About this Topic