WordPress.org

Ready to get started?Download WordPress

Forums

Links work in IE, but not in Firefox (16 posts)

  1. guided
    Member
    Posted 5 years ago #

    I have a cross-browser problem on shosholozashanghai.com:

    Outbound links are active, i.e. clickable, in IE, but not in Firefox. I can't think of why? It might be the result of interference from a plugin? The links have some extra code in them. For example:

    <a href="http://www.winelink.com.cn/en" onclick="javascript:pageTracker._trackPageview('/outgoing/www.winelink.com.cn/en');">www.winelink.com.cn/en</a>

    The best place to go, if you're kind enough to help, is http://shosholozashanghai.com/shanghai-living/.

    Much appreciated,
    Iain

  2. guided
    Member
    Posted 5 years ago #

    The links seem to work for that fraction of a second before a page loads completely. Might that point to the source of my problem?

  3. It's probably your javascript page tracker. I have no idea if that code is right, but it doesn't seem to be FF friendly.

  4. guided
    Member
    Posted 5 years ago #

    It's not the javascript. I've disabled the tracking of outgoing links, and checked to page source. The javascript is gone, but the links still aren't working.

  5. There's also this in your source:

    <p><!--[if gte mso 9]><xml> Normal   0         false   false   false                                 MicrosoftInternetExplorer4 </xml><![endif]--><!--[if gte mso 9]><xml> </xml><![endif]--><!--[if !mso]><span class="mceItemObject"   classid="clsid:38481807-CA0E-42D2-BF39-B33AF135CC4D" id=ieooui></span></p>
    <style>
    st1\:*{behavior:url(#ieooui) }
    </style>
    <p><![endif]--> <!--[if gte mso 10]></p>
    <style>
     /* Style Definitions */
     table.MsoNormalTable
    	{mso-style-name:"Table Normal";
    	mso-tstyle-rowband-size:0;
    	mso-tstyle-colband-size:0;
    	mso-style-noshow:yes;
    	mso-style-parent:"";
    	mso-padding-alt:0in 5.4pt 0in 5.4pt;
    	mso-para-margin:0in;
    	mso-para-margin-bottom:.0001pt;
    	mso-pagination:widow-orphan;
    	font-size:10.0pt;
    	font-family:"Times New Roman";
    	mso-ansi-language:#0400;
    	mso-fareast-language:#0400;
    	mso-bidi-language:#0400;}
    </style>
    <p><![endif]--></p>

    At a guess, you wrote this is Word and pasted it in?

    Seeing as your site is fine on this post Hello World, I'm gonna blame MS Office.

  6. guided
    Member
    Posted 5 years ago #

    Aahhh... That might be it. I didn't write that page -- I'm working on this for a friend -- and wouldn't have thought of that. Thanks a lot.

  7. lifestyler
    Member
    Posted 5 years ago #

    Your friend installed the google analytics plugin for wordpress. By default it doesnt track the admin user! I had the same problem you had and that was because i was logged in as admin (with that same link structure you showed in your first post in my posts) but because the plugin aint working for me as admin i couldnt click the links cause it gave javascript errors. Best is set the google analytics plugin in settings to track admin also (default is not to do that).

    The code posted above here came from MS Word. Tell your friend to use the 'paste-from-word' button in the wysiwig editor

    hope it helps you!

    btw the links work fine for me...

  8. guided
    Member
    Posted 5 years ago #

    The links still aren't working -- and my woes have been added to. The NextGen Gallery, at http://shosholozashanghai.com/photo-gallery/, also works better in IE than in Firefox. The album fronts flicker when hovered in Firefox, and are very difficult to click through on. But they're fin in IE.

    This might have something to do with the theme. It's slaty reloaded -- I've modified it a little, and I'm very pleased with the results (though they're not completely done) -- but the problems might go deeper than my very limited knowledge of CSS and the differences between IE and Firefox go!

    Can anyone suggest a fix? The only other option is finding a much simpler theme and starting again, which would be very disappointing.

    Thanks in advance,
    Iain

  9. iridiax
    Member
    Posted 5 years ago #

    Your theme has image hover effects that appear to conflict with your gallery display in Firefox.

    In general, I'd recommend testing a theme with various browsers, monitor sizes, and plugins before spending much time customizing it.

  10. guided
    Member
    Posted 5 years ago #

    Might this be something to with the way Firefox is reading the output of page.php? Links in the sidebar are okay...

  11. guided
    Member
    Posted 5 years ago #

    I've tried to add the option of sunscribing to a newsletter here and had the same problem! I can't even click into the form!

    Please help!

  12. iridiax
    Member
    Posted 5 years ago #

    Try switching to the default theme and see if the problems go away. If they do, then it's a problem with your theme.

  13. guided
    Member
    Posted 5 years ago #

    It is a problem with my theme. Anyone know where I should look?

  14. iridiax
    Member
    Posted 5 years ago #

    You can edit your theme and remove the img hover and focus css (in style.css) and javascript (in .js files). I don't know what all is going on with your theme, but this script shows up in my Firefox:

    http://shosholozashanghai.com/wp-content/themes/slaty-reloaded-09/modern.js

    The other option would be to find a new theme.

  15. guided
    Member
    Posted 5 years ago #

    Thanks Iridiax,

    I've tried removing the hover and focus codes. No luck! I also deleted the .js file. That didn't work either.

    The problem only affects pages outside of the loop: I've added links and photos to a regular post (they're visible on the front page now), and those work well. So, again, links aren't clickable, and photos flicker -- but only in Firefox. Other than a few minor issues, the site does what it should in IE.

  16. guided
    Member
    Posted 5 years ago #

    *Anybody?*

Topic Closed

This topic has been closed to new replies.

About this Topic