WordPress.org

Ready to get started?Download WordPress

Forums

Social Media Widget
[resolved] Links without icons (2 posts)

  1. jml
    Member
    Posted 1 year ago #

    My custom icons will not display without an ftp/password url. I am only getting links without icons.

    This works (displays icons):
    URL: ftp://user:(ftp password)@www.mysite.com/public_html/blog/public_html/blog/wp-content/icons/vanilla/medium/32
    PATH: /home/site/public_html/blog/wp-content/icons/vanilla/medium/32

    This does not work (displays links only with no icons):
    URL: http://www.mysite.com/public_html/blog/public_html/blog/wp-content/icons/vanilla/medium/32
    PATH: /home/site/public_html/blog/wp-content/icons/vanilla/medium/32

    They are the same except for "http" rather than "ftp://user:(ftp password)@"

    I have tried this with the icons located directly in "/icons" without any subfolders but it does not seem to make a difference. It works both ways with the ftp URL, and gives only links without icons when using the http URL.

    Also tried using the media uploader and changing the URL/Path to wp-content/uploads/2013/03/ but I still get links only with no icons.

    What am I doing wrong?

    http://wordpress.org/extend/plugins/social-media-widget/

  2. jml
    Member
    Posted 1 year ago #

    Answering my own question in case someone else is having this problem.

    The path was correct but the URL was wrong, even though I was really, really sure it was right. I was copying the URL and Path from my ftp client, which was giving me an extra "public_html" in the URL. That was resulting in links with no icons.

    I noticed the error after trying the media uploader again and then looking at the URL of the icons in the "uploads" folder. Instead of "/public_html/blog/public_html/blog/wp-content/" the URLs were "/blog/public_html/blog/wp-content/".

    After I removed the extra "public_html" from the URL to the icons folder it looked like this:
    http://www.mysite.com/blog/public_html/blog/wp-content/icons/vanillaLatte/medium/32x32/

    No change to the path because that part was already correct. Now it works.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.