WordPress.org

Ready to get started?Download WordPress

Forums

Links Updated Time incorrect (12 posts)

  1. Nick Momrik
    Member
    Posted 10 years ago #

    I have the links updated showing, but the time I have set is not working correctly. I have the time set to 6 hours (720) in the options.
    On my blog I have a link that was updated at 11:26a.m. and it's now 8:12p.m. and still showing as updated.
    Any ideas? Thanks!

  2. Nick Momrik
    Member
    Posted 10 years ago #

    I should also note that I have weblogs_cacheminutes set to 15.

  3. Nick Momrik
    Member
    Posted 10 years ago #

    From what I've been able to decipher from the code, it looks as if the problem lies in the fact that whatever time weblogs.com uses for updates is compared against the current time on the server. An offset is never accounted for.

  4. Nick Momrik
    Member
    Posted 10 years ago #

    Also, the "Last Updated" title tag is using the incorrect time.

  5. philor
    Member
    Posted 10 years ago #

    That'll do until something annoying to debug comes along. I'd forgotten that if you hit changes.xml more than three times in an hour, you get a 503 Service Unavailable back (and if your blog is on a shared host with one IP for 200 WP-powered blogs, good luck ever getting to it). Not that that's your problem, since you've got a nice fresh weblogs.com.cache, but it's sure slowing down my debugging the date thing.

  6. Nick Momrik
    Member
    Posted 10 years ago #

    What'll do?

  7. philor
    Member
    Posted 10 years ago #

    "A problem that involves wanting to run links-update-xml.php more than three times in an hour while trying to debug it" - just saying "I'm looking, but not very fast, since I got myself banned from grabbing updates, which is slowing me down."
    Though you might want to switch to something more than a 20 minute interval. You can grab shortChanges.xml more than three times an hour, but since it only does 5 minutes worth, you'd need to grab it from a cron job more often than that to not miss things. A 15 minute cache interval should mean that you get it three times in 45 minutes, then have to wait either 15 minutes or an hour before you can get it three times in 45 minutes again depending on how he does the ban.

  8. Nick Momrik
    Member
    Posted 10 years ago #

    Oh, I can change it to 20 minutes, no problem, I didn't realize there was a minimum. That's not the problem anyways...
    The problem is in the way WP stores the time it gets from weblogs.com. If you look at the values for the link_updated field in the wp_links table, the times are not in relation to all of the other dates/times stored in the database, unless you happen to be in the same time zone that they use for their times. When the "Last Updated" title is displayed, it adds the server offset to this incorrect time. I've modified my links-update-xml.php file to store the dates and times with an offest for the time being, but I believe there needs to be a new setting in the options so that this can be done automatically.

  9. philor
    Member
    Posted 10 years ago #

    Yep, I seem to have lost the ability to read a simple statement of a problem, so for the third time today I was chasing after the wrong bug in the wrong place. I think maybe I'll just go throw rocks at boys for a while.

  10. Nick Momrik
    Member
    Posted 10 years ago #

    Sorry I didn't clarify the best. :-/
    I'm going to put on my hardhat cuz I don't feel like getting hit by a rock! :-P

  11. Nick Momrik
    Member
    Posted 10 years ago #

    Developers?

  12. Nick Momrik
    Member
    Posted 10 years ago #

    Maybe a better solution would be to store all of the dates in relation to the dates used by Weblogs.com and then have a single time offset.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.