WordPress.org

Ready to get started?Download WordPress

Forums

WP eCommerce
[resolved] links to pages not working (10 posts)

  1. magicmummy
    Member
    Posted 1 year ago #

    wpec version: 3.8.11.1

    having performed an upgrade from: 3.8.7.6.2

    links to pages in the menu no longer work ".../your-basket/kit-shop" pulls up a blank page , not the 404 page.

    when i create a new page their urls don't work either.

    any help here would be massively appreciated!

    http://wordpress.org/extend/plugins/wp-e-commerce/

  2. magicmummy
    Member
    Posted 1 year ago #

    looking at debug mode I am getting error:
    "Notice: Trying to get property of non-object in"

    This error is given for the following files:
    query.php
    post-template.php

  3. bobspalding
    Member
    Posted 1 year ago #

    What it your pamerlink structure set to? Sometimes setting back to default then saving then re-setting it to your structure can fix this issue, commonly I have found the structure actually effects the appearance of the 404 page aswell.

  4. magicmummy
    Member
    Posted 1 year ago #

    hey, thanks for replying, yes it seems to work if Iset it to default but once i set it to cusom or even post name its back to the same problem.

  5. bobspalding
    Member
    Posted 1 year ago #

    Right, it sounds like you may need to set the pamalink structure manually using the SQL database, before you do though, lets be clear, are the pages not working actual wordpress pages or wp-e-commerce pages such as a product page?

  6. magicmummy
    Member
    Posted 1 year ago #

    ok, yes definitely a wordpress page NOT a wpec product page.

  7. bobspalding
    Member
    Posted 1 year ago #

    What theme are you using sorry?

  8. bobspalding
    Member
    Posted 1 year ago #

    This might be of some use if WP-E-Commerce is not to blame:
    http://wordpress.org/support/topic/page-not-found-after-changing-permalink-to-postname?replies=15

    As a diagnostic step you may want to try disabling the plugin and then trying a page, see if there is a conflict.

  9. magicmummy
    Member
    Posted 1 year ago #

    wow thanks! pointed me in the right direction. You were right it was a problem with worpdress itself not wpec. I removed the .htaccess file and then saved my permalinks settings again, hey presto!

    Marvellous thank you!

  10. bobspalding
    Member
    Posted 1 year ago #

    No worries, glad I could help

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic