WordPress.org

Ready to get started?Download WordPress

Forums

Links to pages & categories from images are not working (3 posts)

  1. uobeats
    Member
    Posted 7 months ago #

    Hi there,

    Some of my internal links from images to pages and categories are not working. I am fairly sure my permalinks are correct and my code is also.

    This is the part of my site I am referring to - http://uobeats.com/ideas-thoughts/

    Some of the images are linking to the specific categories, but some are not, even though the code is the same. It doesn't make sense to me.

    Any help/feedback would be appreciated.

    Thanks, UOBEATS

  2. Chris Hardin
    Member
    Posted 7 months ago #

    The reason it is working on some and not others is you actually have content for the categories that do work. You are getting Not Found Sorry about that! Try the search bar if you can't find what you're looking for this way... for the ones that don't have content associated to the category. This is the default behavior of WordPress. Just add a post to the categories that you don't have a post for and you wont get the error.

  3. uobeats
    Member
    Posted 7 months ago #

    Thanks for your quick response, much appreciated.

    However, I do have posts in all of these categories, for example, here is the link to the 'music related' category - http://uobeats.com/category-music-related/ - which does not link from the picture here - http://uobeats.com/ideas-thoughts/ ...It seems to be working for some and not others.

Reply

You must log in to post.

About this Topic