WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Links to Pages are Broken (6 posts)

  1. RosieMBanks
    Member
    Posted 9 years ago #

    I'm having a problem with the static Pages and can't find anything in the Codex about it.

    I created five static Pages and they worked fine. Should've left well enough alone! But then I realized they weren't in the order I wanted and went to the admin panel and changed the page number on each.

    After that, clicking on the pages got me an error message that the page did not exist. So I tried to reset all the page numbers back to zero, but still got the 404 error message whenever I clicked on the Pages.

    Then I said to hell with it and deleted the pages. I recreated them, this time in the order I wanted. But now no matter what I do, clicking on these pages gives me an error message. It's as if I've broken the ability to do static Pages.

    Now I have only one page, "About" which I created after again deleting all previously created pages. There should be text that says "bla, bla, bla" (I am so creative) but all I get is an error page.

    Please tell me what I'm doing to mess this up!

  2. Kafkaesqui

    Posted 9 years ago #

    If you're using custom permalinks, this may be the cause/fix:

    http://wordpress.org/support/topic.php?id=24402

  3. RosieMBanks
    Member
    Posted 9 years ago #

    Thanks Kafkaesqui, but I did as suggested and the Pages links are still broken. And now I just noticed that my category and archive links are also broken.

    I'm about ready to delete the whole thing and start all over again.

    I found this thread, too, the problem is kinda similar:
    http://wordpress.org/support/topic.php?id=26531

    The only thing working on my page now is the homepage--everything worked before. Even trying the links from Manage --> Posts --> View --> brings up the 404 page.

  4. Kafkaesqui

    Posted 9 years ago #

    Sorry to hear you hit such a pothole. If you continue having problems, maybe a try at Ryan's new plugin would help things:

    http://boren.nu/archives/2005/03/07/reduced-rewrite-plugin/

  5. korty
    Member
    Posted 9 years ago #

    I had the same problem. I just deleted the .htaccess file and it was made new by updating the 'permalink structure'. The only thing that took some time was to recognize, that it wasn't the .htaccess in the weblog-directory. It was the one in the parent directory!?!

  6. RosieMBanks
    Member
    Posted 9 years ago #

    Okay, I checked with my web host to make sure my mod_write was enabled (it is). Then I went back to the default permalink structure, disposed of the htaccess file, updated the default permalink structure again, and now the links work.

    When I tried to fiddle with the structure of the permalinks, it messes everything up. I tried using this format:

    /%year%/%monthnum%/%day%/%postname%/

    and this format:
    archives/%year%/%monthnum%/%day%/%postname%/

    But both mess everything up. Is my structure incorrect?

    If they are correct, does this mean I am stuck with the default structure? I mean, I can live with it, no problem. But still.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.