WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Links to own posts don't work once new post is published (5 posts)

  1. jonchacon
    Member
    Posted 1 year ago #

    Hey All,

    When ever I link older posts to new posts the links do not work once published.

    When using the editor I can see the linked word(s) highlighted and when I run the cursor over it the "pointing finger" icon shows up and the word is "clickable" and the link to the older post displays properly.

    However, once that new post is published the linked word is no longer a link. In other words, I run my cursor over it and nothing happens. The word does not change color or even provide a description when I run the cursor over it. You would never know it is a linked word.

    For instance, if you go to my homepage at http://www.jonchacon.com and read scroll down to the latest post, the word "variety" is a word that I linked in the editor, but it doesn't work on the site. (The word "variety" is located on the 7th line down from the first picture in the post "1 Uncommon Method for Increasing the Deadlift."

    The link to the older post is supposed to be The 1 Thing Stalling Your Progress in the Gym

    Any help is much appreciated.

    Thanks,

    Jon

  2. alchymyth
    The Sweeper & Moderator
    Posted 1 year ago #

    the problem is caused by the facebook like plugin which outputs a iframe 1000px high which is layering over the links and covering them.

    possibly post in the plugin's direct support forum.

  3. jonchacon
    Member
    Posted 1 year ago #

    Hi Alchymyth,

    Thank you for the help. I went ahead and just deactivated the plugin and it worked. I have another social media plugin anyways.

    Another question though, for the linked word, how do I make it appear a different color, such as a light blue, so that it looks "clickable" to the post viewer?

    Thanks,

    Jon

  4. alchymyth
    The Sweeper & Moderator
    Posted 1 year ago #

    for the linked word, how do I make it appear a different color, such as a light blue, so that it looks "clickable" to the post viewer?

    try to use a browser inspection tool (such as Firebug) to find out which style is formatting the links;
    then use css to change the link colors; http://www.w3schools.com/css/css_link.asp

    in your case, possibly make new styles to format the links; this would make it specific only for the post content area;

    example:

    .post .entry a { color: blue; }
    .post .entry a:visited { color: green; }
    .post .entry a:hover { color: purple; text-decoration : underline; }

    for real color codes, see for instance http://en.wikipedia.org/wiki/Web_colors

    no idea how your theme 'graphene' deals with custom css;
    you might simply need to add these styles to the end of style.css

  5. jonchacon
    Member
    Posted 1 year ago #

    Thank you so much for the help. I will give this a shot.

    Take care,

    Jon

Topic Closed

This topic has been closed to new replies.

About this Topic