WordPress.org

Ready to get started?Download WordPress

Forums

Links to Category, Posts & Archives not working (weird) (10 posts)

  1. Thura
    Member
    Posted 7 years ago #

    My blog is http://www.topofmindblog.com

    I have had this problem before, but it went away after I reinstalled WP a year back, and now it's back - suddenly. Please note that no changes were made prior.. I just realized one day when I was looking around that none of my links were working.

    For example the address bar would show http://topofmindblog.com/2007/06/17/top-48-things-i-learned-from-watching-lost/
    but the actual page displayed will be the home page. Same with the category as well.

    From past experience and checking out the http://codex.wordpress.org/Using_Permalinks I checked if my .htaccess is at 666, then updated the permalinks. But still not working.

    Weired thing is that at default Permalink STructure both the category and post links work, but when I change it back to my Pretty Permalink "Date & Name." it stops working.

    Now I have not seen any problems in the forums and at a loss. I mean I can keep the Permalinks at default, but then I will lose all the outside links and as teh WP forum says "p=61" is UGLY!!

    Help.

  2. omgitztrey
    Member
    Posted 7 years ago #

    First off you won't lose any link as long as the pretty structure wasn't changed.

    secondly, can you post the permalink stucture you were working with?

  3. Thura
    Member
    Posted 7 years ago #

    That's the the thing. I didn't change the structure. It 'just' happened one day. Since I was overdue for a upgrade, I decided to do the upgrade hoping that it will fix the problem. It didn't.

    The structure I am using is Date and Name Based format - http://topofmindblog.com/2007/06/23/movie-review-pirates-of-the-caribbean-at-worlds-end/ see above. But even though the address bar shows the correct address, the page on display is the home page.

  4. Chris_K
    Member
    Posted 7 years ago #

    Visit Options -> Permalinks. At the bottom of the page, are there any messages about manually adding stuff to .htaccess?

    Don't change anything, just re-save what you have.

    Lots more troubleshooting at the Permalinks page in the codex.

  5. Thura
    Member
    Posted 7 years ago #

    At the bottom of the Permalinkk page is the following, but nothing on .htaccess..

    Optional

    If you like, you may enter a custom prefix for your category URLs here. For example, /taxonomy/tags would make your category links like http://example.org/taxonomy/tags/uncategorized/. If you leave this blank the default will be used

    Then I see a box that says Category Base.

  6. Chris_K
    Member
    Posted 7 years ago #

    Ok. The message I was looking for would've been below that. I reckon that would imply that WP can write to your .htaccess (it'll tell you if it can't at the bottom of the permalinks page). That's a good thing.

    So, while there did you re-save your permalinks as suggested?
    Anything change?
    What's in your .htaccess file?

  7. Thura
    Member
    Posted 7 years ago #

    Firstly thanks for trying to help, really appreciate it. OK, there was nothing below that and I have set my .htaccess to 666 through Filezilla so WP should be able to write to that.

    I tried resaving, but still not working. But when I change to Default Parmalink system - the one with the 'p=123,' it works. Weird.

    Anyway, this is what I have in .htaccess..

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

  8. Chris_K
    Member
    Posted 7 years ago #

    But when I change to Default Parmalink system - the one with the 'p=123,' it works. Weird.

    Not too weird. That's the default style and the lowest common denominator. That format always works. :-)

    Has your host made any changes/upgrades recently? You might confirm that mod_rewrite and AllowOverrides are still both on and enabled for your site.

  9. Thura
    Member
    Posted 7 years ago #

    I am contacting my host to check, but it seems that both are enabled.

  10. Thura
    Member
    Posted 6 years ago #

    Handy - thanks so much. It is working now.

    My host confirmed that both are enabled and pointed me to a link with the following .htaccess. I am posting it here because I have seen other users with similar problems and all I did was cut and pate it. Obviously it wiped out whatever settings I had before, but that can be fixed over time.

    You guys are great!

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_URI} !index.php
    RewriteRule (.*) /index.php/$1 [L]
    </IfModule>

    # END WordPress

Topic Closed

This topic has been closed to new replies.

About this Topic