WordPress.org

Ready to get started?Download WordPress

Forums

Links Problem (examplesite.comcategory) (4 posts)

  1. compL33Tazn
    Member
    Posted 4 years ago #

    Hello, I am new to WordPress and I have a slight problem with the links. My links are missing a slash after the root, so they show up as examplesite.comcategory How can I fix this?

  2. compL33Tazn
    Member
    Posted 4 years ago #

    Anyone?

  3. lisaa610
    Member
    Posted 4 years ago #

    I am having the same problem @ http://geneticbonds.com. I can't figure it out either.

  4. lisaa610
    Member
    Posted 4 years ago #

    I think I just figured it out. My website was showing up as http://geneticbonds.comcategory instead of http://geneticbonds.com/category. My Catgory Base was "category" and my permalink structure was /%postname%/

    So if you are here because you are having the same problem with categories showing up with the '404 Error' you need to adjust the permalink structure in the Settings → Permalinks panel (Options → Permalinks before WordPress 2.5). According to Codex - Using Permalinks, "%category% - A sanitized version of the category name (category slug field on New/Edit Category panel). Nested sub-categories appear as nested directories in the URI. Starting Permalinks with %category% is strongly not recommended for performance reasons." I am new to wordpress, and not sure if %category% is the same as /%category%/, but using either /%category%/%category%/%postname%/ on the permalinks or /%category%/%page%/%postname%/ seemed to correct this issue for me.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags