WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Links on website still pointing to localhost (12 posts)

  1. swingz2012
    Member
    Posted 3 years ago #

    When clicking on one of my products on my page, it says "cannot connect to localhost" when in fact I am using godaddy.com as my host. I'm sure there has been someone else with this problem but I have viewed From localhost to webserver and tried everything they said on there being it changing the actual option values in the home and changing the siteurl but still the links think they are supposed to go to localhost. I am beginning to think that this is a problem in one of my scripts. Your help is greatly appreciated!!!

  2. jeezyo
    Member
    Posted 3 years ago #

    Try this: Go to this link, http://help.godaddy.com/article/39 to learn how to determine your databases host name. Once you've got that, go into the wp-config.php file in the root of your install, look for define('DB_HOST', 'localhost'); and change localhost to the name you got in the previous step.

  3. swingz2012
    Member
    Posted 3 years ago #

    Thanks jeezyo I'll give it a try!

  4. swingz2012
    Member
    Posted 3 years ago #

    I gave this a try and it seems that it's already set to my host. so why are the links on the site saying cannot connect to localhost? here's a link to my site
    Swingz Hookah Shop

  5. esmi
    Theme Diva & Forum Moderator
    Posted 3 years ago #

  6. swingz2012
    Member
    Posted 3 years ago #

    This is what I found when I searched all:
    159 0 product_list_url http://localhost/wordpress/?page_id=4 yes

    160 0 shopping_cart_url http://localhost/wordpress/?page_id=5 yes

    161 0 checkout_url http://localhost/wordpress/?page_id=5 yes

    162 0 transact_url http://localhost/wordpress/?page_id=6 yes

    199 0 user_account_url http://localhost/wordpress/?page_id=7

    These all have localhost in them but how do i change them to my server so they actually show the page?

  7. esmi
    Theme Diva & Forum Moderator
    Posted 3 years ago #

    You need to change the links - not your server settings.

  8. swingz2012
    Member
    Posted 3 years ago #

    Do i change them to the actual pages or just change them to my website instead of it being http://localhost change it to http://swingzhookahshop ???

  9. esmi
    Theme Diva & Forum Moderator
    Posted 3 years ago #

    Change them to the actual page urls.

  10. swingz2012
    Member
    Posted 3 years ago #

    another question, how do I find the actual page url? are they in my database in the pages directory or do I have to grab it by clicking the products themselves?

  11. esmi
    Theme Diva & Forum Moderator
    Posted 3 years ago #

    The easiest method would be to navigate to the individual products themselves and copy the urls.

  12. swingz2012
    Member
    Posted 3 years ago #

    YOU ROCK ESMI! the problem is fixed!

Topic Closed

This topic has been closed to new replies.

About this Topic