WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Links on my site don't work in IE8 and under! (6 posts)

  1. Phil Meyer
    Member
    Posted 3 years ago #

    I created this site: http://fortifood.co.za at a different location and then transferred it to it's current location. I checked it's compatibility with Firefox, Chrome and IE9, and all was honky-dory... until my client called me and asked why his site wasn't working.

    He said he was using IE8 (which - we have to face the facts - most uninformed Internet users are probably using) and, apart from the "Visit the shop" link in the right column, not a single link on the page was working (including the menu items).

    So I tested the site in IE8 and true's nuts, it's exactly as he said... in fact, you can't even select the text or images - it's as if there's an invisible layer over the entire site!

    This is obviously not a very happy situation, but I'm buggered if I can figure out how to fix it. Does anyone have an idea?

    Phil

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    Start by sorting out the markup errors. Then move onto the CSS errors.
    http://codex.wordpress.org/Validating_a_Website
    If you continue to have problems with IE, consider conditional comment CSS

  3. Phil Meyer
    Member
    Posted 3 years ago #

    WOW... thanks esmi!

    Phil

  4. Phil Meyer
    Member
    Posted 3 years ago #

    Hey Esmi, would you perhaps be willing to fix it for me (depending on your fee, of course). I'm not much of a programmer and I'm a little stumped here.

  5. esmi
    Forum Moderator
    Posted 3 years ago #

    If you need to contact me privately, please see http://wordpress.org/support/profile/esmi

  6. Phil Meyer
    Member
    Posted 3 years ago #

    Incredibly a friend of mine managed to fix it! Thanks anyway for for being prepared to help, much appreciated.

Topic Closed

This topic has been closed to new replies.

About this Topic